

























  












	


























  











  
  
  	
  

  
  

  
  
  
  
  







  


























  





<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">




                 








  
    
  

























  











  
  
  	
    	


























  










 
  
  
    




  



    
  

  
  

  
  
  
  
  



































  











  
  

  
  

  
  
    
  
  
  
  




<html>
    <head>
        

























  









<!--Janrain SSO JavaScripts -->


<!-- Script added to resolve JS error coming on IE-8 for Janrain login -->
<script>
	document.getElementsByClassName = 
	Element.prototype.getElementsByClassName = function(class_names) {
		// Turn input in a string, prefix space for later space-dot substitution
		class_names = (' ' + class_names)
			// Escape special characters
			.replace(/[~!@$%^&*()_+\-=,./';:"?><[\]{}|`#]/g, '\$&')
			// Normalize whitespace, right-trim
			.replace(/\s*(\s|$)/g, '$1')
			// Replace spaces with dots for querySelectorAll
			.replace(/\s/g, '.');
		return this.querySelectorAll(class_names);
	};
</script>



  
  
    
      
    
  


<meta name="SKYPE_TOOLBAR" content="SKYPE_TOOLBAR_PARSER_COMPATIBLE" />

<META http-equiv="Content-Type" content="text/html; charset=UTF-8">



  
     
	        <meta content="15137500430" property="fb:page_id"/>
  <meta content="141300433,549810759" property="fb:admins"/>
  <meta content="http://covers.oreilly.com/images/0636920046158/bkt.gif" property="og:image"/>
  <meta content="book" property="og:type"/>
  <meta content="0636920046158" property="og:isbn"/>
  <meta content="http://shop.oreilly.com/product/0636920046158.do" property="og:url"/>
  <meta content="SQL and Relational Theory" property="og:title"/>
  <meta name="twitter:card" content="summary"/>
  <meta name="twitter:url" content="http://shop.oreilly.com/product/0636920046158.do"/>
  <meta name="twitter:title" content="SQL and Relational Theory"/>
  <meta name="twitter:description" content="SQL is full of difficulties and traps for the unwary. You can avoid them if you understand relational theory, but only if you know how to put that theory into practice. In this book, Chris Date exp..."/>
  <meta name="twitter:image" content="https://akamaicovers.oreilly.com/images/0636920046158/cat.gif"/>
  <meta name="twitter:site" content="OReillyMedia"/>
  <meta name="book_title" content="SQL and Relational Theory"/>
  <meta name="mobileurl" content="http://shop.oreilly.com/product/mobile/0636920046158.do"/>
  <meta name="subtitle" content="How to Write Accurate SQL Code"/>
  <meta name="author" content="C.J. Date"/>
  <meta name="publisher" content="O'Reilly Media"/>
  <meta name="graphic_large" content="https://akamaicovers.oreilly.com/images/0636920046158/cat.gif"/>
  <meta name="graphic_medium" content="https://akamaicovers.oreilly.com/images/0636920046158/bkt.gif"/>
  <meta name="graphic" content="https://akamaicovers.oreilly.com/images/0636920046158/sm.gif"/>
  <meta name="target" content="SQL and Relational Theory, 1491941170, 1-4919-4117-0, 9781491941171, 978-1-4919-4117-1"/>
  <meta name="keywords" content="SQL and Relational Theory, , 1-4919-4117-0, 1491941170, 9781491941171, 978-1-4919-4117-1, C.J. Date,oreilly, O'Reilly, o'reilly"/>
  <meta name="description" content="SQL is full of difficulties and traps for the unwary. You can avoid them if you understand relational theory, but only if you know how to put that theory into practice. In this book, Chris Date explains relational theory in depth, and demonstrates..."/>
  <meta name="date" content="Nov. 06, 2015"/>
  <meta name="search_date" content="2015-11-06"/>
  <meta name="ean" content="9781491941171"/>
  <meta name="search_isbn" content="0636920046158"/>
  <meta name="Category" content="Books"/>
  <meta name="SubCategory" content="Format~Format~Format~Publisher"/>
  <meta name="SubCategory_Value" content="Print~Ebook~Safari Books Online~O'Reilly Media"/>
  <meta name="Format" content="Print~Ebook~Safari Books Online~"/>
  <meta name="status" content="100"/>
  <meta name="edition" content="3"/>
  <meta name="edition_full" content="3rd Edition"/>
  <meta name="bookeditionsorder" content="1st Edition,2nd Edition,3rd Edition"/>
  <meta name="bookeditionsreference" content="9780596523084,0636920022879,0636920046158"/>
  <meta name="book.tags" content="oreilly,"/>
  <meta name="object.type" content="book"/>
  <meta name="book.title" content="SQL and Relational Theory"/>
  <meta name="book.author" content="C.J. Date"/>
  <meta name="book.isbn" content="9781491941171"/>
  <meta name="book.link" content="http://shop.oreilly.com/product/0636920046158.do"/>
  <meta name="book.image" content="http://covers.oreilly.com/images/0636920046158/bkt.gif"/>
  <meta name="book.year" content="2015"/>
  <meta name="language_name" content="English"/>
  <meta name="native_language_name" content="English"/>
	
  
  


<title>SQL and Relational Theory, 3rd Edition&nbsp;-&nbsp;O'Reilly Media</title>


  
  
        
  




  
  
        
  






  <link rel="canonical" href="http://shop.oreilly.com/product/0636920046158.do"/>

<script type="text/javascript">var _sf_startpt=(new Date()).getTime()</script>
<script type="text/javascript" src="/includes/jquery/jquery-1.4.min.js"></script>
<script type="text/javascript" src="/includes/jquery/plugins/jquery.hoverIntent.minified.js"></script>
<script type="text/javascript" src="/includes/jquery/plugins/jquery.bgiframe.min.js"></script>
<script type="text/javascript" src="/includes/jquery/plugins/jquery.popDown.js"></script>
<script type="text/javascript" src="/includes/jquery/plugins/jquery.autocomplete.js"></script>




<link href="/mod/productquickview/includes/themes/default.css" rel="stylesheet" type="text/css"></link>
<link href="/mod/productquickview/includes/themes/pqv.css" rel="stylesheet" type="text/css"></link>

<!-- Start Visual Website Optimizer Asynchronous Code -->
<script type='text/javascript'>
var _vwo_code=(function(){
var account_id=27087,
settings_tolerance=2000,
library_tolerance=1500,
use_existing_jquery=false,
// DO NOT EDIT BELOW THIS LINE
f=false,d=document;return{use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&r='+Math.random());var a=d.createElement('style'),b='body{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);return settings_timer;}};}());_vwo_settings_timer=_vwo_code.init();
</script>
<!-- End Visual Website Optimizer Asynchronous Code -->
        

























  











  
  

  
  
    <LINK REL="stylesheet" TYPE="text/css" HREF="/includes/stylesheet.css" TITLE="style" />
  

  
  
  
  
  



        
<script type="text/javascript">window.NREUM||(NREUM={}),__nr_require=function(e,n,t){function r(t){if(!n[t]){var o=n[t]={exports:{}};e[t][0].call(o.exports,function(n){var o=e[t][1][n];return r(o||n)},o,o.exports)}return n[t].exports}if("function"==typeof __nr_require)return __nr_require;for(var o=0;o<t.length;o++)r(t[o]);return r}({1:[function(e,n,t){function r(){}function o(e,n,t){return function(){return i(e,[c.now()].concat(u(arguments)),n?null:this,t),n?void 0:this}}var i=e("handle"),a=e(2),u=e(3),f=e("ee").get("tracer"),c=e("loader"),s=NREUM;"undefined"==typeof window.newrelic&&(newrelic=s);var p=["setPageViewName","setCustomAttribute","setErrorHandler","finished","addToTrace","inlineHit","addRelease"],d="api-",l=d+"ixn-";a(p,function(e,n){s[n]=o(d+n,!0,"api")}),s.addPageAction=o(d+"addPageAction",!0),s.setCurrentRouteName=o(d+"routeName",!0),n.exports=newrelic,s.interaction=function(){return(new r).get()};var m=r.prototype={createTracer:function(e,n){var t={},r=this,o="function"==typeof n;return i(l+"tracer",[c.now(),e,t],r),function(){if(f.emit((o?"":"no-")+"fn-start",[c.now(),r,o],t),o)try{return n.apply(this,arguments)}finally{f.emit("fn-end",[c.now()],t)}}}};a("setName,setAttribute,save,ignore,onEnd,getContext,end,get".split(","),function(e,n){m[n]=o(l+n)}),newrelic.noticeError=function(e){"string"==typeof e&&(e=new Error(e)),i("err",[e,c.now()])}},{}],2:[function(e,n,t){function r(e,n){var t=[],r="",i=0;for(r in e)o.call(e,r)&&(t[i]=n(r,e[r]),i+=1);return t}var o=Object.prototype.hasOwnProperty;n.exports=r},{}],3:[function(e,n,t){function r(e,n,t){n||(n=0),"undefined"==typeof t&&(t=e?e.length:0);for(var r=-1,o=t-n||0,i=Array(o<0?0:o);++r<o;)i[r]=e[n+r];return i}n.exports=r},{}],4:[function(e,n,t){n.exports={exists:"undefined"!=typeof window.performance&&window.performance.timing&&"undefined"!=typeof window.performance.timing.navigationStart}},{}],ee:[function(e,n,t){function r(){}function o(e){function n(e){return e&&e instanceof r?e:e?f(e,u,i):i()}function t(t,r,o,i){if(!d.aborted||i){e&&e(t,r,o);for(var a=n(o),u=m(t),f=u.length,c=0;c<f;c++)u[c].apply(a,r);var p=s[y[t]];return p&&p.push([b,t,r,a]),a}}function l(e,n){v[e]=m(e).concat(n)}function m(e){return v[e]||[]}function w(e){return p[e]=p[e]||o(t)}function g(e,n){c(e,function(e,t){n=n||"feature",y[t]=n,n in s||(s[n]=[])})}var v={},y={},b={on:l,emit:t,get:w,listeners:m,context:n,buffer:g,abort:a,aborted:!1};return b}function i(){return new r}function a(){(s.api||s.feature)&&(d.aborted=!0,s=d.backlog={})}var u="nr@context",f=e("gos"),c=e(2),s={},p={},d=n.exports=o();d.backlog=s},{}],gos:[function(e,n,t){function r(e,n,t){if(o.call(e,n))return e[n];var r=t();if(Object.defineProperty&&Object.keys)try{return Object.defineProperty(e,n,{value:r,writable:!0,enumerable:!1}),r}catch(i){}return e[n]=r,r}var o=Object.prototype.hasOwnProperty;n.exports=r},{}],handle:[function(e,n,t){function r(e,n,t,r){o.buffer([e],r),o.emit(e,n,t)}var o=e("ee").get("handle");n.exports=r,r.ee=o},{}],id:[function(e,n,t){function r(e){var n=typeof e;return!e||"object"!==n&&"function"!==n?-1:e===window?0:a(e,i,function(){return o++})}var o=1,i="nr@id",a=e("gos");n.exports=r},{}],loader:[function(e,n,t){function r(){if(!x++){var e=h.info=NREUM.info,n=d.getElementsByTagName("script")[0];if(setTimeout(s.abort,3e4),!(e&&e.licenseKey&&e.applicationID&&n))return s.abort();c(y,function(n,t){e[n]||(e[n]=t)}),f("mark",["onload",a()+h.offset],null,"api");var t=d.createElement("script");t.src="https://"+e.agent,n.parentNode.insertBefore(t,n)}}function o(){"complete"===d.readyState&&i()}function i(){f("mark",["domContent",a()+h.offset],null,"api")}function a(){return E.exists&&performance.now?Math.round(performance.now()):(u=Math.max((new Date).getTime(),u))-h.offset}var u=(new Date).getTime(),f=e("handle"),c=e(2),s=e("ee"),p=window,d=p.document,l="addEventListener",m="attachEvent",w=p.XMLHttpRequest,g=w&&w.prototype;NREUM.o={ST:setTimeout,CT:clearTimeout,XHR:w,REQ:p.Request,EV:p.Event,PR:p.Promise,MO:p.MutationObserver};var v=""+location,y={beacon:"bam.nr-data.net",errorBeacon:"bam.nr-data.net",agent:"js-agent.newrelic.com/nr-1026.min.js"},b=w&&g&&g[l]&&!/CriOS/.test(navigator.userAgent),h=n.exports={offset:u,now:a,origin:v,features:{},xhrWrappable:b};e(1),d[l]?(d[l]("DOMContentLoaded",i,!1),p[l]("load",r,!1)):(d[m]("onreadystatechange",o),p[m]("onload",r)),f("mark",["firstbyte",u],null,"api");var x=0,E=e(4)},{}]},{},["loader"]);</script><link rel="shortcut icon" href="/images/oreilly/en_us/shop_favicon_16x16.ico" type="image/vnd.microsoft.icon">
        <script type="text/javascript" src="/includes/headerScripts.js"></script>
        
		

























  





<!-- MyBuys libraries and style sheet - Place in <head> element -->
<link
  href="http://t.p.mybuys.com/css/mbstyles.css"
  type="text/css"
  rel="stylesheet"
  id="mybuysstyles">
<script
  type="text/javascript"
  src="http://t.p.mybuys.com/js/mybuys3.js">
</script>
<script
  type="text/javascript"
  src="http://t.p.mybuys.com/clients/OREILLY/js/setup.js">
</script>


<!-- End MyBuys libraries and style sheet -->
		

























  





<!-- Tracking pixel here -->

    </head>
<body class="main">


<script>var iPop_imagePath='/images/oreilly/en_us/';//use this image path along with the IPop.js</script>
<script src="/includes/lPop.js"></script>
<!-- removing duplicate autocomplete.js ORLY-634 -->
<div id="popdiv"></div>

<table width="990" border="0" cellpadding="0" cellspacing="0" class="mainLayoutTable">

  <tr>
    <td colspan="3" class=navheaderbg>
		  <div>

























  











  
  
  	
    	<!--TopNav Start-->


























  









<script type="text/javascript">
  function checkIfDefault(keyword) {
    var defaultSearchTerm = "Search";
    if(keyword==defaultSearchTerm) {
      return '';
    }
    else {
      return keyword;
    }
  }
</script>


























  











<div id="header" style="width:990px;">

	
	
	
		<div class="logo">
			<a href="http://shop.oreilly.com"><img src="/images/oreilly/en_us/global/globalnav/logo01.gif" border=0 alt="O'Reilly Media, Inc."></a>
		</div>
	



	<div class="tools">
		
		
		
		
		
			
				<p>
					
						
						
							<a href="https://members.oreilly.com/account/emedia" class="signInLinkmy">Your Account</a>
						
					
				</p>				
			
			
		
		
		


























  












<script  type="text/javascript">
jQuery(document).ready(function(){
	jQuery("#globalBasket").popDown({navLink:"/basket.do?nav=%2Fproduct%2Fid%2F148789&gc=1",navOverClass:"globalCartNavOver",closeDelay:300});
});
</script>


<div
	id="globalBasket"
	class="
		popDownWrapper
		globalCartWrapper
		"
	style="
		margin:2px 0px 0px 0px;
		width:239px;
		">

	<div class="popDownNav globalCartNav">

		<div class="globalCartBasketImg" style=""><img src=/images/oreilly/en_us/global/globalgraphics/basketicon.gif border=0 alt=Shopping Cart></div>
		<div class="globalCartBasketInfo" style="">
			<span class="navHeader">Shopping Cart</span>
			<span class="navQty">0 items</span> <span class="navTotal">$0.00</span>
		</div>
	</div>
	<div class="popDownLayer globalCartLayer" style="margin:3px 0px 0px 0px;">

		
		  
		  
			<div class="globalCartEmpty">Your shopping cart is empty.</div>
		  
		

	</div>
</div>


	</div>
				<!-- SP-2014-15990: Begin -->
				
				
				
				
					
				
					
				
					
				
					
				
					
				
					
				
					
				
				
				
				
				

			<div id="search-box" class="yui-skin-sam"> 
			<form name="searchform" method="get" id="search-form" action="https://ssearch.oreilly.com/">
			<div class="search"> 
			<fieldset> 
			<span id="search-input"> 
			<div class="searchInput"> 
			<span id="search-field"><input type="text" value="Search" name="q" value="" maxlength="64" id="q" onFocus="this.value=checkIfDefault(this.value);" /></span> 
			</div> 
			<span id="search-button">
			
				<input
					type="image"
					value="SEARCH"
					src="/images/oreilly/en_us/global/globalgraphics/search_btn.gif"
					border="0"
					style="float:left"
					alt="Search"
					align="top"/>
			 
			</span> 
			</span> 
			<div id="autocomplete"></div> 
			</fieldset> 
			</div> 
			</form> 
			</div> 
				
				
				
				<!-- SP-2014-15990: End -->

</div>




    
  

  
  

  
  
  
  
  


</div>
      <div>

























  











  
  
  	
    	


























  








    <div id="globalInclude" >
		<!-- csp/3201 in ncs was csp/3019 in ocs -->

<!-- Link to the core stylesheet -->
<link rel="stylesheet" type="text/css" href="//shop.oreilly.com/text/oreilly/ml-combined.css">


<style type="text/css">
#start-video-course-wrapper { display: none; }

/* table.mainLayoutTable > tbody > tr:nth-child(2) > td:nth-child(2) > div > table > tbody > tr > td:nth-child(3) { width: 272px;} */
#related-links { width: 272px; }
table.mainLayoutTable > tbody > tr:nth-child(2) > td:nth-child(2) > div > table > tbody > tr > td:nth-child(3) > div:nth-child(1) > div:nth-child(2) { display: none; }

#safariOption { display: block; background: #b9002d; padding:6px 11px 11px; color: #fff; }
#safariOption h3 { margin: 0 0 10px; padding: 0; color: #fff; font-size: 26px; line-height:30px; font-weight:300; letter-spacing:-.01em; font-family: 'guardian-text-oreilly', open-sans, Arial, sans-serif; -webkit-font-smoothing: antialiased; -moz-osx-font-smoothing: grayscale; }
#safariOption a.safari-button { display: block; padding: 8px 10px 7px; background: #fdb815; text-align: center; font-size: 16px; line-height:16px; font-weight:300; color: #000; text-transform: uppercase; letter-spacing:.02em; text-decoration: none; font-family: 'guardian-text-oreilly', open-sans, Arial, sans-serif; -webkit-font-smoothing: antialiased; -moz-osx-font-smoothing: grayscale; }
#safariOption a.safari-button:hover { background: #ffc439; text-decoration: none; }

#buyingOptionTable { display:none; margin-top:0; }
#buyingOptionTable * { font-family: 'guardian-text-oreilly', open-sans, Arial, sans-serif; }
#buyingOptionTable .box-heading {
  background: url(//shop.oreilly.com/images/oreilly/en_us/local/localgraphics/tabgradient_bg.gif) #F4F4F4; padding: 7px 10px 8px; font-size: 16px; line-height:16px; font-weight:600; color: #333; text-transform: uppercase; letter-spacing:.02em; font-family: 'guardian-text-oreilly', open-sans, Arial, sans-serif; }
#buyingOptionTable .goGreen { display: none; }
#buyingOptionTable .price { font-size: 16px; line-height:20px; font-weight:300; letter-spacing:-.01em; }
#buyingOptionTable .accQtyBox { top: 12px; left:150px; }
#buyingOptionTable td.optionsTd:nth-of-type(1) > div > div:nth-of-type(1) { width:140px !important; }
#buyingOptionTable td.optionsTd:nth-of-type(2) { padding: 14px 10px 8px 0px; text-align: right; }
</style>


<!-- Make updates to buybox -->
<script type="text/javascript">
setTimeout(function(){
  if(window.location.href.indexOf("/product/") > -1) {
    var buyingOptionsTable = document.getElementById("buyingOptionTable");

    if (buyingOptionsTable !== null) {
      var buyingOptionsVideo = false;

      //Remove extra spaces in price strings
      var priceNodes = buyingOptionsTable.getElementsByClassName("price");
      for (var i = 0; i < priceNodes.length; i++) {
        priceNodes[i].innerHTML = priceNodes[i].innerHTML.replace(/&nbsp;/,'');
        if (priceNodes[i].previousSibling.nodeValue.indexOf('Video') !== -1) {
          buyingOptionsVideo = true;
        }
      }

      var buyOptionsForms = buyingOptionsTable.getElementsByTagName("form");
      for (var i = 0; i < buyOptionsForms.length; i++) {
        var addToBasketInput = buyOptionsForms[i].getElementsByTagName("input")["addToBasket"];
        if (typeof(addToBasketInput) != 'undefined' && addToBasketInput != null) {
          buyOptionsForms[i].getElementsByTagName("input")["addToBasket"].setAttribute("src", "//cdn.oreillystatic.com/oreilly/images/ml_addtocart_btn.png");
        }
      }

      var buyingOptionHeading = buyingOptionsTable.getElementsByTagName("td")[0];
      if (buyingOptionsTable.getElementsByClassName("links")[0]) {
        //Add Safari block before buyingOptionsTable
        var buyingContainer = buyingOptionsTable.parentNode;
        var safariLink = buyingOptionsTable.getElementsByClassName("links")[0];
        var safariURL = safariLink.getElementsByTagName("a")[0].getAttribute("href");
        safariURL = safariURL.replace("utm_content=book+page","utm_content=buybox");
        var safariContainer = document.createElement('div');
        safariContainer.id = "safariOption";
        if (buyingOptionsVideo) {
          safariContainer.innerHTML = '<h3 class="safari-heading">Watch on Safari with 10-day <strong>free</strong> trial</h3><a href="' + safariURL + '" class="safari-button">Start your free trial</a>';
        } else {
          safariContainer.innerHTML = '<h3 class="safari-heading">Read on Safari with 10-day <strong>free</strong> trial</h3><a href="' + safariURL + '" class="safari-button">Start your free trial</a>';
        }
        buyingContainer.insertBefore(safariContainer, buyingOptionsTable);

        //Remove Safari block from after buyingOptionsTable
        safariLink.parentNode.removeChild(safariLink);
        //Remove buyingOptionTable heading row
        buyingOptionHeading.parentNode.removeChild(buyingOptionHeading);
      } else {
        //Replace image heading for buyingOptions with text
        buyingOptionHeading.innerHTML = '<div class="box-heading">Buying Options</div>';
      }
      
      buyingOptionsTable.style.display = "block";
    }
  }
}, 500);

//Make sure the buying options table is displayed, even if table isn't found in the above script.
jQuery(document).ready(function() {
  jQuery('#buyingOptionTable').css('display','block');
});

//Load Typekit fonts
(function(d) {
  var config = {
    kitId: 'gap0qyx',
    scriptTimeout: 3000,
    async: true
  },
  h=d.documentElement,t=setTimeout(function(){h.className=h.className.replace(/\bwf-loading\b/g,"")+" wf-inactive";},config.scriptTimeout),tk=d.createElement("script"),f=false,s=d.getElementsByTagName("script")[0],a;h.className+=" wf-loading";tk.src='https://fonts.oreillystatic.com/'+config.kitId+'.js';tk.async=true;tk.onload=tk.onreadystatechange=function(){a=this.readyState;if(f||a&&a!="complete"&&a!="loaded")return;f=true;clearTimeout(t);try{Typekit.load(config)}catch(e){}};s.parentNode.insertBefore(tk,s)
})(document);
</script>


<!-- Links to scripts -->
<script type="text/javascript" src="//shop.oreilly.com/text/oreilly/ml-min.js"></script>

<script type="text/javascript">
<!--

//Remove 'Final' from 'Final Release Date' on ER catalog pages
jQuery(document).ready(function() {
  jQuery('#buyingOptionTable').find('#earlyRelease').each(function() {
    var releaseDateDiv = jQuery('.AuthorName').parent('div').find('div:contains("Final Release Date")');
    releaseDateDiv.html(releaseDateDiv.text().replace('Final Release Date','Release Date'));
  });
});

//Hide prices for learning paths and conference video compilations/collections that are only available in Safari
jQuery(document).ready(function() {
  var hideLpTimeoutID = window.setTimeout(hideLpPrice, 100);
  function hideLpPrice() {
    jQuery('.thumbtext > .widthchange > .thumbheader > a:contains("Learning Path: ")').each(function() {
      $(this).closest('.widthchange').children().last('div').remove();
    });
    jQuery('.thumbtext > .widthchange > .thumbheader > a:contains("Video Compilation")').each(function() {
      $(this).closest('.widthchange').children().last('div').remove();
    });
    jQuery('.thumbtext > .widthchange > .thumbheader > a:contains("Video Collection")').each(function() {
      $(this).closest('.widthchange').children().last('div').remove();
    });
    window.clearTimeout(hideLpTimeoutID);
  }
});


//Display Recently Viewed at the bottom of catalog pages
var ormHideRecent = false;
//Loop through active cookies to find dotdpopup
var ormCookieArray = document.cookie.split(";");
var x,y;
for (var i = 0 ; i < ormCookieArray.length; i++) {
  x = ormCookieArray[i].substr(0, ormCookieArray[i].indexOf("="));
  y = ormCookieArray[i].substr(ormCookieArray[i].indexOf("=") + 1);
  x = x.replace(/^\s+|\s+$/g,"");
  if (x == "recentlyviewed") {
    if (y == "hidden") {
      ormHideRecent = true;
    }
  }
}

jQuery(document).ready(function() {
  //Collect all ML generated recently viewed items
  var mlRecentViews = jQuery('.RecentView');

  //If there are 1 or more items, continue
  if (mlRecentViews.length > 0) {
    //Make the base html for the recently viewed section a new object
    var recentlyViewed = jQuery('<div id="recently-viewed"><div class="overlay"><div class="hover-title"></div><div class="group"><a href="#" class="toggle"><span class="text">Recently Viewed</span></a><div class="items"></div></div><div class="bar"></div></div></div>');

    //For each recently viewed item, add a new node
    mlRecentViews.each(function() {
      var item = new Object();
      item.loc = jQuery(this).find('.thumbdiv a').attr('href');
      item.name = jQuery(this).find('.thumbdiv a img').attr('alt');
      item.imgPath = jQuery(this).find('.thumbdiv a img').attr('src').replace('bkt.gif','icon.gif');

      recentlyViewed.find('.items').append('<a href="' + item.loc + '" data-title="' + item.name + '" class="frame"><img src="' + item.imgPath + '" height="55" alt="' + item.name + '" /></a>');
    });

    //Remove ML recently viewed tab and content
    jQuery('body').append(recentlyViewed);
    jQuery('#tab_03_b').add('#tab_03_b_content').remove();
    if (ormHideRecent) {
      recentlyViewed.addClass('minimized');
    }

    //Add margin left to the bar when covers load
    var recentlyViewedGroup = recentlyViewed.find('.group');
    recentlyViewed.find('.frame > img').one('load', function() {
      recentlyViewed.find('.bar').css('margin-left', recentlyViewedGroup.outerWidth(true) + 'px');
    }).each(function() {
      if(this.complete) jQuery(this).load();
    });

    //Display and position titles on hover
    recentlyViewed.find('.frame').hover(function() {
      var hoverPosition = jQuery(this).position().left + (jQuery(this).width() / 2) - (recentlyViewed.find('.hover-title').outerWidth(true) / 2);

      recentlyViewed.find('.hover-title').text(jQuery(this).attr('data-title')).addClass('show').css('left', hoverPosition + 'px');
    }, function() {
      recentlyViewed.find('.hover-title').removeClass('show');
    });

    recentlyViewed.find('.toggle').click(function(e) {
      e.preventDefault();
      e.stopPropagation();

      var ormRecentlyViewedDate = new Date();
      ormRecentlyViewedDate.setTime(ormRecentlyViewedDate.getTime()+(90*24*60*60*1000));
      var ormRecentlyViewedExpires = "; expires="+ormRecentlyViewedDate.toGMTString();
      if (recentlyViewed.hasClass('minimized')) {
        recentlyViewed.removeClass('minimized');
        document.cookie = "recentlyviewed=visible; " + ormRecentlyViewedExpires + "; path=/";
      }
      else {
        recentlyViewed.addClass('minimized');
        document.cookie = "recentlyviewed=hidden; " + ormRecentlyViewedExpires + "; path=/";
      }
    });
  }
});
-->
</script>


<!-- New Nav -->
<!--[if lt IE 9]>
  <script>
    'article aside footer header nav section time'.replace(/\w+/g,function(n){document.createElement(n)})
  </script>
<![endif]-->


<!-- Nav CSS -->
<!-- Not Needed for Actual Site -->
<style type="text/css">

  nav a { text-decoration:none; }
  nav a:hover { text-decoration:underline; }

  nav p { margin:0 0 10px; }
  nav .fsl { font-size:16px; }
  nav .fsxl { font-size:24px; line-height:1.1em; }
  nav .fwb { font-weight:bold; }
  nav .fc-highlight { color:#b9002d; }
  nav .fc-dark { color:#222; }
  nav .fc-light { color:#fff; }
  nav .nm { margin:0; }
  nav .mb { margin-bottom:10px; }
  nav .mr { margin-right:10px; }
  nav .floatl { float:left; }
  nav .clear { clear:both; }

  nav  a.btn-green-arrow { display:block; float:left; padding:5px 10px 5px 22px; line-height:22px; font-size:20px; font-weight:bold; -webkit-border-radius: 4px; -moz-border-radius: 4px; border-radius: 4px; border:1px solid #f2ba12; color:#222; background: rgb(247,209,69); background: url(data:image/svg+xml;base64,PD94bWwgdmVyc2lvbj0iMS4wIiA/Pgo8c3ZnIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgdmlld0JveD0iMCAwIDEgMSIgcHJlc2VydmVBc3BlY3RSYXRpbz0ibm9uZSI+CiAgPGxpbmVhckdyYWRpZW50IGlkPSJncmFkLXVjZ2ctZ2VuZXJhdGVkIiBncmFkaWVudFVuaXRzPSJ1c2VyU3BhY2VPblVzZSIgeDE9IjAlIiB5MT0iMCUiIHgyPSIwJSIgeTI9IjEwMCUiPgogICAgPHN0b3Agb2Zmc2V0PSI1MCUiIHN0b3AtY29sb3I9IiNmN2QxNDUiIHN0b3Atb3BhY2l0eT0iMSIvPgogICAgPHN0b3Agb2Zmc2V0PSI1MCUiIHN0b3AtY29sb3I9IiNmNWM1MTciIHN0b3Atb3BhY2l0eT0iMSIvPgogIDwvbGluZWFyR3JhZGllbnQ+CiAgPHJlY3QgeD0iMCIgeT0iMCIgd2lkdGg9IjEiIGhlaWdodD0iMSIgZmlsbD0idXJsKCNncmFkLXVjZ2ctZ2VuZXJhdGVkKSIgLz4KPC9zdmc+); background: -moz-linear-gradient(top,  rgba(247,209,69,1) 50%, rgba(245,197,23,1) 50%); background: -webkit-gradient(linear, left top, left bottom, color-stop(50%,rgba(247,209,69,1)), color-stop(50%,rgba(245,197,23,1))); background: -webkit-linear-gradient(top, rgba(247,209,69,1) 50%,rgba(245,197,23,1) 50%); background: -o-linear-gradient(top, rgba(247,209,69,1) 50%,rgba(245,197,23,1) 50%); background: -ms-linear-gradient(top, rgba(247,209,69,1) 50%,rgba(245,197,23,1) 50%); background: linear-gradient(to bottom,  rgba(247,209,69,1) 50%,rgba(245,197,23,1) 50%); filter: progid:DXImageTransform.Microsoft.gradient( startColorstr='#f7d145', endColorstr='#f5c517',GradientType=0 ); }
  nav a.btn-green-arrow:hover { text-decoration:none; }
  nav a.btn-green-arrow .arrow { display:block; min-height:18px; background:transparent url(//cdn.oreillystatic.com/oreilly/images/btn-green-arrow-overlay.png) left center no-repeat; margin:0 0 0 -25px; padding:0 0 0 25px; }
  nav a.btn-green-arrow.small { font-size:13px; line-height:18px;  padding:5px 10px 5px 22px !important; }

  ul#primarynav, #sf-menu-text-nav { display:none; }
</style>

<!-- Styles for page -->
<style type="text/css">
  /* Reset for browsers that don't automatically set semantic tags to block */
  article,aside,details,figcaption,figure,footer,header,hgroup,menu,nav,section { display:block; }

  nav .self-clear:after { content:""; display:block; clear:both; height:0; }

#globalInclude { text-align:left !important; }
</style>


<!-- Nav Styles -->
<style type="text/css">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</style>


<!-- Advertisement Styles -->
<style type="text/css">
  nav #contextual-nav ul.horizontal li.ad.data { width:425px; min-height:560px; position:absolute; z-index:-1; top:0; bottom:0; left:0; margin-right:-55px; background:transparent url(//cdn.oreillystatic.com/oreilly/promos/ad-data-bg.png) left bottom no-repeat; }

  nav #contextual-nav ul.horizontal li.ad.photography { width:370px; min-height:560px; position:absolute; z-index:-1; top:0; bottom:0; left:0; background:transparent url(//cdn.oreillystatic.com/oreilly/promos/ad-photography-bg.jpg) left bottom no-repeat; }

  nav #contextual-nav ul.horizontal li.ad.programming { width:425px; min-height:585px; position:absolute; z-index:-1; top:0; bottom:0; left:0; margin-bottom:-25px; background:transparent url(//cdn.oreillystatic.com/oreilly/promos/ad-programming-bg.png) left bottom no-repeat; }
</style>


  <!-- Subnav JavaScript -->
  
<script type="text/javascript">

  //Initialize the site subnav dropdown menu
  function initSubNav() {

    var isMobile = (/iPhone|iPod|iPad|Android|BlackBerry|IEMobile|Opera Mini/).test(navigator.userAgent);
    if (isMobile) {
      //Prevent default interaction on clicks of drop-down menu titles
      jQuery('nav').find('.sub > .title').bind('click', function(e) {
        e.preventDefault();
      });
    }

    jQuery('#contextual-nav > .sub').bind('mouseover', function(e) {
      var that = jQuery(this);
      that.addClass('on');
    }).bind('mouseleave', function(e) {
      var that = jQuery(this);
      that.removeClass('on');
      that.find('.sub').removeClass('hover');
    });

    jQuery('nav').find('.vertical > .sub').bind('mouseover', function(e) {
      var that = jQuery(this);
      that.addClass('on');
      setTimeout(function() {
        if (that.hasClass('on')) {
          that.parent().children().removeClass('hover');
          that.addClass('hover');
        }
      },70);
    }).bind('mouseleave', function(e) {
      var that = jQuery(this);
      that.removeClass('on');
    });
  }

  //Break subnav lists into columns where 'split' classes have been added
  function breakNavColumns() {
    jQuery('nav').find('.horizontal').each(function() {
      jQuery(this).find('.split').each(function(i) {
      var category = jQuery(this).parent().find('.category:eq(0)').parent();
      jQuery(this).css('margin-top', - (jQuery(this).position().top - category.position().top - category.height()) + "px");
      jQuery(this).add(jQuery(this).nextAll(':not(.ad)')).css('margin-left', ((1+i) * (5 + jQuery(this).width())) + 'px');
      }); 
    });
  }
  
  //When the document is loaded, initialize the subnav dropdown menu and multi-column subnav lists
  jQuery(document).ready(function(jQuery) {
    breakNavColumns();
    initSubNav();
  });

</script>


<nav role="navigation">
  <ul id="global-nav" role="menubar">
    <li role="menuitem"><a href="http://www.oreilly.com">Home</a></li>
    <li role="menuitem"><a href="http://shop.oreilly.com" class="current">Shop Video Training &amp; Books</a></li>
    <li role="menuitem"><a href="http://radar.oreilly.com">Radar</a></li>
    <li role="menuitem"><a href="http://www.safaribooksonline.com/?utm_source=oreilly&utm_medium=referral&utm_campaign=publisher&utm_content=nav">Safari Books Online</a></li>
    <li role="menuitem"><a href="http://conferences.oreilly.com/">Conferences</a></li>
    <!-- li role="menuitem"><a href="http://www.oreillyschool.com/">IT Courses &amp; Certificates</a></li -->
    <li class="social"><a href="http://twitter.com/oreillymedia" class="icon twitter" title="O'Reilly on Twitter"></a><a href="http://www.youtube.com/subscription_center?add_user=oreillymedia" class="icon youtube" title="O'Reilly on YouTube"></a><a href="http://www.facebook.com/OReilly" class="icon facebook" title="O'Reilly on Facebook"></a><a href="https://plus.google.com/+oreillymedia/" class="icon googleplus" title="O'Reilly on Google+"></a><a href="http://oreilly.com/feeds/" class="icon rss" title="Subscribe to Feed"></a></li>
  </ul>

  
    <!-- Store Subnav -->
    <!-- New CS -->
  <ul id="contextual-nav" role="menubar">
    <li class="sub" aria-haspopup="true" role="menuitem">
      <a class="title" href="http://shop.oreilly.com/category/browse-subjects.do"><span>Browse Subjects</span></a>
      <ul class="vertical" role="menu">
        <li class="sub" aria-haspopup="true" role="menuitem">
          <a href="http://shop.oreilly.com/category/browse-subjects/apple-mac.do" class="title">Apple</a>
          <ul class="horizontal" role="menu">
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/apple-mac.do" class="category">Apple</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/apple-mac/apple-apps.do">Apple Apps</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/apple-mac/apple-programming.do">Apple Programming</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/apple-mac/ios-programming.do">iOS Programming</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/apple-mac/ipad-iphone-ipod.do">iPad, iPhone, &amp; iPod</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/apple-mac/mac.do">Mac</a></li>
          </ul>
        </li>
        <li class="sub" aria-haspopup="true" role="menuitem">
          <a href="http://shop.oreilly.com/category/browse-subjects/apps-software.do" class="title">Apps &amp; Software</a>
          <ul class="horizontal" role="menu">
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/apps-software.do" class="category">Apps &amp; Software</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/apps-software/apple-apps.do">Apple Apps</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/apps-software/design-apps.do">Design Apps</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/apps-software/office-sharepoint.do">Office &amp; SharePoint</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/apps-software/photo-apps.do">Photoshop &amp; Photo Apps</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/apps-software/web-mobile-apps.do">Web &amp; Mobile Apps</a></li>
          </ul>
        </li>
        <li class="sub" aria-haspopup="true" role="menuitem">
          <a href="http://shop.oreilly.com/category/browse-subjects/digital-audio-video.do" class="title">Audio &amp; Video</a>
          <ul class="horizontal" role="menu">
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/digital-audio-video.do" class="category">Audio &amp; Video</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/digital-audio-video/digital-audio.do">Audio</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/digital-audio-video/digital-video.do">Video</a></li>
          </ul>
        </li>
        <li class="sub" aria-haspopup="true" role="menuitem">
          <a href="http://shop.oreilly.com/category/browse-subjects/business.do" class="title">Business</a>
          <ul class="horizontal" role="menu">
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/business.do" class="category">Business</a></a>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/business/accounting-finance.do">Accounting &amp; Finance</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/business/agile.do">Agile &amp; Lean</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/business/business-management.do">Business Management &amp; Leadership</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/business/career-development.do">Career Development</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/business/entrepreneurship.do">Entrepreneurship</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/business/it-leadership.do">IT Leadership</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/business/project-management.do">Project Management</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/business/sales-marketing.do">Sales &amp; Marketing</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/business/society-culture.do">Society &amp; Culture</a></li>
          </ul>
        </li>
        <li class="sub" aria-haspopup="true" role="menuitem">
          <a href="http://shop.oreilly.com/category/browse-subjects/certification-training.do" class="title">Certification</a>
          <ul class="horizontal" role="menu">
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/certification-training.do" class="category">Certification</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/certification-training/cisco-certification.do">Cisco Certification</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/certification-training/linux-certification.do">Linux Certification</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/certification-training/microsoft-certification-training.do">Microsoft Certification &amp; Training</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/certification-training/pmp.do">PMP</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/certification-training/other-certification.do">Other Certification</a></li>
          </ul>
        </li>
        <li class="sub" aria-haspopup="true" role="menuitem">
          <a href="http://shop.oreilly.com/category/browse-subjects/data.do" class="title">Data</a>
          <ul class="horizontal" style="width:370px;" role="menu">
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/data.do" class="category">Data</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/data/data-analysis-visualization.do">Data Analysis &amp; Visualization</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/data/data-topics.do">Data Topics</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/data/non-relational-databases.do">Non-Relational Databases</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/data/sas.do">SAS</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/data/oracle.do">Oracle</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/data/relational-databases.do">Relational Databases</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/data/sql-server.do">SQL Server</a></li>

          </ul>
        </li>
        <li class="sub" aria-haspopup="true" role="menuitem">
          <a href="http://shop.oreilly.com/category/browse-subjects/design.do" class="title">Design</a>
          <ul class="horizontal" role="menu">
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/design.do" class="category">Design</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/design/animation.do">Animation</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/design/design-apps.do">Design Apps</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/design/digital-publishing.do">Digital Publishing</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/design/game-design.do">Game Design &amp; Development</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/design/information-architecture.do">Information Architecture</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/design/mobile-design.do">Mobile Design &amp; Development</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/design/prod-design.do">Product Design</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/design/user-experience.do">User Experience</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/design/web-design.do">Web Design</a></li>
          </ul>
        </li>
        <li class="sub" aria-haspopup="true" role="menuitem">
          <a href="http://shop.oreilly.com/category/browse-subjects/science-math.do" class="title">Engineering, Math, &amp; Science</a>
          <ul class="horizontal" role="menu">
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/science-math.do" class="category">Engineering, Math, &amp; Science</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/science-math/bioinformatics.do">Bioinformatics</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/science-math/electrical-engineering.do">Electrical Engineering</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/science-math/hardware-engineering.do">Hardware Engineering</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/science-math/math.do">Math</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/science-math/science.do">Science</a></li>
          </ul>
        </li>
        <li class="sub" aria-haspopup="true" role="menuitem">
          <a href="http://shop.oreilly.com/category/browse-subjects/health.do" class="title">Health &amp; Wellness</a>
          <ul class="horizontal" role="menu">
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/health.do" class="category">Health &amp; Wellness</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/health/cancer.do">Cancer</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/health/disorders-diseases.do">Disorders &amp; Diseases</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/health/health-it.do">Health IT</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/health/mind-body.do">Mind &amp; Body</a></li>
          </ul>
        </li>
        <li class="sub" aria-haspopup="true" role="menuitem">
          <a href="http://shop.oreilly.com/category/browse-subjects/iot.do" class="title">IoT (Internet of Things)</a>
          <ul class="horizontal" role="menu">
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/iot.do" class="category">IoT (Internet of Things)</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/iot/diy-projects.do">DIY Projects</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/iot/electronics.do">Electronics</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/iot/hardware-hacking.do">Hardware Hacking</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/iot/lego-robotics.do">Lego &amp; Robotics</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/iot/make-craft.do">Make &amp; Craft</a></li>
          </ul>
        </li>

        <li class="sub" aria-haspopup="true" role="menuitem">
          <a href="http://shop.oreilly.com/category/browse-subjects/microsoft.do" class="title">Microsoft</a>
          <ul class="horizontal" role="menu">
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/microsoft.do" class="category">Microsoft</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/microsoft/dotnet.do">.NET &amp; Windows Programming</a></li>
            <li role="menuitem" role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/microsoft/business-solutions.do">Microsoft Business Solutions</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/microsoft/certification-training.do">Microsoft Certification &amp; Training</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/microsoft/servers.do">Microsoft Servers</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/microsoft/software-development.do">Microsoft Software Development</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/microsoft/webdesign.do">Microsoft Web Design &amp; Development</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/microsoft/office-sharepoint.do">Office &amp; Sharepoint</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/microsoft/windows.do">Windows</li></a>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/microsoft/windows-administration.do">Windows Administration</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/microsoft/windows-phone.do">Windows Phone</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/microsoft/windows-phone-programming.do">Windows Phone Programming</a></li>
          </ul>
        </li>
        <li class="sub" aria-haspopup="true" role="menuitem">
          <a href="http://shop.oreilly.com/category/browse-subjects/mobile-devices.do" class="title">Mobile &amp; Ereader Devices</a>
          <ul class="horizontal" role="menu">
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/mobile-devices.do" class="category">Mobile &amp; Ereader Devices</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/mobile-devices/android.do">Android</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/mobile-devices/ipad-iphone-ipod.do">iPad, iPhone, &amp; iPad</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/mobile-devices/kindle.do">Kindle</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/mobile-devices/nook.do">Nook</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/mobile-devices/windows-phone.do">Windows Phone</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/mobile-devices/other-devices.do">Other Devices</a></li>
          </ul>
        </li>
        <li class="sub" aria-haspopup="true" role="menuitem">
          <a href="http://shop.oreilly.com/category/browse-subjects/networking.do" class="title">Networking</a>
          <ul class="horizontal" role="menu">
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/networking.do" class="category">Networking</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/networking/cisco.do">Cisco</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/networking/cloud-network-security.do">Cloud &amp; Network Security</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/networking/home-networking.do">Home Networking</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/networking/network-administration.do">Network Administration</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/networking/networking-topics.do">Networking Topics</a></li>
          </ul>
        </li>
        <li class="sub" aria-haspopup="true" role="menuitem">
          <a href="http://shop.oreilly.com/category/browse-subjects/personal-computing.do" class="title">Personal Computing</a>
          <ul class="horizontal" role="menu">
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/personal-computing.do" class="category">Personal Computing</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/personal-computing/home-networking.do">Home Networking</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/personal-computing/mac.do">Mac</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/personal-computing/pc.do">PC</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/personal-computing/windows.do">Windows</a></li>
          </ul>
        </li>
        <li class="sub" aria-haspopup="true" role="menuitem">
          <a href="http://shop.oreilly.com/category/browse-subjects/personal-growth.do" class="title">Personal Growth</a>
          <ul class="horizontal" role="menu">
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/personal-growth.do" class="category">Personal Growth</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/personal-growth/business-management-leadership.do">Business Management &amp; Leadership</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/personal-growth/career-development.do">Career Development</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/personal-growth/mind-body.do">Mind &amp; Body</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/personal-growth/personal-finance.do">Personal Finance</a></li>
          </ul>
        </li>
        <li class="sub" aria-haspopup="true" role="menuitem">
          <a href="http://shop.oreilly.com/category/browse-subjects/digital-photography.do" class="title">Photography</a>
          <ul class="horizontal" style="width:370px;" role="menu">
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/digital-photography.do" class="category">Photography</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/digital-photography/camera-guides.do">Camera Guides</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/digital-photography/digital-photography.do">Digital Photography</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/digital-photography/photoshop.do">Photoshop &amp; Photo Apps</a></li>


          </ul>
        </li>
        <li class="sub" aria-haspopup="true" role="menuitem">
          <a href="http://shop.oreilly.com/category/browse-subjects/programming.do" class="title">Programming</a>
          <ul class="horizontal" style="width:425px;" role="menu">
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming.do" class="category">Programming</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/dotnet.do">.NET &amp; Windows</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/agile.do">Agile</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/android-programming.do">Android</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/apple-programming.do">Apple</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/c.do">C/C++</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/csharp.do">C#</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/design-patterns.do">Design Patterns</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/game-design.do">Game Design &amp; Development</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/graphics-multimedia-programming.do">Graphics &amp; Multimedia</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/ios-programming.do">iOS</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/java.do">Java</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/javascript.do">JavaScript</a></li>
            <li class="split" style="position:relative; z-index:10;" role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/perl.do">Perl</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/mobile-design.do">Mobile Design &amp; Development</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/php.do">PHP</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/python.do">Python</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/r.do">R</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/ruby.do">Ruby &amp; Rails</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/secure-programming.do">Secure</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/software-engineering.do">Software Engineering</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/testing.do">Testing</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/windows-phone-programming.do">Windows Phone</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/other-programming-languages.do">Other Languages</a></li>

          </ul>
        </li>
        <li class="sub" aria-haspopup="true" role="menuitem">
          <a href="http://shop.oreilly.com/category/browse-subjects/security.do" class="title">Security &amp; Cryptography</a>
          <ul class="horizontal" role="menu">
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/security.do" class="category">Security &amp; Cryptography</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/security/cloud-network-security.do">Cloud &amp; Network Security</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/security/computer-security.do">Computer Security</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/security/cryptography.do">Cryptography</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/security/secure-programming.do">Secure Programming</a></li>
          </ul>
        </li>
        <li class="sub" aria-haspopup="true" role="menuitem">
          <a href="http://shop.oreilly.com/category/browse-subjects/system-administration.do" class="title">System Administration</a>
          <ul class="horizontal" role="menu">
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/system-administration.do" class="category">System Administration</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/system-administration/cloud-administration.do">Cloud Administration</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/system-administration/email-administration.do">Email Administration</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/system-administration/linux-unix.do">Linux &amp; Unix</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/system-administration/microsoft-servers.do">Microsoft Servers</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/system-administration/performance.do">Performance</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/system-administration/system-admin-ops.do">System Admin &amp; Ops</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/system-administration/windows-administration.do">Windows Administration</a></li>
          </ul>
        </li>
        <li class="sub" aria-haspopup="true" role="menuitem">
          <a href="http://shop.oreilly.com/category/browse-subjects/tech-culture.do" class="title">Tech Culture</a>
          <ul class="horizontal" role="menu">
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/tech-culture.do" class="category">Tech Culture</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/tech-culture/game-strategy.do">Game Strategy</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/tech-culture/tech-culture.do">Tech Culture</a></li>
          </ul>
        </li>
        <li class="sub" aria-haspopup="true" role="menuitem">
          <a href="http://shop.oreilly.com/category/browse-subjects/web-development.do" class="title">Web Development</a>
          <ul class="horizontal" role="menu">
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/web-development.do" class="category">Web Development</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/web-development/html-css.do">HTML &amp; CSS</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/web-development/javascript.do">JavaScript</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/web-development/performance.do">Performance</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/web-development/php.do">PHP</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/web-development/ruby-rails.do">Ruby &amp; Rails</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/web-development/sem-seo.do">SEM &amp; SEO</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/web-development/web-content-management.do">Web Content Management</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/web-development/web-design.do">Web Design</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/web-development/web-development.do">Web Development</a></li>
          </ul>
        </li>
      </ul>
    </li>
    <li role="menuitem"><a href="http://shop.oreilly.com/category/learning-path.do">Learning Paths</a></li>
    <li role="menuitem"><a href="http://shop.oreilly.com/category/videos.do">Video Training</a></li>
    <li role="menuitem"><a href="http://shop.oreilly.com/category/new.do">New</a></li>
    <li role="menuitem"><a href="http://shop.oreilly.com/category/upcoming.do">Upcoming</a></li>
    <li role="menuitem"><a href="http://shop.oreilly.com/category/early-release.do">Early Release</a></li>
    <li role="menuitem"><a href="http://shop.oreilly.com/category/bestselling.do">Bestselling</a></li>
    <li role="menuitem" class="no-divider"><a href="http://shop.oreilly.com/category/ebooks.do">Ebooks</a></li>

    <li class="contact vcard">
        <span class="tel">1-800-889-8969</span> / <span class="tel">707-827-7019</span> / <a class="email" href="mailto:orders@oreilly.com">orders@oreilly.com</a>
    </li>
  </ul>
  

  

  


  

  


</nav>

<div style="text-align:center" id="global-ad">
<!-- Safari Self Assessments  -->
<a href="https://www.safaribooksonline.com/public/self-assessments/?utm_medium=content&utm_source=oreilly.com&utm_campaign=lgen&utm_content=20170508+self+assessment+global+banner" onClick="var s=s_gi(s_account); s.products=';orm-store-global-safari-self-assessment'; s.eVar23='orm-store-global-safari-self-assessment'; s.events='event5'; s.linkTrackVars='eVar23,products,events'; s.linkTrackEvents='event5'; s.tl(this,'o','Ad Click');"><img src="//cdn.oreillystatic.com/assets/images/global-self-assessment-20170508.jpg" width="974" height="190" alt="The Safari platform now includes self assessments. Learn more" /></a>
</div>



	</div>






    
  

  
  

  
  
  
  
  


</div>
    </td>
  </tr>

  <tr valign="top">

    

    <td width="8" class="contentbg"><img src="/images/oreilly/en_us/global/globalgraphics/spacer01.gif" width="8" height=1 border=0></td>
    <td width="974" class="contentbg">
      <div>

























  

















			
		

























  











<script src="/includes/kits.js"></script>
<script src="/includes/validateProductSelection.js"></script>
<script type="text/javascript" src="//cdn.oreillystatic.com/assets/js/abridge-description.js"></script>
<script language="javascript">
	var noQtyMsg = "Quantity must be at least 1.";
	var noOptionsMsg = "Select Valid Option(s)";
</script>

	
	
	








<div class"detailFillslot">
	
</div>



<table cellspacing="0" cellpadding="0" border="0">


	<input type="hidden" name="from" value="detail">

	

	<input type="hidden" name="pageCategory" value="">

	

	<tr valign="top">

  		<td style="width:690px;">

				<div id="browse-content" style="float:left;width:190px;">
					

					
					
					
					
						
							
						

























  







  



<div>
	
		<a href="https://library.oreilly.com/book/0636920046158/_/toc" id="search-inside" onclick="var s=s_gi(s_account); s.products=';shop-reader-searchin-0636920046158'; s.eVar23='shop-reader-searchin-0636920046158'; s.events='event5'; s.linkTrackVars='eVar23,products,events'; s.linkTrackEvents='event5'; s.tl(this,'o','Ad Click');">Search Inside and Read</a>
	
</div>


										

					
					
					
						
					

























  







<script src="/includes/optionClasses.js"></script>
<script src="/includes/detailImageSwatches.js"></script>





  









  
  
    
    

    
  










	
		
		
		
			<div class="detailimgcontainer">
				
				 
				 
				 
				 
				 
			<a href="/product/0636920046158.do?sortby=publicationDate" target="_parent" onClick="goSwatches_148789.openViewLarger(500,680,'/product/0636920046158/ViewLarger.do?sortby=publicationDate','ViewLarger');">
			<img id="largeImage" src="http://akamaicovers.oreilly.com/images/0636920046158/cat.gif" border="0" alt="How to Write Accurate SQL Code"/></a>
				
			</div>
		
	
	<script type="text/javascript">
		var sViewLargerCall = "goSwatches_148789.openViewLarger(500,680,'/product/0636920046158/ViewLarger.do?sortby=publicationDate','ViewLarger', 'NoFocus')"
	</script>

	

	
	
		<div class="viewLarger">
		<a href="#" onClick="goSwatches_148789.openViewLarger(500,680,'/product/0636920046158/ViewLarger.do?sortby=publicationDate','ViewLarger');" >

			Larger Cover

			
		</a>
		</div>
	
 


 






<script type="text/javascript">
  

  
    
    
      
      
    
  

  
  var goSwatches_148789 = new DetailImageSwatches(148789,null,null,null,null);
</script>


					




					
				</div>

			
   			<div class="detailheader">
   				SQL and Relational Theory, 3rd Edition
   			</div>

			
			
				<div class="detailSubHeader">
					How to Write Accurate SQL Code
				</div>
			

    		

			
			 <div>
				 
					
					
				 

























  





























   <div class="AuthorName">By&nbsp;<a href="#tab_04_2" class="byLineLink" onclick="setActiveTab('tab_04_2', 'About the Author',2)">C.J. Date</a></div>



   <div>Publisher:&nbsp;O'Reilly Media</div>

	
	
      
         
            <div>Final Release Date:&nbsp;November 2015
			
            </div>
         
      
   
   
      <div class="default">Pages:&nbsp;582</div>
   
   




			 </div>


			<div class="SocialIconBox">

							<table cellspacing="0" cellpadding="0" border="0" width="100%">
					<tr>

						
							<td>
								<!--Start:fix for ORLY97  -->
								<div>
									 
										
									 

























  





<link rel="stylesheet" href="/text/pwr/engine/pr_styles_review.css" id="prBaseStylesheet"/>
<link rel="stylesheet" href="/includes/reviews_social.css" type="text/css" id="prMerchantOverrideStylesheet">


	
	
	
    
	
	
	
	
	

	<script type="text/javascript" src="/text/pwr/engine/js/full.js"></script>
	<script type="text/javascript">
		 var pr_locale = 'en_US';
		 var pr_zip_location='/text';
		var pr_style_sheet='/includes/reviews_social.css ';
		var pr_page_id = '0636920046158.IP'; /* SPECIFY THE PRODUCT SEO code here since Product ID not dependable  */
	</script>

	<script type="text/javascript">
	function ReviewAnchor() {
			window.location = String(window.location).replace(/#.*$/, "") + "#PowerReview";
	}
	</script>


		<div id="hasReviews">
			<script type="text/javascript">
				POWERREVIEWS.display.snippet(document, {
				pr_page_id : '0636920046158.IP',
				pr_read_review : 'javascript:ReviewAnchor()',
				pr_write_review : '/product/0636920046158/ReviewSubmit.do?sortby=publicationDate?pageId=0636920046158.IP'
			});
			</script>
		</div>
		<div id="noReviews" style="display:none">
			<script type="text/javascript">document.write('Be the first to <a href="/product/0636920046158/ReviewSubmit.do?sortby=publicationDate?pageId=0636920046158.IP">write a review </a>')</script>
		</div>

<!-- End PowerReviews snippet -->



							 	</div>
								<!--End:fix for ORLY97  -->
								
							</td>
					</tr>
				</table>
			</div>
			
			
						
			<!--Start:SC-2013-04523  -->
			<div id="detail-description-container">
			
			
			<table width="500" cellpadding=0 cellspacing=0><tr><td>
				<div class="detail-description-content">
				
					<div>
                                                <div>
                                                    <p>SQL is full of difficulties and traps for the unwary. You can avoid them if you understand relational theory, but only if you know how to put that theory into practice. In this book, Chris Date explains relational theory in depth, and demonstrates through numerous examples and exercises how you can apply it to your use of SQL.</p>
                                                    <p>This third edition has been revised, extended, and improved throughout. Topics whose treatment has been expanded include data types and domains, table comparisons, image relations, aggregate operators and summarization, view updating, and subqueries. A special feature of this edition is a new appendix on NoSQL and relational theory.</p>
                                                    <ul>
                                                        <li>Could you write an SQL query to find employees who have worked at least once in every programming department in the company? And be sure it’s correct?</li>
                                                        <li>Why is proper column naming so important?</li>
                                                        <li>Nulls in the database cause wrong answers. Why? What you can do about it?</li>
                                                        <li>How can image relations help you formulate complex SQL queries?</li>
                                                        <li>SQL supports "quantified comparisons," but they’re better avoided. Why? And how?</li>
                                                    </ul>
                                                    <p>Database theory and practice have evolved considerably since Codd first defined the relational model, back in 1969. This book draws on decades of experience to present the most up to date treatment of the material available anywhere. Anyone with a modest to advanced background in SQL can benefit from the insights it contains. The book is product independent.</p>
                                                </div>
                                            </div>
				</div></td></tr></table>
				<script type="text/javascript">abridgeDescription();</script>
			</div>
			<!--End-2013-04523  -->
			
				
					
				

























  











  
  
  	
    	
    
  

  
  

  
  
  
  
  




			
				 
					
				 

























  















				
		
			
			
				<div>
				
				</div>
			
		

			
			 <div style="clear: both;"></div>

			
			

			
			
				
				<div class="infoTabs">
					
					
						
						
							
						
					

























  







  









				</div>
				
				
				<div class="infoTabs">
					
					
						
					

























  







  









  
  
  
  

  
  <script src="/includes/InfoTabs.js"></script>

  
  
  
  
  
    <div id="tab_02_2_content" style="display:none;">
      <table width="100%" cellpadding=0 cellspacing=0><tr><td><div id="toc-content"><ol id="chapters"><li class="chapter" title="1"><h3><span class="chapter-label">Chapter 1</span>Setting the Scene</h3><ol><li class="sect1" title="1.1"><h4>The relational model is much misunderstood</h4></li><li class="sect1" title="1.2"><h4>Some remarks on terminology</h4></li><li class="sect1" title="1.3"><h4>Principles not products</h4></li><li class="sect1" title="1.4"><h4>A review of the original model</h4></li><li class="sect1" title="1.5"><h4>Model vs. implementation</h4></li><li class="sect1" title="1.6"><h4>Properties of relations</h4></li><li class="sect1" title="1.7"><h4>Base vs. derived relations</h4></li><li class="sect1" title="1.8"><h4>Relations vs. relvars</h4></li><li class="sect1" title="1.9"><h4>Values vs. variables</h4></li><li class="sect1" title="1.10"><h4>Concluding remarks</h4></li><li class="sect1" title="1.11"><h4>Exercises</h4></li><li class="sect1" title="1.12"><h4>Answers</h4></li></ol></li><li class="chapter" title="2"><h3><span class="chapter-label">Chapter 2</span>Types and Domains</h3><ol><li class="sect1" title="2.1"><h4>Types and relations</h4></li><li class="sect1" title="2.2"><h4>Equality comparisons</h4></li><li class="sect1" title="2.3"><h4>Data value atomicity</h4></li><li class="sect1" title="2.4"><h4>What&#8217;s a type?</h4></li><li class="sect1" title="2.5"><h4>Scalar vs. nonscalar types</h4></li><li class="sect1" title="2.6"><h4>Scalar types in SQL</h4></li><li class="sect1" title="2.7"><h4>Type checking and coercion in SQL</h4></li><li class="sect1" title="2.8"><h4>Collations in SQL</h4></li><li class="sect1" title="2.9"><h4>Row and table types in SQL</h4></li><li class="sect1" title="2.10"><h4>Concluding remarks</h4></li><li class="sect1" title="2.11"><h4>Exercises</h4></li><li class="sect1" title="2.12"><h4>Answers</h4></li></ol></li><li class="chapter" title="3"><h3><span class="chapter-label">Chapter 3</span>Tuples and Relations, Rows and Tables</h3><ol><li class="sect1" title="3.1"><h4>What&#8217;s a tuple?</h4></li><li class="sect1" title="3.2"><h4>Rows in SQL</h4></li><li class="sect1" title="3.3"><h4>What&#8217;s a relation?</h4></li><li class="sect1" title="3.4"><h4>Relations and their bodies</h4></li><li class="sect1" title="3.5"><h4>Relations are n-dimensional</h4></li><li class="sect1" title="3.6"><h4>Relational comparisons</h4></li><li class="sect1" title="3.7"><h4>TABLE_DUM and TABLE_DEE</h4></li><li class="sect1" title="3.8"><h4>Tables in SQL</h4></li><li class="sect1" title="3.9"><h4>Column naming in SQL</h4></li><li class="sect1" title="3.10"><h4>Concluding remarks</h4></li><li class="sect1" title="3.11"><h4>Exercises</h4></li><li class="sect1" title="3.12"><h4>Answers</h4></li></ol></li><li class="chapter" title="4"><h3><span class="chapter-label">Chapter 4</span>No Duplicates, No Nulls</h3><ol><li class="sect1" title="4.1"><h4>What&#8217;s wrong with duplicates?</h4></li><li class="sect1" title="4.2"><h4>Duplicates: further issues</h4></li><li class="sect1" title="4.3"><h4>Avoiding duplicates in SQL</h4></li><li class="sect1" title="4.4"><h4>What&#8217;s wrong with nulls?</h4></li><li class="sect1" title="4.5"><h4>Avoiding nulls in SQL</h4></li><li class="sect1" title="4.6"><h4>A remark on outer join</h4></li><li class="sect1" title="4.7"><h4>Concluding remarks</h4></li><li class="sect1" title="4.8"><h4>Exercises</h4></li><li class="sect1" title="4.9"><h4>Answers</h4></li></ol></li><li class="chapter" title="5"><h3><span class="chapter-label">Chapter 5</span>Base Relvars, Base Tables</h3><ol><li class="sect1" title="5.1"><h4>Updating is set level</h4></li><li class="sect1" title="5.2"><h4>Relational assignment</h4></li><li class="sect1" title="5.3"><h4>More on candidate keys</h4></li><li class="sect1" title="5.4"><h4>More on foreign keys</h4></li><li class="sect1" title="5.5"><h4>Relvars and predicates</h4></li><li class="sect1" title="5.6"><h4>Relations vs. types</h4></li><li class="sect1" title="5.7"><h4>Exercises</h4></li><li class="sect1" title="5.8"><h4>Answers</h4></li></ol></li><li class="chapter" title="6"><h3><span class="chapter-label">Chapter 6</span>SQL and Relational Algebra I: The Original Operators</h3><ol><li class="sect1" title="6.1"><h4>Some preliminaries</h4></li><li class="sect1" title="6.2"><h4>More on closure</h4></li><li class="sect1" title="6.3"><h4>Restriction</h4></li><li class="sect1" title="6.4"><h4>Projection</h4></li><li class="sect1" title="6.5"><h4>Join</h4></li><li class="sect1" title="6.6"><h4>Union, intersection, and difference</h4></li><li class="sect1" title="6.7"><h4>Which operators are primitive?</h4></li><li class="sect1" title="6.8"><h4>Formulating expressions one step at a time</h4></li><li class="sect1" title="6.9"><h4>What do relational expressions mean?</h4></li><li class="sect1" title="6.10"><h4>Evaluating SQL table expressions</h4></li><li class="sect1" title="6.11"><h4>Expression transformation</h4></li><li class="sect1" title="6.12"><h4>The reliance on attribute names</h4></li><li class="sect1" title="6.13"><h4>Exercises</h4></li><li class="sect1" title="6.14"><h4>Answers</h4></li></ol></li><li class="chapter" title="7"><h3><span class="chapter-label">Chapter 7</span>SQL and Relational Algebra II: Additional Operators</h3><ol><li class="sect1" title="7.1"><h4>Exclusive union</h4></li><li class="sect1" title="7.2"><h4>Semijoin and semidifference</h4></li><li class="sect1" title="7.3"><h4>Extend</h4></li><li class="sect1" title="7.4"><h4>Image relations</h4></li><li class="sect1" title="7.5"><h4>Divide</h4></li><li class="sect1" title="7.6"><h4>Aggregate operators</h4></li><li class="sect1" title="7.7"><h4>Image relations revisited</h4></li><li class="sect1" title="7.8"><h4>Summarization</h4></li><li class="sect1" title="7.9"><h4>Summarization revisited</h4></li><li class="sect1" title="7.10"><h4>Group, ungroup, and relation valued attributes</h4></li><li class="sect1" title="7.11"><h4>&#8220;What if&#8221; queries</h4></li><li class="sect1" title="7.12"><h4>A note on recursion</h4></li><li class="sect1" title="7.13"><h4>What about ORDER BY?</h4></li><li class="sect1" title="7.14"><h4>Exercises</h4></li><li class="sect1" title="7.15"><h4>Answers</h4></li></ol></li><li class="chapter" title="8"><h3><span class="chapter-label">Chapter 8</span>SQL and Constraints</h3><ol><li class="sect1" title="8.1"><h4>Type constraints</h4></li><li class="sect1" title="8.2"><h4>Type constraints in SQL</h4></li><li class="sect1" title="8.3"><h4>Database constraints</h4></li><li class="sect1" title="8.4"><h4>Database constraints in SQL</h4></li><li class="sect1" title="8.5"><h4>Transactions</h4></li><li class="sect1" title="8.6"><h4>Why database constraint checking must be immediate</h4></li><li class="sect1" title="8.7"><h4>But doesn&#8217;t some checking have to be deferred?</h4></li><li class="sect1" title="8.8"><h4>Constraints and predicates</h4></li><li class="sect1" title="8.9"><h4>Miscellaneous issues</h4></li><li class="sect1" title="8.10"><h4>Exercises</h4></li><li class="sect1" title="8.11"><h4>Answers</h4></li></ol></li><li class="chapter" title="9"><h3><span class="chapter-label">Chapter 9</span>SQL and Views</h3><ol><li class="sect1" title="9.1"><h4>Views are relvars</h4></li><li class="sect1" title="9.2"><h4>Views and predicates</h4></li><li class="sect1" title="9.3"><h4>Retrieval operations</h4></li><li class="sect1" title="9.4"><h4>Views and constraints</h4></li><li class="sect1" title="9.5"><h4>Update operations</h4></li><li class="sect1" title="9.6"><h4>What are views for?</h4></li><li class="sect1" title="9.7"><h4>Views and snapshots</h4></li><li class="sect1" title="9.8"><h4>Exercises</h4></li><li class="sect1" title="9.9"><h4>Answers</h4></li></ol></li><li class="chapter" title="10"><h3><span class="chapter-label">Chapter 10</span>SQL and Logic</h3><ol><li class="sect1" title="10.1"><h4>Why do we need logic?</h4></li><li class="sect1" title="10.2"><h4>Simple and compound propositions</h4></li><li class="sect1" title="10.3"><h4>Simple and compound predicates</h4></li><li class="sect1" title="10.4"><h4>Quantification</h4></li><li class="sect1" title="10.5"><h4>Relational calculus</h4></li><li class="sect1" title="10.6"><h4>More on quantification</h4></li><li class="sect1" title="10.7"><h4>Some equivalences</h4></li><li class="sect1" title="10.8"><h4>Concluding remarks</h4></li><li class="sect1" title="10.9"><h4>Exercises</h4></li><li class="sect1" title="10.10"><h4>Answers</h4></li></ol></li><li class="chapter" title="11"><h3><span class="chapter-label">Chapter 11</span>Using Logic to Formulate SQL Expressions</h3><ol><li class="sect1" title="11.1"><h4>Some transformation laws</h4></li><li class="sect1" title="11.2"><h4>Example 1: Logical implication</h4></li><li class="sect1" title="11.3"><h4>Example 2: Universal quantification</h4></li><li class="sect1" title="11.4"><h4>Example 3: Implication and universal quantification</h4></li><li class="sect1" title="11.5"><h4>Example 4: Correlated subqueries</h4></li><li class="sect1" title="11.6"><h4>Example 5: Naming subexpressions</h4></li><li class="sect1" title="11.7"><h4>Example 6: More on naming subexpressions</h4></li><li class="sect1" title="11.8"><h4>Example 7: Dealing with ambiguity</h4></li><li class="sect1" title="11.9"><h4>Example 8: Using COUNT</h4></li><li class="sect1" title="11.10"><h4>Example 9: Another variation</h4></li><li class="sect1" title="11.11"><h4>Example 10: UNIQUE quantification</h4></li><li class="sect1" title="11.12"><h4>Example 11: ALL or ANY comparisons</h4></li><li class="sect1" title="11.13"><h4>Example 12: GROUP BY and HAVING</h4></li><li class="sect1" title="11.14"><h4>Exercises</h4></li><li class="sect1" title="11.15"><h4>Answers</h4></li></ol></li><li class="chapter" title="12"><h3><span class="chapter-label">Chapter 12</span>Miscellaneous SQL Topics</h3><ol><li class="sect1" title="12.1"><h4>SELECT *</h4></li><li class="sect1" title="12.2"><h4>Explicit tables</h4></li><li class="sect1" title="12.3"><h4>Dot qualification</h4></li><li class="sect1" title="12.4"><h4>Range variables</h4></li><li class="sect1" title="12.5"><h4>Subqueries</h4></li><li class="sect1" title="12.6"><h4>&#8220;Possibly nondeterministic&#8221; expressions</h4></li><li class="sect1" title="12.7"><h4>Empty sets</h4></li><li class="sect1" title="12.8"><h4>A simplified BNF grammar</h4></li><li class="sect1" title="12.9"><h4>Exercises</h4></li><li class="sect1" title="12.10"><h4>Answers</h4></li></ol></li><li class="appendix" title=""><h3><span class="chapter-label">Appendix </span>The Relational Model</h3><ol><li class="sect1" title="12.1"><h4>The relational model vs. others</h4></li><li class="sect1" title="12.2"><h4>The significance of theory</h4></li><li class="sect1" title="12.3"><h4>The relational model defined</h4></li><li class="sect1" title="12.4"><h4>Database variables</h4></li><li class="sect1" title="12.5"><h4>Objectives of the relational model</h4></li><li class="sect1" title="12.6"><h4>Some database principles</h4></li><li class="sect1" title="12.7"><h4>What remains to be done?</h4></li></ol></li><li class="appendix" title=""><h3><span class="chapter-label">Appendix </span>SQL Departures from the Relational Model</h3></li><li class="appendix" title=""><h3><span class="chapter-label">Appendix </span>A Relational Approach to Missing Information</h3><ol><li class="sect1" title="12.1"><h4>Vertical decomposition</h4></li><li class="sect1" title="12.2"><h4>Horizontal decomposition</h4></li><li class="sect1" title="12.3"><h4>What do the shaded entries mean?</h4></li><li class="sect1" title="12.4"><h4>Constraints</h4></li><li class="sect1" title="12.5"><h4>Queries</h4></li><li class="sect1" title="12.6"><h4>More on predicates</h4></li><li class="sect1" title="12.7"><h4>Exercises</h4></li><li class="sect1" title="12.8"><h4>Answers</h4></li></ol></li><li class="appendix" title=""><h3><span class="chapter-label">Appendix </span>A Tutorial D Grammar</h3></li><li class="appendix" title=""><h3><span class="chapter-label">Appendix </span>Summary of Recommendations</h3></li><li class="appendix" title=""><h3><span class="chapter-label">Appendix </span>NoSQL and Relational Theory</h3><ol><li class="sect1" title="12.1"><h4>Functional segmentation</h4></li><li class="sect1" title="12.2"><h4>Sharding</h4></li><li class="sect1" title="12.3"><h4>Eventual consistency</h4></li><li class="sect1" title="12.4"><h4>The Fernandez interview</h4></li></ol></li><li class="appendix" title=""><h3><span class="chapter-label">Appendix </span>Suggestions for Further Reading</h3></li></ol></div></td></tr></table>
    </div>
	
  
  
    <div id="tab_03_2_content" style="display:none;">
      <table width="100%" cellpadding=0 cellspacing=0><tr><td><dl>                                                <dt>Title:</dt>                                                <dd>                                                    <cite property="dc:title">SQL and Relational Theory, 3rd Edition</cite>                                                </dd>                                                <dt>By:</dt>                                                <dd>                                                    <span rel="dc:creator">                                                        <span>                                                            <a about="urn:x-domain:oreilly.com:agent:pdb:1458" href="http://www.oreillynet.com/pub/au/2136" typeof="foaf:Person" rel="foaf:homepage" property="foaf:name" class="authorname">C.J. Date</a>                                                        </span>                                                    </span>                                                </dd>                                                <dt>Publisher:</dt>                                                <dd>                                                    <span property="dc:publisher">O'Reilly Media</span>                                                </dd>                                                <dt>Formats:</dt>                                                <dd>                                                    <ul rel="frbr:embodiment">                                                        <li about="urn:x-domain:oreilly.com:product:9781491941171.BOOK" typeof="frbr:Manifestation">                                                            <span resource="http://purl.oreilly.com/product-types/BOOK" rel="dc:type">Print</span>                                                        </li>                                                        <li about="urn:x-domain:oreilly.com:product:9781491941126.EBOOK" typeof="frbr:Manifestation">                                                            <span resource="http://purl.oreilly.com/product-types/EBOOK" rel="dc:type">Ebook</span>                                                        </li>                                                        <li about="urn:x-domain:oreilly.com:product:9781491941164.SAF" class="last" typeof="frbr:Manifestation">                                                            <span resource="http://purl.oreilly.com/product-types/SAF" rel="dc:type">Safari Books Online</span>                                                        </li>                                                    </ul>                                                </dd>                                                <dt>Print:</dt>                                                <dd about="urn:x-domain:oreilly.com:product:9781491941171.BOOK">                                                    <span datatype="xsd:dateTime" content="2015-11-06" property="dc:issued" class="date">    November 2015    </span>                                                </dd>                                                <dt>Ebook:</dt>                                                <dd about="urn:x-domain:oreilly.com:product:9781491941126.EBOOK">                                                    <span datatype="xsd:dateTime" content="2015-11-09" property="dc:issued" class="date">    November 2015    </span>                                                </dd>                                                <dt>Pages:</dt>                                                <dd about="urn:x-domain:oreilly.com:product:9781491941171.BOOK" property="dc:extent">                    582                </dd>                                                <dt>Print ISBN:</dt>                                                <dd about="urn:x-domain:oreilly.com:product:9781491941171.BOOK" resource="urn:isbn:9781491941171" class="isbn" rel="dc:identifier">978-1-4919-4117-1</dd>                                                <dt class="isbn-10"> | ISBN 10:</dt>                                                <dd>1-4919-4117-0</dd>                                                <dt>Ebook ISBN:</dt>                                                <dd about="urn:x-domain:oreilly.com:product:9781491941126.EBOOK" resource="urn:isbn:9781491941126" class="isbn" rel="dc:identifier">978-1-4919-4112-6</dd>                                                <dt class="isbn-10"> | ISBN 10:</dt>                                                <dd>1-4919-4112-X</dd>                                            </dl></td></tr></table>
    </div>
	
  
  
    <div id="tab_04_2_content" style="display:none;">
      <table width="100%" cellpadding=0 cellspacing=0><tr><td><ol>                                                <li class="author-bio">                                                    <h3>C.J. Date</h3>                                                    <div>                                                        <p>C.J. Date has a stature that is unique within the database industry. C.J. is a prolific writer, and is well-known for his best-selling textbook: An Introduction to Database Systems (Addison Wesley). C.J. is an exceptionally clear-thinking writer who can lay out principles and theory in a way easily understood by his audience.</p>                                                    </div>                                                    <p>                                                        <a href="http://www.oreillynet.com/pub/au/2136">View C.J. Date's full profile page.</a>                                                    </p>                                                </li>                                            </ol></td></tr></table>
    </div>
	
  

  
  

  
  <div style="width:690px;overflow:hidden">

  <table border="0" cellpadding="0" cellspacing="0" class="infoTabs" style="">
    
    <tr>
      <td>

        <table border="0" cellpadding="0" cellspacing="0"  style="border-left: 1px solid #dddddd;">
          <tr>
          
			
			
			
			
			
          
			
			
			
			
			
            
              
              

              
              
                <td id="tab_02_2" class="infoTabOff" onclick="setActiveTab('tab_02_2', 'Table of Contents',2)" valign="top" nowrap>
                  <div>Table of Contents</div>
                </td>
              
            
            
            
		 
          
			
			
			
			
			
            
              
              

              
              
                <td id="tab_03_2" class="infoTabOff" onclick="setActiveTab('tab_03_2', 'Product Details',2)" valign="top" nowrap>
                  <div>Product Details</div>
                </td>
              
            
            
            
		 
          
			
			
			
			
			
            
              
              

              
              
                <td id="tab_04_2" class="infoTabOff" onclick="setActiveTab('tab_04_2', 'About the Author',2)" valign="top" nowrap>
                  <div>About the Author</div>
                </td>
              
            
            
		 
          

          
          
            <td class="infoTabSpacer" style="WIDTH:100%"><img src="/images/oreilly/en_us/global/globalgraphics/spacer01.gif" width="1" height="1" border="0"></td>
          </tr>
        </table>
      </td>
      <td class="infoTabSpacer" style="WIDTH:100%"><img src="/images/oreilly/en_us/global/globalgraphics/spacer01.gif" width="0" height="1" border="0"></td>
    </tr>

    
    <tr>
      
        
        
          <td colspan=2 class="infoTabContent" valign="top">
            <div id="tabContentFixer">
            	<div
            		id="tabContent_2" class="tabContent"
            		style="height:255px;"></div>
            </div>
          </td>
        
        
        
      
    </tr>
  </table>
	</div>
  
  <script>
    // Preloading tab images here.
    

    // Activate the first tab.
    
      
      
        setActiveTab('tab_02_2','',2);
      

      
      
    

  </script>


				</div>
				
				

				<script type="text/javascript">
				<!--

				function setActiveTabB(theTab){

					document.getElementById("tab_01_b").className = "infoTabOff";

					if(document.getElementById("tab_02_b") != null){
						document.getElementById("tab_02_b").className = "infoTabOff";
					}

					if(document.getElementById("tab_03_b") != null){
						document.getElementById("tab_03_b").className = "infoTabOff";
					}


					document.getElementById("tab_01_b_content").style.display = "none";

					if(document.getElementById("tab_02_b") != null){
						document.getElementById("tab_02_b_content").style.display = "none";
					}

					if(document.getElementById("tab_03_b") != null){
						document.getElementById("tab_03_b_content").style.display = "none";
					}


					document.getElementById(theTab).className = "infoTabOn";
					document.getElementById(theTab + "_content").style.display = "block";

				}

				// -->
				</script>
				
			
			
				<div class="relatedContent" style="padding-top: 25px;"><div id="video-preview"/>  <div id="video-preview"/></div>
			
				
				<div class="infoTabs" style="marign-bottom:15px;">

					<table width="100%" cellspacing="0" cellpadding="0" border="0" class="infoTabs">

						<tr>
							<td>

								<table cellspacing="0" cellpadding="0" border="0" style="border-left: 1px solid #dddddd;">
									<tr>

										<td valign="top" onclick="setActiveTabB('tab_01_b')" class="infoTabOn" id="tab_01_b" nowrap="" >
											<div>Recommended for You</div>
										</td>

											

											

										<td style="width: 100%;" class="infoTabSpacer"><img height="1" width="1" border="0" src="/images/oreilly/en_us/global/globalgraphics/spacer01.gif"/></td>
									</tr>
								</table>

							</td>
						</tr>

						<tr>
							<td valign="top" class="infoTabContent" colspan="2">

								<div class="tab_b_content first" id="tab_01_b_content">
									
										
										

										
											
										

























  







<!-- MyBuys Web Recommendation Zone - Place in body element -->


  <div mybuyszone="2"></div>

<!-- End MyBuys Web Recommendation Zone -->
										

























  





<!-- MyBuys Page Parameters Place in body element -->
<script type="text/javascript">
  mybuys.set("productid","0636920046158.IP");
</script>
<!-- End MyBuys Page Parameters -->
										

























  





<!-- MyBuys Page Parameters Place in body element -->


	
		
		
			<script type="text/javascript">
				mybuys.setPageType("PRODUCT_DETAILS");
			</script>
		
	

<!-- End MyBuys Page Parameters -->
								</div>
								

									
								
							</td>
						</tr>
					</table>
				</div>

			
			
				
			
			

			
			 
			 <a name="PowerReview"></a>
			 
				<div><img src="/images/oreilly/en_us/global/globalgraphics/spacer01.gif" width="1" height="25" border=0></div>
				<div class="content-subtitle">Customer Reviews</div>
				<div><img src="/images/oreilly/en_us/global/globalgraphics/spacer01.gif" width="1" height="10" border=0></div>
				
					<script type="text/javascript">
						POWERREVIEWS.display.engine(document, {
							pr_page_id : '0636920046158.IP',
							pr_write_review : '/product/0636920046158/ReviewSubmit.do?sortby=publicationDate?pageId=0636920046158.IP'
						});
					</script>
			
 
		</td>

		<td style="width:10px;">&nbsp;</td>

		<td>
			
			 	
			 

























  







  




	<div>
		
				
				
		

























  













	


	











<script language="javascript">
	function setTarget(ismobile) {
		
		if(ismobile != '' && ismobile=='yes'){
			document.getElementById('mainForm').action="/mobile/addToBasket.do?method=view";
		}else{
			document.getElementById('mainForm').action="/stockAvailability.do?method=view";
		}
		
		 return true;
}

function flyopenLocal(width, height){
    width = (width && !isNaN(width))? width:null;
    height = (height && !isNaN(height))? height:null;
    var winURL = (arguments[2])? arguments[2]:null;
    var winName = (arguments[3])? arguments[3]:"generic";

	//only launch the window if we've got a width, height and url
	if (width && height && winURL){
        var ieIncrement = ((navigator.appName+"").indexOf("Netscape") == -1)? 15:0;
        winName = eval("window.open('"+ winURL +"','"+ winName +"','resizable=yes,scrollbars=yes,width="+ (width + ieIncrement) +",height="+ (height + ieIncrement) +",top=5,left=75')");
		if(winName != null && winName != 'undefined') {
			winName.focus();
		}
	}
}

</script>
<!--Back Order Message if any now using the product in the kit.element ORLY-124-->
<!%--Date now = new Date(); %>

	
			

				
				<div>
						
							
						

























  











<div style="width:272px;height:49px;">
	
	
	
	
		
		
			
				<a href="/category/customer-service/b2g1f.do"><img
					src="/images/oreilly/en_us/local/localgraphics/buytwogetone_off.gif"
					border="0"
					name="buyTwoGetOne"
					alt="Buy 2 Get 1 Free"
					style="float:left"
					onmouseover="this.src='/images/oreilly/en_us/local/localgraphics/buytwogetone_on.gif'"
					onmouseout="this.src='/images/oreilly/en_us/local/localgraphics/buytwogetone_off.gif'"
					/></a>

				<a href="/category/customer-service/free-shipping.do"><img
					src="/images/oreilly/en_us/local/localgraphics/freeshipping_off.gif"
					border="0"
					name="freeShipping"
					alt="Free Shipping"
					style="float:left;margin:0 3px"
					onmouseover="this.src='/images/oreilly/en_us/local/localgraphics/freeshipping_on.gif'"
					onmouseout="this.src='/images/oreilly/en_us/local/localgraphics/freeshipping_off.gif'"
					/></a>

				<a href="/category/customer-service/oreilly-guarantee.do"><img
					src="/images/oreilly/en_us/local/localgraphics/guarantee_off.gif"
					border="0"
					name="guarantee"
					alt="Guarantee"
					style="float:left"
					onmouseover="this.src='/images/oreilly/en_us/local/localgraphics/guarantee_on.gif'"
					onmouseout="this.src='/images/oreilly/en_us/local/localgraphics/guarantee_off.gif'"
					/></a>

		
	
 </div>
				</div>
				
				
			<div id="buyingOptionTable">
				<table cellspacing="0" cellpadding="0" border="0">
				<tr>
					<td style="border-bottom:1px solid #dddddd; ">
						
							<img src="/images/oreilly/en_us/local/headers/main/buyingoptions_mhd.gif" alt="Buying Options" />
							
						
				</td>
				</tr>
				<tr>
				<td>
				
						
		
			
			
			
						
					<div class="goGreen">Immediate Access - Go Digital&nbsp;<a id="goGreen" href="#" onClick="return flyopenLocal(360,600,'http://oreilly.com/store/gogreen.html','goGreen');">what's this?</a></div>
					
					
					
					
						
						
						
								
								
								 
								
									
									
								
								
								
								
								
								<form name="addToBasketForm" method="post" action="/addToBasket.do" onsubmit="document.getElementById('mainForm').pageCategory.value=getVariableValue('eVar4');return validateProductSelection(noQtyMsg, noOptionsMsg, this, 1);" id="mainForm">
										<input type="hidden" name="from" value="detail">
											<div style="position: relative;">
													<input type="hidden" name="pageCategory" value="">
													<table cellspacing="0" cellpadding="0" border="0" id="optionsTable">
													 <tr>
													  <td width="64%" class="optionsTd">
															<input type='hidden' name='productPk' value='148789' />
															
															<input type='hidden' name='optionTypes' value='1' />
															<input type='hidden' name='option' value='100002=100011'/>
															<input type="hidden" name="selectedKitItems" id="selectedKitItems_main_148789" value='28104,149758,151320,1'>
															<div style="float:left;">
																
																	
																	
																
																
																
																	<div float="right" style="font-size: 12px; width: 130px;">
																		
																			
																			
																				
																				
																					
																					Ebook:
																				
																			
																		  
																		 
																			
																			
																			
																			
																			
																			
																				<span class="price">&nbsp;$33.99</span>
																			
																		
																		</div>
																
																
																
																
																	
																			<span style="font-size:11px;">Formats:&nbsp;</span>
																			<a id="availableFormats" href="#" onClick="javascript:flyopenLocal(480,480,'http://oreilly.com/store/ebooks.html','AvailableFormats');  return false;">
																			DAISY, ePub, Mobi, PDF </a>
																	
																
																
																
																
																<div class="accQtyBox">
																
																	
																										<div class="tableitem">
																											<input type="hidden" name="qty" id="qty_100011" value="1" size="2" class="quantity"/>
																										</div>
																									
																									
																									
																									
																								
																							</div>
				
																							 <div style="width: 130px;">
																								
				
																								
																							</div>
																							<div>
																							
																						   </div>
																						</td>
																						<td width="36%" class="optionsTd" style="padding-bottom: 0px;">
				
																						<!--ORLY-124-->
																						
																							
																							
																							<!-- ORLY-397 -->
																							
																								
																									
																									
																									
																										
																										
																											
																											
																											<span style="padding-left:8px;"><input type="image" name="addToBasket" alt="Add To Cart"src="/images/oreilly/en_us/local/localbuttons/addtobasket_btn.gif" border="0" /></span><div><img src="/images/oreilly/en_us/global/globalgraphics/spacer01.gif" width="1" height="5" border=0></div>
																											
																												
																												
																												
																											
																																																
																										
																									
																								
																							
																							<!-- ORLY-397 -->
																							
																							
																							
																							
																                          
				
				
																						</td>
																					</tr>
																					</table>
																					
																					</div>
																				</form>
																		
						
						
						
								
								
								 
								
									
									
								
								
								
								
								
								<form name="addToBasketForm" method="post" action="/addToBasket.do" onsubmit="document.getElementById('mainForm').pageCategory.value=getVariableValue('eVar4');return validateProductSelection(noQtyMsg, noOptionsMsg, this, 1);" id="mainForm">
										<input type="hidden" name="from" value="detail">
											<div style="position: relative;">
													<input type="hidden" name="pageCategory" value="">
													<table cellspacing="0" cellpadding="0" border="0" id="optionsTable">
													 <tr>
													  <td width="64%" class="optionsTd">
															<input type='hidden' name='productPk' value='148789' />
															
															<input type='hidden' name='optionTypes' value='1' />
															<input type='hidden' name='option' value='100002=100013'/>
															<input type="hidden" name="selectedKitItems" id="selectedKitItems_main_148789" value='28106,149758,151320,1||28105,148788,150107,1'>
															<div style="float:left;">
																
																	
																	
																
																
																
																	<div float="right" style="font-size: 12px; width: 130px;">
																		
																			
																			
																				
																				
																					
																					Print &amp; Ebook:
																				
																			
																		  
																		 
																			
																			
																			
																			
																			
																			
																				<span class="price">&nbsp;$43.99</span>
																			
																		
																		</div>
																
																
																
																
																	
																
																
																
																
																<div class="accQtyBox">
																
																	
																										<div class="tableitem">
																											<input type="hidden" name="qty" id="qty_100013" value="1" size="2" class="quantity"/>
																										</div>
																									
																									
																									
																									
																								
																							</div>
				
																							 <div style="width: 130px;">
																								
				
																								
																							</div>
																							<div>
																							
																						   </div>
																						</td>
																						<td width="36%" class="optionsTd" style="padding-bottom: 0px;">
				
																						<!--ORLY-124-->
																						
																							
																							
																							<!-- ORLY-397 -->
																							
																								
																									
																									
																									
																										
																										
																											
																											
																											<span style="padding-left:8px;"><input type="image" name="addToBasket" alt="Add To Cart"src="/images/oreilly/en_us/local/localbuttons/addtobasket_btn.gif" border="0" /></span><div><img src="/images/oreilly/en_us/global/globalgraphics/spacer01.gif" width="1" height="5" border=0></div>
																											
																												
																												
																												
																											
																																																
																										
																									
																								
																							
																							<!-- ORLY-397 -->
																							
																							
																							
																							
																                          
				
				
																						</td>
																					</tr>
																					</table>
																					
																					</div>
																				</form>
																		
						
						
						
								
								
								 
								
									
									
								
								
								
								
								
								<form name="addToBasketForm" method="post" action="/addToBasket.do" onsubmit="document.getElementById('mainForm').pageCategory.value=getVariableValue('eVar4');return validateProductSelection(noQtyMsg, noOptionsMsg, this, 1);" id="mainForm">
										<input type="hidden" name="from" value="detail">
											<div style="position: relative;">
													<input type="hidden" name="pageCategory" value="">
													<table cellspacing="0" cellpadding="0" border="0" id="optionsTable">
													 <tr>
													  <td width="64%" class="optionsTd">
															<input type='hidden' name='productPk' value='148789' />
															
															<input type='hidden' name='optionTypes' value='1' />
															<input type='hidden' name='option' value='100002=100012'/>
															<input type="hidden" name="selectedKitItems" id="selectedKitItems_main_148789" value='27460,148788,150107,1'>
															<div style="float:left;">
																
																	
																	
																
																
																
																	<div float="right" style="font-size: 12px; width: 130px;">
																		
																			
																			
																				
																				
																					
																					Print:
																				
																			
																		  
																		 
																			
																			
																			
																			
																			
																			
																				<span class="price">&nbsp;$39.99</span>
																			
																		
																		</div>
																
																
																
																
																	
																
																
																
																
																<div class="accQtyBox">
																
																	
																									
																									
																									
																										<div class="tableitem">
																											<input type="text" name="qty" id="qty_100012" value="1" size="2" maxlength="2" class="quantity"/>
																										</div>
																									
																								
																							</div>
				
																							 <div style="width: 130px;">
																								
																									
																										
																									
																								
				
																								
																							</div>
																							<div>
																							
																						   </div>
																						</td>
																						<td width="36%" class="optionsTd" style="padding-bottom: 0px;">
				
																						<!--ORLY-124-->
																						
																							
																							
																							<!-- ORLY-397 -->
																							
																								
																									
																									
																									
																										
																										
																											
																											
																											<span style="padding-left:8px;"><input type="image" name="addToBasket" alt="Add To Cart"src="/images/oreilly/en_us/local/localbuttons/addtobasket_btn.gif" border="0" /></span><div><img src="/images/oreilly/en_us/global/globalgraphics/spacer01.gif" width="1" height="5" border=0></div>
																											
																												
																												
																												
																											
																																																
																										
																									
																								
																							
																							<!-- ORLY-397 -->
																							
																							
																                          
				
				
																						</td>
																					</tr>
																					</table>
																					
																					</div>
																				</form>
																		
				
			
			
														
															<tr>
																<td class="links" colspan="2" style="border-bottom: 1px solid #ddd;">
														
														
															
																
																
																	Safari Books Online - <a target="_blank" href="https://www.safaribooksonline.com/library/view/_/9781491941164/?utm_medium=referral&amp;utm_campaign=publisher&amp;utm_source=oreilly&amp;utm_content=book+page">Read now ></a>
																
															
														
														
														
																</td>
															</tr>
														
													
				
				
			
			
	
	</td>
</tr>

</table>
</div>

	</div>
	
	<div>
	
		<div class="relatedLink"><div id="related-links">                                            <div class="box-heading">Essential Links</div>                                            <ul>                                                <li class="strong">                                                    <a href="http://oreilly.com/register/">Register Your Book</a>                                                </li>                                                <li>                                                    <a href="http://oreilly.com/catalog/errata.csp?isbn=0636920046158" class="errata-link" rel="nofollow">View/Submit Errata</a>                                                </li>                                                <li>                                                    <a href="http://oreilly.com/catalog/praise.csp?isbn=0636920046158" class="errata-link" rel="nofollow">Media Praise</a>                                                </li>                                                <li>                                                    <a href="http://getsatisfaction.com/oreilly/">Ask a Question</a>                                                </li>                                                <li>                                                    <a href="http://oreilly.com/corporate/">Bulk Discounts &amp; Licensing</a>                                                </li>                                            </ul>                                        </div></div>
	
	</div>
	
		
	 	
	 

























  







  







<div>
	
</div>
	 
	 
	 	
	 	
	 

























  







  







<div>
	
</div>
	 
	 
	 	
	 	
	 

























  







  







<div>
	
</div>
	


		</td>
</tr>
</table>




<style>
.mbzone2 .mbzonetitle {display: none; !important;}
</style>

	
	
</div>
    </td>
    <td width="8" class="contentbg"><img src="/images/oreilly/en_us/global/globalgraphics/spacer01.gif" width="8" height=1 border=0></td>
  </tr>

	
	<tr>
		<td colspan="3" class="eightPixel">&nbsp;</td>
	</tr>



  <tr valign="bottom">
    <td align="center" colspan="3" class="navfooterbg">

























  











  
  
  	
    	<!--BottomNav Start-->


























  









	<!-- autocomplete scripts --> 
<script type="text/javascript" src="//ajax.googleapis.com/ajax/libs/yui/2.6.0/build/utilities/utilities.js"></script> 
<script type="text/javascript" src="//ajax.googleapis.com/ajax/libs/yui/2.6.0/build/datasource/datasource-min.js"></script> 
<script type="text/javascript" src="//ajax.googleapis.com/ajax/libs/yui/2.6.0/build/autocomplete/autocomplete-min.js"></script> 
<script type="text/javascript" src="//content.atomz.com/sp10049ed9/publish/autocomplete_data.js?sp_js_cache_ver=14"></script>










	

	

	

	






	



	<!-- ncs 3141 071014 --><table border="0" cellspacing="0" cellpadding="0" class="emailSignUpTable">
  <tr>
    <td style="width:516px;">
    
    </td>

    <td>
    
    </td>

    <td style="text-align:right">
      <ul class="utility">
        <li><a class="twitter" href="http://twitter.com/oreillymedia" target="_blank"><span class="hidden">Twitter</span></a></li>
        <li><a class="youtube" href="http://youtube.com/oreillymedia" target="_blank"><span class="hidden">YouTube</span></a></li>
        <li><a class="slideshare" href="http://slideshare.net/oreillymedia" target="_blank"><span class="hidden">Slideshare</span></a></li>
        <li><a class="facebook" href="http://www.facebook.com/OReilly" target="_blank"><span class="hidden">Facebook</span></a></li>
        <li><a class="googleplus" href="https://plus.google.com/108442503368488643007?prsrc=3"><span class="hidden">Google Plus</span></a></li>
        <li><a class="rss" href="http://feeds.feedburner.com/oreilly/all" target="_blank"><span class="hidden">RSS</span></a></li>
        <li><a class="all-rss" href="http://oreilly.com/feeds/">View All RSS Feeds &gt;</a></li>
      </ul>
    </td>
  </tr>
</table>





<div id="multiColumnFooter">

	<div id="footer-branding">
		<p class="copyright">&copy; 2016, O'Reilly Media, Inc.</p>
<p><span class="phone-number">(707) 827-7019</span><span class="phone-number">(800) 889-8969</span></p>
<p class="trademarks">All trademarks and registered trademarks appearing on oreilly.com are the property of their respective owners.</p><!-- 2013 -->

	</div>

	
	<div class="contentSectionBlock">
		
			
				

				<!-- style="width:25%;" -->

				<div class="contentSectionContainer" >
					<span id="footerColumn-1" class="contentSection">
						<h3>About O'Reilly</h3>
						<ul>
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://oreilly.com/academic/">Academic Solutions</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://oreilly.com/jobs/">Jobs</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://oreilly.com/contact.html">Contacts</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://oreilly.com/about/">Corporate Information</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://press.oreilly.com/index.html">Press Room</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://oreilly.com/oreilly/privacy.csp">Privacy Policy</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://oreilly.com/terms/">Terms of Service</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://oreilly.com/oreilly/author/intro.csp">Writing for O'Reilly</a></li>
									
									
								
							
						
						</ul>
					</span>
				</div>
			
		
			
				

				<!-- style="width:25%;" -->

				<div class="contentSectionContainer" >
					<span id="footerColumn-2" class="contentSection">
						<h3>Community</h3>
						<ul>
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://oreilly.com/authors/">Authors</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://oreilly.com/community/">Community & Featured Users</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://forums.oreilly.com/">Forums</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="https://members.oreilly.com/">Membership</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://elists.oreilly.com/">Newsletters</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://answers.oreilly.com/">O'Reilly Answers</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://oreilly.com/feeds/">RSS Feeds</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://ug.oreilly.com/">User Groups</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://chimera.labs.oreilly.com/">O'Reilly Chimera (beta)</a></li>
									
									
								
							
						
						</ul>
					</span>
				</div>
			
		
			
				

				<!-- style="width:25%;" -->

				<div class="contentSectionContainer" >
					<span id="footerColumn-3" class="contentSection">
						<h3>Partner Sites</h3>
						<ul>
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://makezine.com/">makezine.com</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://makerfaire.com/">makerfaire.com</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://craftzine.com/">craftzine.com</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://www.ignitetalks.io/">Ignite Talks</a></li>
									
									
								
							
						
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://blogs.forbes.com/oreillymedia/">O'Reilly Insights on Forbes.com</a></li>
									
									
								
							
						
							
						
							
						
						</ul>
					</span>
				</div>
			
		
			
				

				<!-- style="width:24%;" -->

				<div class="contentSectionContainer" >
					<span id="footerColumn-4" class="contentSection">
						<h3>Shop O'Reilly</h3>
						<ul>
						
							
								
								
								
									
									
									
								<li><a class="footer" href="/category/customer-service.do">Customer Service</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="/category/customer-service.do">Contact Us</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="/category/customer-service/shipping-information.do">Shipping Information</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="/category/customer-service/ordering-payment.do">Ordering & Payment</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://oreilly.com/affiliates/">Affiliate Program</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="/category/customer-service/oreilly-guarantee.do">The O'Reilly Guarantee</a></li>
									
									
								
							
						
							
						
							
						
							
						
						</ul>
					</span>
				</div>
			
		
		<div style="clear:both;"></div>
	</div>

	
	

	
	
</div>
<!--BottomNav End-->


    
  

  
  

  
  
  
  
  


</td>
  </tr>
</table>


  

























  










      

























  







<!-- Omniture Reporting Support -->
<!-- SiteCatalyst code version: H.20.3.
Copyright 1997-2009 Omniture, Inc. More info available at
http://www.omniture.com -->

<script language="JavaScript">
function getId() {
  return "ororeilly,orglobal"
}
function getSerializationID() {
  return "6639123"
}
</script>
<script language="JavaScript" type="text/javascript" src="/text/omniture/js/s_code.js"></script>
<script language="JavaScript" type="text/javascript" src="/omniture/parseOmnitureJSON.js"></script>
<script language="JavaScript" type="text/javascript"><!--



    var oOmnitureJSON = {"eVar4":"Product Detail","eVar5":"Product Detail","pageName":"oreilly:store:sql and relational theory 3rd edition","eVar3":"Product Detail","eVar8":"DEAL","prop2":"oreilly:store:product detail","prop1":"oreilly:store","eVar6":"Product Detail","events":{"prodView":null,"event3":null,"event18":null},"prop5":"sql and relational theory 3rd edition","prop6":"0636920046158","prop3":"oreilly:store:product detail:product detail","prop4":"product detail","products":[{"eVars":{},"pricePerUnit":null,"subTotal":null,"events":{},"name":"SQL and Relational Theory 3rd Edition","quantity":null,"code":"0636920046158.IP"}],"channel":"oreilly"};

    parseOmnitureJSON(oOmnitureJSON);

/************* DO NOT ALTER ANYTHING BELOW THIS LINE ! **************/
var s_code=s.t();if(s_code)document.write(s_code)//--></script>
<script language="JavaScript" type="text/javascript"><!--
if(navigator.appVersion.indexOf('MSIE')>=0)document.write(unescape('%3C')+'\!-'+'-')
//--></script><noscript><a href="http://www.omniture.com" title="Web Analytics"><img
src="http://ororeilly,orglobal.122.2O7.net/b/ss/ororeilly,orglobal/1/H.20.3--NS/0"
height="1" width="1" border="0" alt="" /></a></noscript><!--/DO NOT REMOVE/-->
<!-- End SiteCatalyst code version: H.20.3. -->
<!-- End, Omniture Reporting Support -->




      

























  







<!-- Google Analytics Reporting Support -->
<!-- Google Analytics More info available at http://www.google.com/analytics/index.html -->
<script language="JavaScript" type="text/javascript" src="/googleanalytics/parseGoogleAnalyticsJSON.js"></script>
<script type="text/javascript"> 
var _gaq = _gaq || []; 
_gaq.push(['_setAccount', 'UA-4591498-1']); 
_gaq.push(['_setDomainName', 'oreilly.com']); 
_gaq.push(['_addIgnoredRef', 'oreilly.com']); 
_gaq.push(['_trackPageview']); 

  
    
  
  (function() { 
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true; 
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js'; 
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s); 
  })(); 

</script> 
<!-- End, Google Analytics Reporting Support -->




 <script type="text/javascript">
var _sf_async_config={uid:1632,domain:"shop.oreilly.com"};
(function(){
  function loadChartbeat() {
    window._sf_endpt=(new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src',
       (("https:" == document.location.protocol) ? "https://a248.e.akamai.net/chartbeat.download.akamai.com/102508/" : "http://static.chartbeat.com/") +
       "js/chartbeat.js");
    document.body.appendChild(e);
  }
  var oldonload = window.onload;
  window.onload = (typeof window.onload != 'function') ?
     loadChartbeat : function() { oldonload(); loadChartbeat(); };
})();

</script> 

<!-- crazyegg -->
<script type="text/javascript">
setTimeout(function(){var a=document.createElement("script"); var b=document.getElementsByTagName("script")[0]; a.src=document.location.protocol+"//dnn506yrbagrg.cloudfront.net/pages/scripts/0011/6381.js?"+Math.floor(new Date().getTime()/3600000); a.async=true;a.type="text/javascript";b.parentNode.insertBefore(a,b)}, 1);
</script>









<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"applicationID":"26513819","applicationTime":68,"beacon":"bam.nr-data.net","queueTime":0,"licenseKey":"85a7277884","transactionName":"b11UZkoDW0ZZVkNeDlYXZUZKF0FGF0VFWAVNW0IdEkg=","agent":"","errorBeacon":"bam.nr-data.net"}</script></body>
<script type="text/javascript" src="/includes/footerScripts.js"></script>
<!-- MyBuys Page Initialization Place after </body> tag -->
<script type="text/javascript">
  mybuys.initPage();
</script>
<!-- End MyBuys Page Initialization -->
</html>