

<!DOCTYPE html>
<html lang="en">
  <head>
    <!-- Google Tag Manager -->
    <script>
    (function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start': new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0], j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src= 'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f); })(window,document,'script','dataLayer','GTM-5P4V6Z');
    </script>
    <!-- End Google Tag Manager -->

    <!-- Start Visual Website Optimizer Asynchronous Code -->
    <script type='text/javascript'>
    var _vwo_code=(function(){
    var account_id=27087,
    settings_tolerance=2000,
    library_tolerance=1500,
    use_existing_jquery=false,
    // DO NOT EDIT BELOW THIS LINE
    f=false,d=document;return{use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&r='+Math.random());var a=d.createElement('style'),b='body{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);return settings_timer;}};}());_vwo_settings_timer=_vwo_code.init();
    </script>
<!-- End Visual Website Optimizer Asynchronous Code -->

    <meta charset="utf-8">
    <meta http-equiv="X-UA-Compatible" content="IE=edge">
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <!-- The above 3 meta tags *must* come first in the head; any other head content must come *after* these tags -->
    <link rel="icon" type="image/png" href="//www.oreilly.com/favicon.ico">
    
      <meta content="15137500430" property="fb:page_id"/>
<meta content="141300433,549810759" property="fb:admins"/>
<meta content="http://covers.oreilly.com/images/0636920049005/bkt.gif" property="og:image"/>
<meta content="book" property="og:type"/>
<meta content="0636920049005" property="og:isbn"/>
<meta content="http://shop.oreilly.com/product/0636920049005.do" property="og:url"/>
<meta content="Arista Warrior" property="og:title"/>
<meta content="summary" name="twitter:card"/>
<meta content="http://shop.oreilly.com/product/0636920049005.do" name="twitter:url"/>
<meta content="Arista Warrior" name="twitter:title"/>
<meta content="In the updated, second edition of this book, renowned consultant and technical author Gary Donahue (Network Warrior) provides an in-depth, objective guide to Arista Network’s lineup of hardwa..." name="twitter:description"/>
<meta content="https://akamaicovers.oreilly.com/images/0636920049005/cat.gif" name="twitter:image"/>
<meta content="OReillyMedia" name="twitter:site"/>
<meta content="Arista Warrior" name="book_title"/>
<meta content="http://shop.oreilly.com/product/mobile/0636920049005.do" name="mobileurl"/>
<meta content="A Real-World Guide to Understanding Arista Switches and EOS" name="subtitle"/>
<meta content="Gary A. Donahue" name="author"/>
<meta content="O'Reilly Media" name="publisher"/>
<meta content="https://akamaicovers.oreilly.com/images/0636920049005/cat.gif" name="graphic_large"/>
<meta content="https://akamaicovers.oreilly.com/images/0636920049005/bkt.gif" name="graphic_medium"/>
<meta content="https://akamaicovers.oreilly.com/images/0636920049005/sm.gif" name="graphic"/>
<meta content="Arista Warrior, 1491953047, 1-4919-5304-7, 9781491953044, 978-1-4919-5304-4" name="target"/>
<meta content="Arista Warrior, , 1-4919-5304-7, 1491953047, 9781491953044, 978-1-4919-5304-4, Gary A. Donahue,oreilly, O'Reilly, o'reilly" name="keywords"/>
<meta content="In the updated, second edition of this book, renowned consultant and technical author Gary Donahue (Network Warrior) provides an in-depth, objective guide to Arista Network’s lineup of hardware, and explains why its network switches and..." name="description"/>
<meta content="Sep. 15, 2017" name="date"/>
<meta content="2017-09-15" name="search_date"/>
<meta content="9781491953044" name="ean"/>
<meta content="0636920049005" name="search_isbn"/>
<meta content="Books" name="Category"/>
<meta content="Format~Format~Format~Publisher" name="SubCategory"/>
<meta content="Print~Rough Cut~Early Release Ebook~O'Reilly Media" name="SubCategory_Value"/>
<meta content="Print~Rough Cut~Early Release Ebook~" name="Format"/>
<meta content="100" name="status"/>
<meta content="2" name="edition"/>
<meta content="2nd Edition" name="edition_full"/>
<meta content="1st Edition,2nd Edition" name="bookeditionsorder"/>
<meta content="0636920022435,0636920049005" name="bookeditionsreference"/>
<meta content="oreilly," name="book.tags"/>
<meta content="book" name="object.type"/>
<meta content="Arista Warrior" name="book.title"/>
<meta content="Gary A. Donahue" name="book.author"/>
<meta content="9781491953044" name="book.isbn"/>
<meta content="http://shop.oreilly.com/product/0636920049005.do" name="book.link"/>
<meta content="http://covers.oreilly.com/images/0636920049005/bkt.gif" name="book.image"/>
<meta content="2017" name="book.year"/>
<meta content="English" name="language_name"/>
<meta content="English" name="native_language_name"/>

    
    
	<title>Arista Warrior,&nbsp;2nd Edition&nbsp;-&nbsp;O'Reilly Media</title>
	<link rel="canonical" href="http://shop.oreilly.com/product/0636920049005.do"/>


    <link rel="shortcut icon" type="image/png" href="#">
    <link rel="stylesheet" type="text/css" href="https://cdn.oreillystatic.com/assets/css/2017_font_face.css" />
    <link rel="stylesheet" type="text/css" href="https://cdn.oreillystatic.com/assets/css/norm-layout-171020.css">
    <link rel="stylesheet" type="text/css" href="https://cdn.oreillystatic.com/assets/css/norm-conferences-170317.css">
    <link type="text/css" rel="stylesheet" href="https://cdn.oreillystatic.com/assets/css/norm-shop-170705.css">
    <script type="text/javascript" src="https://cdn.oreillystatic.com/ajax/libs/jquery/1.7.2/jquery.min.js"></script>
    
  </head>
  <body>
    <!-- Google Tag Manager (noscript) -->
    <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-5P4V6Z" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
    <!-- End Google Tag Manager (noscript) -->
    <header role="banner">
    <div class="branding-bar pa-bg" role="navigation" aria-label="site sections">
      <a href="https://www.oreilly.com" class="logo" title="home page"><img src="//cdn.oreillystatic.com/images/sitewide-headers/oreilly-logo-norm.svg" onerror="this.src='//cdn.oreillystatic.com/images/sitewide-headers/oreilly-logo-reversed-130x23.png'; this.onerror=null;" alt="O'Reilly home"></a>
      <ul class="top-nav" role="menu">
        <li role="menuitem"><a href="https://www.oreilly.com/ideas">Ideas</a></li>
        <li role="menuitem"><a href="https://www.oreilly.com/online-learning/?utm_medium=content&utm_source=oreilly.com&utm_campaign=lgen&utm_content=20170601+nav">Learning Platform</a></li>
        <li role="menuitem"><a href="https://www.oreilly.com/conferences/">Conferences</a></li>
        <li role="menuitem"><a href="https://shop.oreilly.com/">Shop</a></li>
      </ul>
      <div class="right">
        <div class="search-nav">
          <form class="search-form" action="https://ssearch.oreilly.com" method="GET" role="search">
            <label for="qd"><span class="screen-reader-text">Search terms</span></label>
            <input class="transparent" name="q" id="qd" type="text" placeholder="Search..." value="">
            <a class="search-cta">
              <span class="icon-search icon--white">
                <svg viewBox="0 0 20 20" id="search" height="24px" width="19px">
                  <title>Search</title>
                  <path d="M17.545 15.467l-3.78-3.78a6.15 6.15 0 0 0 .9-3.21c0-3.416-2.962-6.376-6.38-6.376S2.1 4.87 2.1 8.288c0 3.416 2.96 6.377 6.377 6.377 1.137 0 2.2-.31 3.115-.844l3.8 3.8c.37.372.974.372 1.345 0l.943-.942c.37-.37.236-.84-.135-1.21zm-13.54-7.18c0-2.366 1.916-4.283 4.28-4.283S12.76 6.11 12.76 8.478c0 2.365-1.918 4.283-4.283 4.283s-4.473-2.108-4.473-4.473z"></path>
                </svg>
              </span>
            </a>
            <input class="hide" type="submit" value="Submit">
          </form>
        </div>

        <div id="user">
          <a href="https://members.oreilly.com" class="t-c--d" id="log-out">Your Account</a>
        </div>
      </div> <!-- div.right -->

    </div><!-- div.branding_bar -->

    <div id="mobile-menu">

      <input type="checkbox" id="menu-toggle" name="menu-toggle" value="unchecked">
      <label for="menu-toggle">
         <svg viewBox="-449 428 20 20" id="menu" height="34px" width="34px">
            <title>Open menu</title>
            <path d="M-431 433.5c0 .3-.2.5-.5.5h-15c-.3 0-.5-.2-.5-.5v-1c0-.3.2-.5.5-.5h15c.3 0 .5.2.5.5v1zM-431 438.5c0 .3-.2.5-.5.5h-15c-.3 0-.5-.2-.5-.5v-1c0-.3.2-.5.5-.5h15c.3 0 .5.2.5.5v1zM-431 443.5c0 .3-.2.5-.5.5h-15c-.3 0-.5-.2-.5-.5v-1c0-.3.2-.5.5-.5h15c.3 0 .5.2.5.5v1z"></path>
          </svg>
          <svg viewBox="-489 391 20 20" id="close" height="34px" width="34px">
            <title>Close menu</title>
            <path d="M-477.6 401l4.6-4.6c.2-.2.2-.5 0-.7l-.7-.7c-.2-.2-.5-.2-.7 0l-4.6 4.6-4.6-4.6c-.2-.2-.5-.2-.7 0l-.7.7c-.2.2-.2.5 0 .7l4.6 4.6-4.6 4.6c-.2.2-.2.5 0 .7l.7.7c.2.2.5.2.7 0l4.6-4.6 4.6 4.6c.2.2.5.2.7 0l.7-.7c.2-.2.2-.5 0-.7l-4.6-4.6z"></path>
          </svg>
      </label>

      <div class="mobile-nav" role="navigation" aria-label="site sections">
        <ul class="mobile-top-nav">
          <li><a href="https://www.oreilly.com/ideas">Ideas</a></li>
          <li><a href="https://www.oreilly.com/online-learning/?utm_medium=content&utm_source=oreilly.com&utm_campaign=lgen&utm_content=20170601+nav">Learning Platform</a></li>
          <li><a href="https://www.oreilly.com/conferences/">Conferences</a></li>
          <li><a href="https://shop.oreilly.com/">Shop</a></li>
        </ul>

        <div class="search-nav">
          <form class="search-form--m" action="https://ssearch.oreilly.com" method="GET" role="search">
            <label for="qm"><span class="screen-reader-text">Search terms</span></label>
            <input class="transparent" name="q" id="qm" type="text" placeholder="Search..." value="">
            <a class="search-cta--m">
              <span class="icon-search icon--black">
                <svg viewBox="0 0 20 20" id="search" height="24px" width="19px">
                  <title>Search</title>
                  <path d="M17.545 15.467l-3.78-3.78a6.15 6.15 0 0 0 .9-3.21c0-3.416-2.962-6.376-6.38-6.376S2.1 4.87 2.1 8.288c0 3.416 2.96 6.377 6.377 6.377 1.137 0 2.2-.31 3.115-.844l3.8 3.8c.37.372.974.372 1.345 0l.943-.942c.37-.37.236-.84-.135-1.21zm-13.54-7.18c0-2.366 1.916-4.283 4.28-4.283S12.76 6.11 12.76 8.478c0 2.365-1.918 4.283-4.283 4.283s-4.473-2.108-4.473-4.473z"></path>
                </svg>
              </span>
            </a>
            <input class="hide" type="submit" value="Submit">
          </form>
        </div>
      </div>
    </div>

    </header>
    <main role="main" id="maincontent">
      <div class="title-row">
      <a href="/" style="display:inline-block;"><h2 class="title">Books &amp; Videos</h2></a>
      <form name="searchform" method="get" id="search-form" action="https://ssearch.oreilly.com/">
					<div class="search">
					<fieldset>
						<span id="search-input">
							<div class="searchInput">
								<span id="search-field"><input type="text" placeholder="" name="q" maxlength="64" id="q" onfocus="this.value=checkIfDefault(this.value);" class="yui-ac-input" autocomplete="off"></span>
							</div>
							<input id="search-button" type="submit" value="Search">
						</span>
						<div id="autocomplete" class="yui-ac-container"><div class="yui-ac-content" style="display: none;"><div class="yui-ac-hd" style="display: none;"></div><div class="yui-ac-bd"><ul><li style="display: none;"></li><li style="display: none;"></li><li style="display: none;"></li><li style="display: none;"></li><li style="display: none;"></li><li style="display: none;"></li><li style="display: none;"></li><li style="display: none;"></li><li style="display: none;"></li><li style="display: none;"></li></ul></div><div class="yui-ac-ft" style="display: none;"></div></div></div>
					</fieldset>
					</div>
			</form>
    </div>
      <div id="banner"></div>

      
	<section id="product-image-detail-links">
		<a href="https://covers.oreillystatic.com/images/0636920049005/lrg.jpg" target="_blank"><img id="product-image" src="https://covers.oreillystatic.com/images/0636920049005/cat.gif" /></a>
			<section id="product-detail">
				<h1 id="product-title">Arista Warrior, 2nd Edition </h1>

		
		<h3>A Real-World Guide to Understanding Arista Products and EOS</h3>
		

		
			<p class="authors">By
			
				
				<a href="http://www.oreillynet.com/pub/au/2906" style="text-decoration: underline;">
					Gary Donahue</a>
				
			
			</p>
		
		<section id="publisher-release-length">
		
			<p><strong>Publisher:</strong> <a href="https://learning.oreilly.com/library/publisher/oreilly-media-inc/?utm_medium=referral&amp;utm_campaign=publisher&amp;utm_source=oreilly&amp;utm_content=catalog&utm_content=catalog">O&#39;Reilly Media</a></p>
		
		
			<p><strong>Release Date:</strong> June 2019</p>
		

		

		
				<p><strong>Pages:</strong> 546</p>
		
		</section>

		<section id="product-links">
			
				<a id="safari-link" href="https://learning.oreilly.com/library/view/arista-warrior/9781491953037/?utm_medium=referral&amp;utm_campaign=publisher&amp;utm_source=oreilly&amp;utm_content=buybox">
					<h4>
						
							Read
						
						on O'Reilly Online Learning with&nbsp;a&nbsp;10-day&nbsp;trial
					</h4>
					<span id="trial-btn" class="btn">Start your free trial<span class="test"> now</span></span>
				</a>
			

			
				<a id="buy-on-amazon" class="btn" href="https://www.amazon.com/s/ref=nb_sb_noss?tag=oreilly20-20&amp;url=search-alias&amp;field-keywords=Arista%20Warrior">Buy on Amazon</a>
			

			<div id="more-info">
				<p class="customer-service-link">
					
						Where’s the cart? Now you can get everything with <a href="https://www.oreilly.com/online-learning/?utm_medium=content&utm_source=oreilly.com&utm_campaign=lgen&utm_content=20170628+catalog+sidebar">O'Reilly Online Learning</a>. To purchase books, visit Amazon or your favorite retailer.
					
					Questions? <a id="customer-service" href="http://shop.oreilly.com/category/customer-service/faq.do">See our FAQ</a> or contact customer service:</p>
				<p class="phone-numbers">1-800-889-8969 / 707-827-7019<br><a href="mailto:support@oreilly.com">support@oreilly.com</a></p>
				
				
				<p><a id="errata-link" href="http://www.oreilly.com/catalog/errata.csp?isbn=0636920049005">View/Submit Errata</a></p>
				

			</div>
		</section>

		<section id="product-description">
		<p>Arista Networks has become a key player when it comes to software-driven cloud networking solutions for large data center storage and computing environments. In this updated edition of <i>Arista Warrior</i>, renowned consultant and technical author Gary Donahue (<i>Network Warrior</i>) provides an in-depth, objective guide to Arista’s lineup of hardware—and explains why its network switches and Extensible Operating System (EOS) are so effective.
<p>
Anyone with a CCNA or equivalent knowledge will benefit from this book, especially entrenched administrators, engineers, or architects tasked with building an Arista network. Is Arista right for your data center? Pick up this in-depth guide and find out. 
<p>
Topics include:
<ul>
<li><b>SysDB:</b> the EOS system database that holds state, statuses, and variables
<li><b>Multichassis Link Aggregation (MLAG):</b> for linking a port-channel to multiple switches instead of just one
<li><b>Latency Analyzer (LANZ):</b> the interface-buffer troubleshooting tool with a reporting granularity of one millisecond
<li><b>VM Tracer:</b> for adding, changing, and removing VLANs without human interaction
<li><b>Zero-Touch Provisioning (ZTP):</b> for remote switch configuration
<li><b>Hardware advantages:</b> including merchant silicon, low-latency networking, and power consumption
<li><b>Gotchas:</b> issues with Arista switches or systems
</ul>
		</section>
		</section><!-- product-detail-->
	</section>

	




    </main>
    <footer role="contentinfo">

    <div class="footer-top">
      <div class="footer-inner">

        <div class="about-us" role="navigation" aria-label="company info">
          <h3 class="title">About Us</h3>
          <ul role="menu">
            <li role="menuitem"><a href="https://www.oreilly.com/about/">Our Company</a></li>
            <li role="menuitem"><a href="https://www.oreilly.com/work-with-us.html">Teach/Speak/Write</a></li>
            <li role="menuitem"><a href="https://www.oreilly.com/careers/"> Careers </a></li>
            <li role="menuitem"><a href="https://shop.oreilly.com/category/customer-service.do">Customer Service</a></li>
            <li role="menuitem"><a href="https://www.oreilly.com/about/contact.html">Contact Us</a></li>
          </ul>
        </div>

        <div class="social" role="navigation" aria-label="social media links">
          <ul role="menu">
            <li role="menuitem">
              <a class="icon-link" href="https://twitter.com/oreillymedia">
                <span class="icon icon-twitter t-fill icon--white">
                  <svg id="twitter" xmlns="https://www.w3.org/2000/svg" width="24.61" height="20" viewBox="0 0 24.61 20"><title>Twitter</title><path d="M22.09,5c0,.22,0,.44,0,.65A14.27,14.27,0,0,1,7.74,20,14.28,14.28,0,0,1,0,17.73a10.54,10.54,0,0,0,1.2.07,10.13,10.13,0,0,0,6.27-2.16,5.06,5.06,0,0,1-4.72-3.5A5.16,5.16,0,0,0,5,12,5.06,5.06,0,0,1,1,7.1V7a5,5,0,0,0,2.29.63A5,5,0,0,1,1.71.92,14.33,14.33,0,0,0,12.12,6.2,5.1,5.1,0,0,1,12,5a5,5,0,0,1,5-5h0a5,5,0,0,1,3.69,1.59A10.17,10.17,0,0,0,23.93.37a5.07,5.07,0,0,1-2.22,2.79,10.1,10.1,0,0,0,2.9-.79A10.2,10.2,0,0,1,22.09,5Z"></path></svg>
                </span>
              </a>
            </li><li role="menuitem">
              <a class="icon-link" href="https://www.facebook.com/OReilly/">
                <span class="icon icon-facebook t-fill icon--white">
                  <svg id="facebook" xmlns="https://www.w3.org/2000/svg" width="11.11" height="20" viewBox="0 0 11.11 20"><title>Facebook</title><path d="M11.11,3.48H7.94c-.38,0-.79.49-.79,1.15V6.92h4l-.6,3.27H7.14V20H3.4V10.19H0V6.92H3.4V5A4.71,4.71,0,0,1,7.94,0h3.17V3.48Z"></path></svg>
                </span>
              </a>
            </li><li role="menuitem">
              <a class="icon-link" href="https://www.linkedin.com/company/o%27reilly-media">
                <span class="icon icon-linkedin t-fill icon--white">
                  <svg id="linkedin" xmlns="https://www.w3.org/2000/svg" width="20" height="20" viewBox="0 0 20 20"><title>LinkedIn</title><path d="M4.46,2.29A2.07,2.07,0,0,1,2.29,4.46,2.07,2.07,0,0,1,.13,2.29,2.26,2.26,0,0,1,2.29,0,2.26,2.26,0,0,1,4.46,2.29ZM0,20V5.61H4.46V20ZM6.5,6.11h3.95L10.7,8h.13A4.79,4.79,0,0,1,15,5.86c2.8,0,5,1.91,5,5.86V20H15.54V12.36c0-1.78-.64-3.06-2.17-3.06a2.18,2.18,0,0,0-2,1.78,2.48,2.48,0,0,0-.13,1V20H6.75V10.45S6.62,7.26,6.5,6.11Z"></path></svg>
                </span>
              </a>
            </li><li role="menuitem">
              <a class="icon-link" href="https://www.youtube.com/user/OreillyMedia">
                <span class="icon icon-youtube-large t-fill icon--white">
                  <svg id="youtube-large" xmlns="https://www.w3.org/2000/svg" width="47.87" height="20" viewBox="0 0 47.87 20"><title>YouTube</title><path d="M16.06,13.89c-.4.54-.69.86-1.06.86s-.34-.09-.4-.37V6.51H12.8v7.66a3.92,3.92,0,0,0,.2,1.4,1.09,1.09,0,0,0,1.14.71c.63,0,1.2-.4,1.91-1.17v1.06h1.83V6.51H16.06v7.37ZM8.91,6.46a2.27,2.27,0,0,0-2,.94,3.88,3.88,0,0,0-.57,2.31v3.43a3.51,3.51,0,0,0,.54,2.2,2.56,2.56,0,0,0,2,1,2.66,2.66,0,0,0,2.06-1,3.51,3.51,0,0,0,.54-2.2V9.66a3.88,3.88,0,0,0-.57-2.31,2.57,2.57,0,0,0-2-.89Zm0,8.31c-.57,0-.86-.49-.77-1.43V9.49c-.09-1,.2-1.4.77-1.4s.86.46.77,1.4v3.83C9.74,14.29,9.46,14.77,8.91,14.77ZM4.69,3.29l-1.31,5L2,3.29H0c.4,1.2,2.4,7.66,2.4,7.66v5.29H4.31V10.94l2.4-7.66ZM36.57,8.06a1.41,1.41,0,0,0-.91.43v5.8a1.24,1.24,0,0,0,.91.43c.49,0,.71-.37.71-1.34V9.31c0-1-.2-1.26-.71-1.26ZM43.71,9.2c0-.89-.23-1.14-.8-1.14s-.83.23-.83,1.14v1.06h1.63Zm3.91-4.89a6.35,6.35,0,0,0-1.11-2.83A4.14,4.14,0,0,0,43.66.29c-4-.29-10-.29-10-.29s-6,0-10,.29a4,4,0,0,0-2.86,1.2,6,6,0,0,0-1.11,2.83,43.12,43.12,0,0,0-.29,4.6v2.14a42.42,42.42,0,0,0,.29,4.6,6.35,6.35,0,0,0,1.11,2.83,4.9,4.9,0,0,0,3.14,1.2c2.23.23,9.66.31,9.66.31s6,0,10-.31a4,4,0,0,0,2.86-1.2,6,6,0,0,0,1.11-2.83,43.12,43.12,0,0,0,.29-4.6V8.91A30.34,30.34,0,0,0,47.63,4.31Zm-22,11.86H23.71v-11h-2V3.34h6V5.17H25.66v11Zm6.89,0H30.69V15.11a2.64,2.64,0,0,1-1.91,1.17,1.21,1.21,0,0,1-1.14-.71,3.92,3.92,0,0,1-.2-1.4V6.6h1.83v7.74c0,.29.14.37.4.37s.66-.31,1.06-.86V6.6h1.83v9.57h0Zm6.6-2.86a7.6,7.6,0,0,1-.17,1.91,1.44,1.44,0,0,1-1.43,1.09,2.53,2.53,0,0,1-1.83-1.09v1H34V3.37h1.71V7.54a2.43,2.43,0,0,1,1.83-1.09,1.45,1.45,0,0,1,1.4,1.11,6.87,6.87,0,0,1,.23,1.91v3.83h0Zm3.83,1.4c.43,0,.66-.23.8-.69,0-.09,0-.51,0-1.2h1.83v.29c0,.54-.06.94-.06,1.11a2.16,2.16,0,0,1-.4,1,2.39,2.39,0,0,1-2.09,1,2.49,2.49,0,0,1-2.09-1,3.49,3.49,0,0,1-.6-2.2V9.8a3.88,3.88,0,0,1,.57-2.31,2.46,2.46,0,0,1,2.06-1,2.37,2.37,0,0,1,2,1,3.65,3.65,0,0,1,.57,2.23v2H42.11V13.4c0,.91.23,1.31.83,1.31Z"></path></svg>
                </span>
              </a>
            </li><li role="menuitem">
              <a class="icon-link" href="https://www.oreilly.com/emails/newsletters/">
                <span class="icon icon-google t-fill icon--white">
                  <svg id="email" xmlns="https://www.w3.org/2000/svg" width="25" height="20" viewBox="0 0 25 20"><title>Newsletters</title><path d="M22.5,0H2.5A2.5,2.5,0,0,0,0,2.5v15A2.51,2.51,0,0,0,2.5,20h20A2.51,2.51,0,0,0,25,17.5V2.5A2.51,2.51,0,0,0,22.5,0Zm0,5-10,6.25L2.5,5V2.5l10,6.25,10-6.25Z"></path></svg>
                </span>
              </a>
            </li>
          </ul>
        </div>
      </div>
    </div>

    <div class="footer-bottom">
      <div class="legal">
        <a href="https://www.oreilly.com" class="logo pa-bg" title="O'Reilly home page"><img src="//cdn.oreillystatic.com/images/sitewide-headers/oreilly-logo-norm.svg" onerror="this.src='//cdn.oreillystatic.com/images/sitewide-headers/oreilly-logo-reversed-130x23.png'; this.onerror=null;" alt="O'Reilly home"></a>
        <p class="copyright">© 2019 O’Reilly Media, Inc. All trademarks and registered trademarks appearing on oreilly.com are the property of their respective owners.</p>
        <br>

        <p class="t-c pa-text"><a href="https://www.oreilly.com/terms/">Terms of Service</a> <span class="bullet">•</span> <a href="https://www.oreilly.com/privacy.html">Privacy Policy</a> <span class="bullet">•</span> <a href="https://www.oreilly.com/about/editorial_independence.html">Editorial Independence</a></p>
      </div>

      <figure class="animal">
        <img class="tarsier" src="//cdn.oreillystatic.com/images/sitewide-headers/tarsier-footer.png" alt="Tarsier">
      </figure>
    </div>

  </footer>
    <!-- search bar - desktop behavior -->
    
      <script src="//cdn.oreillystatic.com/assets/js/norm-search-bar-170221.js" type="text/javascript"></script>

      <script language="JavaScript" type="text/javascript"><!--
      var s_account="ororeilly,orglobal"
      //--></script>
      <!-- SiteCatalyst code version: H.20.2. Copyright 1997-2009 Omniture, Inc. More info available at http://www.omniture.com -->
      <script language="JavaScript" type="text/javascript" src="https://cdn.oreillystatic.com/assets/js/s_code.js"></script>
      <script language="JavaScript" type="text/javascript"><!--
      
	s.pageName="oreilly:store:arista warrior 2nd edition"
    s.channel="oreilly"
    s.events="prodView,event18,event2"
    s.products=";0636920049005.IP;;;"
    s.prop1="oreilly:store"
    s.prop2="oreilly:store:product detail"
    s.prop3="oreilly:store:product detail:product detail"
    s.prop4="product detail"
    s.prop5="arista warrior 2nd edition"
    s.prop6="0636920049005"
    s.prop18="o&#39;reilly media"

      /************* DO NOT ALTER ANYTHING BELOW THIS LINE ! **************/
      var s_code=s.t();if(s_code)document.write(s_code)//--></script>
      <!-- End SiteCatalyst code version: H.20.2. -->
      <!-- analytics.pl: 2017/4/28 7:28:08 -->
    
    </body>
</html>


<script type="text/javascript">
  function checkIfDefault(keyword) {
    var defaultSearchTerm = "Search";
    if(keyword==defaultSearchTerm) {
      return '';
    }
    else {
      return keyword;
    }
  }
</script>
<script type="text/javascript" src="//ajax.googleapis.com/ajax/libs/yui/2.6.0/build/utilities/utilities.js"></script>
<script type="text/javascript" src="//ajax.googleapis.com/ajax/libs/yui/2.6.0/build/datasource/datasource-min.js"></script>
<script type="text/javascript" src="//ajax.googleapis.com/ajax/libs/yui/2.6.0/build/autocomplete/autocomplete-min.js"></script>
<script type="text/javascript" src="//content.atomz.com/sp10049ed9/publish/autocomplete_data.js?sp_js_cache_ver=14"></script>

