

























  












	


























  











  
  
  	
  

  
  

  
  
  
  
  







  


























  





<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">




                 








  
    
  

























  











  
  
  	
    	


























  










 
  
  
    




  



    
  

  
  

  
  
  
  
  



































  











  
  

  
  

  
  
    
  
  
  
  




<html>
    <head>
        

























  









<!--Janrain SSO JavaScripts -->


<!-- Script added to resolve JS error coming on IE-8 for Janrain login -->
<script>
	document.getElementsByClassName = 
	Element.prototype.getElementsByClassName = function(class_names) {
		// Turn input in a string, prefix space for later space-dot substitution
		class_names = (' ' + class_names)
			// Escape special characters
			.replace(/[~!@$%^&*()_+\-=,./';:"?><[\]{}|`#]/g, '\$&')
			// Normalize whitespace, right-trim
			.replace(/\s*(\s|$)/g, '$1')
			// Replace spaces with dots for querySelectorAll
			.replace(/\s/g, '.');
		return this.querySelectorAll(class_names);
	};
</script>



  
  
    
      
    
  


<meta name="SKYPE_TOOLBAR" content="SKYPE_TOOLBAR_PARSER_COMPATIBLE" />

<META http-equiv="Content-Type" content="text/html; charset=UTF-8">



  
     
	        <meta content="15137500430" property="fb:page_id"/>
  <meta content="141300433,549810759" property="fb:admins"/>
  <meta content="http://covers.oreilly.com/images/0636920063698/rc_bkt.gif" property="og:image"/>
  <meta content="book" property="og:type"/>
  <meta content="0636920063698" property="og:isbn"/>
  <meta content="http://shop.oreilly.com/product/0636920063698.do" property="og:url"/>
  <meta content="Learning TensorFlow" property="og:title"/>
  <meta name="twitter:card" content="summary"/>
  <meta name="twitter:url" content="http://shop.oreilly.com/product/0636920063698.do"/>
  <meta name="twitter:title" content="Learning TensorFlow"/>
  <meta name="twitter:description" content="TensorFlow is currently the leading open-source software for deep learning, used by a rapidly growing number of practitioners working on computer vision, Natural Language Processing (NLP), speech r..."/>
  <meta name="twitter:image" content="https://akamaicovers.oreilly.com/images/0636920063698/cat.gif"/>
  <meta name="twitter:site" content="OReillyMedia"/>
  <meta name="book_title" content="Learning TensorFlow"/>
  <meta name="mobileurl" content="http://shop.oreilly.com/product/mobile/0636920063698.do"/>
  <meta name="subtitle" content="A guide to building deep learning systems"/>
  <meta name="author" content="Tom Hope, Yehezkel S. Resheff, Itay Lieder"/>
  <meta name="publisher" content="O'Reilly Media"/>
  <meta name="graphic_large" content="https://akamaicovers.oreilly.com/images/0636920063698/cat.gif"/>
  <meta name="graphic_medium" content="https://akamaicovers.oreilly.com/images/0636920063698/bkt.gif"/>
  <meta name="graphic" content="https://akamaicovers.oreilly.com/images/0636920063698/sm.gif"/>
  <meta name="target" content="Learning TensorFlow, 1491978511, 1-4919-7851-1, 9781491978511, 978-1-4919-7851-1"/>
  <meta name="keywords" content="Learning TensorFlow, , 1-4919-7851-1, 1491978511, 9781491978511, 978-1-4919-7851-1, Tom Hope, Yehezkel S. Resheff, Itay Lieder,oreilly, O'Reilly, o'reilly"/>
  <meta name="description" content="TensorFlow is currently the leading open-source software for deep learning, used by a rapidly growing number of practitioners working on computer vision, Natural Language Processing (NLP), speech recognition, and general predictive analytics. This..."/>
  <meta name="date" content="Jan. 19, 2017"/>
  <meta name="search_date" content="2017-01-19"/>
  <meta name="ean" content="9781491978511"/>
  <meta name="search_isbn" content="0636920063698"/>
  <meta name="Category" content="Books"/>
  <meta name="SubCategory" content="Format~Format~Format~Publisher"/>
  <meta name="SubCategory_Value" content="Print~Safari Books Online~Early Release Ebook~O'Reilly Media"/>
  <meta name="Format" content="Print~Safari Books Online~Early Release Ebook~"/>
  <meta name="status" content="100"/>
  <meta name="edition" content="1"/>
  <meta name="edition_full" content="1st Edition"/>
  <meta name="bookeditionsorder" content="1st Edition"/>
  <meta name="bookeditionsreference" content="0636920063698"/>
  <meta name="book.tags" content="oreilly,"/>
  <meta name="object.type" content="book"/>
  <meta name="book.title" content="Learning TensorFlow"/>
  <meta name="book.author" content="Tom Hope, Yehezkel S. Resheff, Itay Lieder"/>
  <meta name="book.isbn" content="9781491978511"/>
  <meta name="book.link" content="http://shop.oreilly.com/product/0636920063698.do"/>
  <meta name="book.image" content="http://covers.oreilly.com/images/0636920063698/rc_bkt.gif"/>
  <meta name="book.year" content="2017"/>
  <meta name="language_name" content="English"/>
  <meta name="native_language_name" content="English"/>
	
  
  


<title>Learning TensorFlow&nbsp;-&nbsp;O'Reilly Media</title>


  
  
        
  




  
  
        
  






  <link rel="canonical" href="http://shop.oreilly.com/product/0636920063698.do"/>

<script type="text/javascript">var _sf_startpt=(new Date()).getTime()</script>
<script type="text/javascript" src="/includes/jquery/jquery-1.4.min.js"></script>
<script type="text/javascript" src="/includes/jquery/plugins/jquery.hoverIntent.minified.js"></script>
<script type="text/javascript" src="/includes/jquery/plugins/jquery.bgiframe.min.js"></script>
<script type="text/javascript" src="/includes/jquery/plugins/jquery.popDown.js"></script>
<script type="text/javascript" src="/includes/jquery/plugins/jquery.autocomplete.js"></script>




<link href="/mod/productquickview/includes/themes/default.css" rel="stylesheet" type="text/css"></link>
<link href="/mod/productquickview/includes/themes/pqv.css" rel="stylesheet" type="text/css"></link>

<!-- Start Visual Website Optimizer Asynchronous Code -->
<script type='text/javascript'>
var _vwo_code=(function(){
var account_id=27087,
settings_tolerance=2000,
library_tolerance=1500,
use_existing_jquery=false,
// DO NOT EDIT BELOW THIS LINE
f=false,d=document;return{use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&r='+Math.random());var a=d.createElement('style'),b='body{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);return settings_timer;}};}());_vwo_settings_timer=_vwo_code.init();
</script>
<!-- End Visual Website Optimizer Asynchronous Code -->
        

























  











  
  

  
  
    <LINK REL="stylesheet" TYPE="text/css" HREF="/includes/stylesheet.css" TITLE="style" />
  

  
  
  
  
  



        <link rel="shortcut icon" href="/images/oreilly/en_us/shop_favicon_16x16.ico" type="image/vnd.microsoft.icon">
        <script type="text/javascript" src="/includes/headerScripts.js"></script>
        
		

























  





<!-- MyBuys libraries and style sheet - Place in <head> element -->
<link
  href="http://t.p.mybuys.com/css/mbstyles.css"
  type="text/css"
  rel="stylesheet"
  id="mybuysstyles">
<script
  type="text/javascript"
  src="http://t.p.mybuys.com/js/mybuys3.js">
</script>
<script
  type="text/javascript"
  src="http://t.p.mybuys.com/clients/OREILLY/js/setup.js">
</script>


<!-- End MyBuys libraries and style sheet -->
		

























  





<!-- Tracking pixel here -->

    </head>
<body class="main">


<script>var iPop_imagePath='/images/oreilly/en_us/';//use this image path along with the IPop.js</script>
<script src="/includes/lPop.js"></script>
<!-- removing duplicate autocomplete.js ORLY-634 -->
<div id="popdiv"></div>

<table width="990" border="0" cellpadding="0" cellspacing="0" class="mainLayoutTable">

  <tr>
    <td colspan="3" class=navheaderbg>
		  <div>

























  











  
  
  	
    	<!--TopNav Start-->


























  









<script type="text/javascript">
  function checkIfDefault(keyword) {
    var defaultSearchTerm = "Search";
    if(keyword==defaultSearchTerm) {
      return '';
    }
    else {
      return keyword;
    }
  }
</script>


























  











<div id="header" style="width:990px;">

	
	
	
		<div class="logo">
			<a href="http://shop.oreilly.com"><img src="/images/oreilly/en_us/global/globalnav/logo01.gif" border=0 alt="O'Reilly Media, Inc."></a>
		</div>
	



	<div class="tools">
		
		
		
		
		
			
				<p>
					
						
						
							<a href="https://members.oreilly.com/account/emedia" class="signInLinkmy">Your Account</a>
						
					
				</p>				
			
			
		
		
		


























  












<script  type="text/javascript">
jQuery(document).ready(function(){
	jQuery("#globalBasket").popDown({navLink:"/basket.do?nav=%2Fproduct%2Fid%2F253789&gc=1",navOverClass:"globalCartNavOver",closeDelay:300});
});
</script>


<div
	id="globalBasket"
	class="
		popDownWrapper
		globalCartWrapper
		"
	style="
		margin:2px 0px 0px 0px;
		width:239px;
		">

	<div class="popDownNav globalCartNav">

		<div class="globalCartBasketImg" style=""><img src=/images/oreilly/en_us/global/globalgraphics/basketicon.gif border=0 alt=Shopping Cart></div>
		<div class="globalCartBasketInfo" style="">
			<span class="navHeader">Shopping Cart</span>
			<span class="navQty">0 items</span> <span class="navTotal">$0.00</span>
		</div>
	</div>
	<div class="popDownLayer globalCartLayer" style="margin:3px 0px 0px 0px;">

		
		  
		  
			<div class="globalCartEmpty">Your shopping cart is empty.</div>
		  
		

	</div>
</div>


	</div>
				<!-- SP-2014-15990: Begin -->
				
				
				
				
					
				
					
				
					
				
					
				
					
				
					
				
					
				
				
				
				
				

			<div id="search-box" class="yui-skin-sam"> 
			<form name="searchform" method="get" id="search-form" action="https://ssearch.oreilly.com/">
			<div class="search"> 
			<fieldset> 
			<span id="search-input"> 
			<div class="searchInput"> 
			<span id="search-field"><input type="text" value="Search" name="q" value="" maxlength="64" id="q" onFocus="this.value=checkIfDefault(this.value);" /></span> 
			</div> 
			<span id="search-button">
			
				<input
					type="image"
					value="SEARCH"
					src="/images/oreilly/en_us/global/globalgraphics/search_btn.gif"
					border="0"
					style="float:left"
					alt="Search"
					align="top"/>
			 
			</span> 
			</span> 
			<div id="autocomplete"></div> 
			</fieldset> 
			</div> 
			</form> 
			</div> 
				
				
				
				<!-- SP-2014-15990: End -->

</div>




    
  

  
  

  
  
  
  
  


</div>
      <div>

























  











  
  
  	
    	


























  








    <div id="globalInclude" >
		<!-- csp/3201 in ncs was csp/3019 in ocs -->

<!-- Link to the core stylesheet -->
<link rel="stylesheet" type="text/css" href="//shop.oreilly.com/text/oreilly/ml-combined.css">


<style type="text/css">
#start-video-course-wrapper { display: none; }

/* table.mainLayoutTable > tbody > tr:nth-child(2) > td:nth-child(2) > div > table > tbody > tr > td:nth-child(3) { width: 272px;} */
#related-links { width: 272px; }
table.mainLayoutTable > tbody > tr:nth-child(2) > td:nth-child(2) > div > table > tbody > tr > td:nth-child(3) > div:nth-child(1) > div:nth-child(2) { display: none; }

#safariOption { display: block; background: #b9002d; padding:6px 11px 11px; color: #fff; }
#safariOption h3 { margin: 0 0 10px; padding: 0; color: #fff; font-size: 26px; line-height:30px; font-weight:300; letter-spacing:-.01em; font-family: 'guardian-text-oreilly', open-sans, Arial, sans-serif; -webkit-font-smoothing: antialiased; -moz-osx-font-smoothing: grayscale; }
#safariOption a.safari-button { display: block; padding: 8px 10px 7px; background: #fdb815; text-align: center; font-size: 16px; line-height:16px; font-weight:300; color: #000; text-transform: uppercase; letter-spacing:.02em; text-decoration: none; font-family: 'guardian-text-oreilly', open-sans, Arial, sans-serif; -webkit-font-smoothing: antialiased; -moz-osx-font-smoothing: grayscale; }
#safariOption a.safari-button:hover { background: #ffc439; text-decoration: none; }

#buyingOptionTable { display:none; margin-top:0; }
#buyingOptionTable * { font-family: 'guardian-text-oreilly', open-sans, Arial, sans-serif; }
#buyingOptionTable .box-heading {
  background: url(//shop.oreilly.com/images/oreilly/en_us/local/localgraphics/tabgradient_bg.gif) #F4F4F4; padding: 7px 10px 8px; font-size: 16px; line-height:16px; font-weight:600; color: #333; text-transform: uppercase; letter-spacing:.02em; font-family: 'guardian-text-oreilly', open-sans, Arial, sans-serif; }
#buyingOptionTable .goGreen { display: none; }
#buyingOptionTable .price { font-size: 16px; line-height:20px; font-weight:300; letter-spacing:-.01em; }
#buyingOptionTable .accQtyBox { top: 12px; left:150px; }
#buyingOptionTable td.optionsTd:nth-of-type(1) > div > div:nth-of-type(1) { width:140px !important; }
#buyingOptionTable td.optionsTd:nth-of-type(2) { padding: 14px 10px 8px 0px; text-align: right; }
</style>


<!-- Make updates to buybox -->
<script type="text/javascript">
setTimeout(function(){
  if(window.location.href.indexOf("/product/") > -1) {
    var buyingOptionsTable = document.getElementById("buyingOptionTable");

    if (buyingOptionsTable !== null) {
      var buyingOptionsVideo = false;

      //Remove extra spaces in price strings
      var priceNodes = buyingOptionsTable.getElementsByClassName("price");
      for (var i = 0; i < priceNodes.length; i++) {
        priceNodes[i].innerHTML = priceNodes[i].innerHTML.replace(/&nbsp;/,'');
        if (priceNodes[i].previousSibling.nodeValue.indexOf('Video') !== -1) {
          buyingOptionsVideo = true;
        }
      }

      var buyOptionsForms = buyingOptionsTable.getElementsByTagName("form");
      for (var i = 0; i < buyOptionsForms.length; i++) {
        var addToBasketInput = buyOptionsForms[i].getElementsByTagName("input")["addToBasket"];
        if (typeof(addToBasketInput) != 'undefined' && addToBasketInput != null) {
          buyOptionsForms[i].getElementsByTagName("input")["addToBasket"].setAttribute("src", "//cdn.oreillystatic.com/oreilly/images/ml_addtocart_btn.png");
        }
      }

      var buyingOptionHeading = buyingOptionsTable.getElementsByTagName("td")[0];
      if (buyingOptionsTable.getElementsByClassName("links")[0]) {
        //Add Safari block before buyingOptionsTable
        var buyingContainer = buyingOptionsTable.parentNode;
        var safariLink = buyingOptionsTable.getElementsByClassName("links")[0];
        var safariURL = safariLink.getElementsByTagName("a")[0].getAttribute("href");
        safariURL = safariURL.replace("utm_content=book+page","utm_content=buybox");
        var safariContainer = document.createElement('div');
        safariContainer.id = "safariOption";
        if (buyingOptionsVideo) {
          safariContainer.innerHTML = '<h3 class="safari-heading">Watch on Safari with 10-day <strong>free</strong> trial</h3><a href="' + safariURL + '" class="safari-button">Start your free trial</a>';
        } else {
          safariContainer.innerHTML = '<h3 class="safari-heading">Read on Safari with 10-day <strong>free</strong> trial</h3><a href="' + safariURL + '" class="safari-button">Start your free trial</a>';
        }
        buyingContainer.insertBefore(safariContainer, buyingOptionsTable);

        //Remove Safari block from after buyingOptionsTable
        safariLink.parentNode.removeChild(safariLink);
        //Remove buyingOptionTable heading row
        buyingOptionHeading.parentNode.removeChild(buyingOptionHeading);
      } else {
        //Replace image heading for buyingOptions with text
        buyingOptionHeading.innerHTML = '<div class="box-heading">Buying Options</div>';
      }
      
      buyingOptionsTable.style.display = "block";
    }
  }
}, 500);

//Make sure the buying options table is displayed, even if table isn't found in the above script.
jQuery(document).ready(function() {
  jQuery('#buyingOptionTable').css('display','block');
});

//Load Typekit fonts
(function(d) {
  var config = {
    kitId: 'gap0qyx',
    scriptTimeout: 3000,
    async: true
  },
  h=d.documentElement,t=setTimeout(function(){h.className=h.className.replace(/\bwf-loading\b/g,"")+" wf-inactive";},config.scriptTimeout),tk=d.createElement("script"),f=false,s=d.getElementsByTagName("script")[0],a;h.className+=" wf-loading";tk.src='https://fonts.oreillystatic.com/'+config.kitId+'.js';tk.async=true;tk.onload=tk.onreadystatechange=function(){a=this.readyState;if(f||a&&a!="complete"&&a!="loaded")return;f=true;clearTimeout(t);try{Typekit.load(config)}catch(e){}};s.parentNode.insertBefore(tk,s)
})(document);
</script>


<!-- Links to scripts -->
<script type="text/javascript" src="//shop.oreilly.com/text/oreilly/ml-min.js"></script>

<script type="text/javascript">
<!--

//Remove 'Final' from 'Final Release Date' on ER catalog pages
jQuery(document).ready(function() {
  jQuery('#buyingOptionTable').find('#earlyRelease').each(function() {
    var releaseDateDiv = jQuery('.AuthorName').parent('div').find('div:contains("Final Release Date")');
    releaseDateDiv.html(releaseDateDiv.text().replace('Final Release Date','Release Date'));
  });
});

//Hide prices for learning paths and conference video compilations/collections that are only available in Safari
jQuery(document).ready(function() {
  var hideLpTimeoutID = window.setTimeout(hideLpPrice, 100);
  function hideLpPrice() {
    jQuery('.thumbtext > .widthchange > .thumbheader > a:contains("Learning Path: ")').each(function() {
      $(this).closest('.widthchange').children().last('div').remove();
    });
    jQuery('.thumbtext > .widthchange > .thumbheader > a:contains("Video Compilation")').each(function() {
      $(this).closest('.widthchange').children().last('div').remove();
    });
    jQuery('.thumbtext > .widthchange > .thumbheader > a:contains("Video Collection")').each(function() {
      $(this).closest('.widthchange').children().last('div').remove();
    });
    window.clearTimeout(hideLpTimeoutID);
  }
});


//Display Recently Viewed at the bottom of catalog pages
var ormHideRecent = false;
//Loop through active cookies to find dotdpopup
var ormCookieArray = document.cookie.split(";");
var x,y;
for (var i = 0 ; i < ormCookieArray.length; i++) {
  x = ormCookieArray[i].substr(0, ormCookieArray[i].indexOf("="));
  y = ormCookieArray[i].substr(ormCookieArray[i].indexOf("=") + 1);
  x = x.replace(/^\s+|\s+$/g,"");
  if (x == "recentlyviewed") {
    if (y == "hidden") {
      ormHideRecent = true;
    }
  }
}

jQuery(document).ready(function() {
  //Collect all ML generated recently viewed items
  var mlRecentViews = jQuery('.RecentView');

  //If there are 1 or more items, continue
  if (mlRecentViews.length > 0) {
    //Make the base html for the recently viewed section a new object
    var recentlyViewed = jQuery('<div id="recently-viewed"><div class="overlay"><div class="hover-title"></div><div class="group"><a href="#" class="toggle"><span class="text">Recently Viewed</span></a><div class="items"></div></div><div class="bar"></div></div></div>');

    //For each recently viewed item, add a new node
    mlRecentViews.each(function() {
      var item = new Object();
      item.loc = jQuery(this).find('.thumbdiv a').attr('href');
      item.name = jQuery(this).find('.thumbdiv a img').attr('alt');
      item.imgPath = jQuery(this).find('.thumbdiv a img').attr('src').replace('bkt.gif','icon.gif');

      recentlyViewed.find('.items').append('<a href="' + item.loc + '" data-title="' + item.name + '" class="frame"><img src="' + item.imgPath + '" height="55" alt="' + item.name + '" /></a>');
    });

    //Remove ML recently viewed tab and content
    jQuery('body').append(recentlyViewed);
    jQuery('#tab_03_b').add('#tab_03_b_content').remove();
    if (ormHideRecent) {
      recentlyViewed.addClass('minimized');
    }

    //Add margin left to the bar when covers load
    var recentlyViewedGroup = recentlyViewed.find('.group');
    recentlyViewed.find('.frame > img').one('load', function() {
      recentlyViewed.find('.bar').css('margin-left', recentlyViewedGroup.outerWidth(true) + 'px');
    }).each(function() {
      if(this.complete) jQuery(this).load();
    });

    //Display and position titles on hover
    recentlyViewed.find('.frame').hover(function() {
      var hoverPosition = jQuery(this).position().left + (jQuery(this).width() / 2) - (recentlyViewed.find('.hover-title').outerWidth(true) / 2);

      recentlyViewed.find('.hover-title').text(jQuery(this).attr('data-title')).addClass('show').css('left', hoverPosition + 'px');
    }, function() {
      recentlyViewed.find('.hover-title').removeClass('show');
    });

    recentlyViewed.find('.toggle').click(function(e) {
      e.preventDefault();
      e.stopPropagation();

      var ormRecentlyViewedDate = new Date();
      ormRecentlyViewedDate.setTime(ormRecentlyViewedDate.getTime()+(90*24*60*60*1000));
      var ormRecentlyViewedExpires = "; expires="+ormRecentlyViewedDate.toGMTString();
      if (recentlyViewed.hasClass('minimized')) {
        recentlyViewed.removeClass('minimized');
        document.cookie = "recentlyviewed=visible; " + ormRecentlyViewedExpires + "; path=/";
      }
      else {
        recentlyViewed.addClass('minimized');
        document.cookie = "recentlyviewed=hidden; " + ormRecentlyViewedExpires + "; path=/";
      }
    });
  }
});
-->
</script>


<!-- New Nav -->
<!--[if lt IE 9]>
  <script>
    'article aside footer header nav section time'.replace(/\w+/g,function(n){document.createElement(n)})
  </script>
<![endif]-->


<!-- Nav CSS -->
<!-- Not Needed for Actual Site -->
<style type="text/css">

  nav a { text-decoration:none; }
  nav a:hover { text-decoration:underline; }

  nav p { margin:0 0 10px; }
  nav .fsl { font-size:16px; }
  nav .fsxl { font-size:24px; line-height:1.1em; }
  nav .fwb { font-weight:bold; }
  nav .fc-highlight { color:#b9002d; }
  nav .fc-dark { color:#222; }
  nav .fc-light { color:#fff; }
  nav .nm { margin:0; }
  nav .mb { margin-bottom:10px; }
  nav .mr { margin-right:10px; }
  nav .floatl { float:left; }
  nav .clear { clear:both; }

  nav  a.btn-green-arrow { display:block; float:left; padding:5px 10px 5px 22px; line-height:22px; font-size:20px; font-weight:bold; -webkit-border-radius: 4px; -moz-border-radius: 4px; border-radius: 4px; border:1px solid #f2ba12; color:#222; background: rgb(247,209,69); background: url(data:image/svg+xml;base64,PD94bWwgdmVyc2lvbj0iMS4wIiA/Pgo8c3ZnIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgdmlld0JveD0iMCAwIDEgMSIgcHJlc2VydmVBc3BlY3RSYXRpbz0ibm9uZSI+CiAgPGxpbmVhckdyYWRpZW50IGlkPSJncmFkLXVjZ2ctZ2VuZXJhdGVkIiBncmFkaWVudFVuaXRzPSJ1c2VyU3BhY2VPblVzZSIgeDE9IjAlIiB5MT0iMCUiIHgyPSIwJSIgeTI9IjEwMCUiPgogICAgPHN0b3Agb2Zmc2V0PSI1MCUiIHN0b3AtY29sb3I9IiNmN2QxNDUiIHN0b3Atb3BhY2l0eT0iMSIvPgogICAgPHN0b3Agb2Zmc2V0PSI1MCUiIHN0b3AtY29sb3I9IiNmNWM1MTciIHN0b3Atb3BhY2l0eT0iMSIvPgogIDwvbGluZWFyR3JhZGllbnQ+CiAgPHJlY3QgeD0iMCIgeT0iMCIgd2lkdGg9IjEiIGhlaWdodD0iMSIgZmlsbD0idXJsKCNncmFkLXVjZ2ctZ2VuZXJhdGVkKSIgLz4KPC9zdmc+); background: -moz-linear-gradient(top,  rgba(247,209,69,1) 50%, rgba(245,197,23,1) 50%); background: -webkit-gradient(linear, left top, left bottom, color-stop(50%,rgba(247,209,69,1)), color-stop(50%,rgba(245,197,23,1))); background: -webkit-linear-gradient(top, rgba(247,209,69,1) 50%,rgba(245,197,23,1) 50%); background: -o-linear-gradient(top, rgba(247,209,69,1) 50%,rgba(245,197,23,1) 50%); background: -ms-linear-gradient(top, rgba(247,209,69,1) 50%,rgba(245,197,23,1) 50%); background: linear-gradient(to bottom,  rgba(247,209,69,1) 50%,rgba(245,197,23,1) 50%); filter: progid:DXImageTransform.Microsoft.gradient( startColorstr='#f7d145', endColorstr='#f5c517',GradientType=0 ); }
  nav a.btn-green-arrow:hover { text-decoration:none; }
  nav a.btn-green-arrow .arrow { display:block; min-height:18px; background:transparent url(//cdn.oreillystatic.com/oreilly/images/btn-green-arrow-overlay.png) left center no-repeat; margin:0 0 0 -25px; padding:0 0 0 25px; }
  nav a.btn-green-arrow.small { font-size:13px; line-height:18px;  padding:5px 10px 5px 22px !important; }

  ul#primarynav, #sf-menu-text-nav { display:none; }
</style>

<!-- Styles for page -->
<style type="text/css">
  /* Reset for browsers that don't automatically set semantic tags to block */
  article,aside,details,figcaption,figure,footer,header,hgroup,menu,nav,section { display:block; }

  nav .self-clear:after { content:""; display:block; clear:both; height:0; }

#globalInclude { text-align:left !important; }
</style>


<!-- Nav Styles -->
<style type="text/css">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</style>


<!-- Advertisement Styles -->
<style type="text/css">
  nav #contextual-nav ul.horizontal li.ad.data { width:425px; min-height:560px; position:absolute; z-index:-1; top:0; bottom:0; left:0; margin-right:-55px; background:transparent url(//cdn.oreillystatic.com/oreilly/promos/ad-data-bg.png) left bottom no-repeat; }

  nav #contextual-nav ul.horizontal li.ad.photography { width:370px; min-height:560px; position:absolute; z-index:-1; top:0; bottom:0; left:0; background:transparent url(//cdn.oreillystatic.com/oreilly/promos/ad-photography-bg.jpg) left bottom no-repeat; }

  nav #contextual-nav ul.horizontal li.ad.programming { width:425px; min-height:585px; position:absolute; z-index:-1; top:0; bottom:0; left:0; margin-bottom:-25px; background:transparent url(//cdn.oreillystatic.com/oreilly/promos/ad-programming-bg.png) left bottom no-repeat; }
</style>


  <!-- Subnav JavaScript -->
  
<script type="text/javascript">

  //Initialize the site subnav dropdown menu
  function initSubNav() {

    var isMobile = (/iPhone|iPod|iPad|Android|BlackBerry|IEMobile|Opera Mini/).test(navigator.userAgent);
    if (isMobile) {
      //Prevent default interaction on clicks of drop-down menu titles
      jQuery('nav').find('.sub > .title').bind('click', function(e) {
        e.preventDefault();
      });
    }

    jQuery('#contextual-nav > .sub').bind('mouseover', function(e) {
      var that = jQuery(this);
      that.addClass('on');
    }).bind('mouseleave', function(e) {
      var that = jQuery(this);
      that.removeClass('on');
      that.find('.sub').removeClass('hover');
    });

    jQuery('nav').find('.vertical > .sub').bind('mouseover', function(e) {
      var that = jQuery(this);
      that.addClass('on');
      setTimeout(function() {
        if (that.hasClass('on')) {
          that.parent().children().removeClass('hover');
          that.addClass('hover');
        }
      },70);
    }).bind('mouseleave', function(e) {
      var that = jQuery(this);
      that.removeClass('on');
    });
  }

  //Break subnav lists into columns where 'split' classes have been added
  function breakNavColumns() {
    jQuery('nav').find('.horizontal').each(function() {
      jQuery(this).find('.split').each(function(i) {
      var category = jQuery(this).parent().find('.category:eq(0)').parent();
      jQuery(this).css('margin-top', - (jQuery(this).position().top - category.position().top - category.height()) + "px");
      jQuery(this).add(jQuery(this).nextAll(':not(.ad)')).css('margin-left', ((1+i) * (5 + jQuery(this).width())) + 'px');
      }); 
    });
  }
  
  //When the document is loaded, initialize the subnav dropdown menu and multi-column subnav lists
  jQuery(document).ready(function(jQuery) {
    breakNavColumns();
    initSubNav();
  });

</script>


<nav role="navigation">
  <ul id="global-nav" role="menubar">
    <li role="menuitem"><a href="http://www.oreilly.com">Home</a></li>
    <li role="menuitem"><a href="http://shop.oreilly.com" class="current">Shop Video Training &amp; Books</a></li>
    <li role="menuitem"><a href="http://radar.oreilly.com">Radar</a></li>
    <li role="menuitem"><a href="http://www.safaribooksonline.com/?utm_source=oreilly&utm_medium=referral&utm_campaign=publisher&utm_content=nav">Safari Books Online</a></li>
    <li role="menuitem"><a href="http://conferences.oreilly.com/">Conferences</a></li>
    <!-- li role="menuitem"><a href="http://www.oreillyschool.com/">IT Courses &amp; Certificates</a></li -->
    <li class="social"><a href="http://twitter.com/oreillymedia" class="icon twitter" title="O'Reilly on Twitter"></a><a href="http://www.youtube.com/subscription_center?add_user=oreillymedia" class="icon youtube" title="O'Reilly on YouTube"></a><a href="http://www.facebook.com/OReilly" class="icon facebook" title="O'Reilly on Facebook"></a><a href="https://plus.google.com/+oreillymedia/" class="icon googleplus" title="O'Reilly on Google+"></a><a href="http://oreilly.com/feeds/" class="icon rss" title="Subscribe to Feed"></a></li>
  </ul>

  
    <!-- Store Subnav -->
    <!-- New CS -->
  <ul id="contextual-nav" role="menubar">
    <li class="sub" aria-haspopup="true" role="menuitem">
      <a class="title" href="http://shop.oreilly.com/category/browse-subjects.do"><span>Browse Subjects</span></a>
      <ul class="vertical" role="menu">
        <li class="sub" aria-haspopup="true" role="menuitem">
          <a href="http://shop.oreilly.com/category/browse-subjects/apple-mac.do" class="title">Apple</a>
          <ul class="horizontal" role="menu">
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/apple-mac.do" class="category">Apple</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/apple-mac/apple-apps.do">Apple Apps</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/apple-mac/apple-programming.do">Apple Programming</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/apple-mac/ios-programming.do">iOS Programming</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/apple-mac/ipad-iphone-ipod.do">iPad, iPhone, &amp; iPod</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/apple-mac/mac.do">Mac</a></li>
          </ul>
        </li>
        <li class="sub" aria-haspopup="true" role="menuitem">
          <a href="http://shop.oreilly.com/category/browse-subjects/apps-software.do" class="title">Apps &amp; Software</a>
          <ul class="horizontal" role="menu">
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/apps-software.do" class="category">Apps &amp; Software</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/apps-software/apple-apps.do">Apple Apps</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/apps-software/design-apps.do">Design Apps</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/apps-software/office-sharepoint.do">Office &amp; SharePoint</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/apps-software/photo-apps.do">Photoshop &amp; Photo Apps</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/apps-software/web-mobile-apps.do">Web &amp; Mobile Apps</a></li>
          </ul>
        </li>
        <li class="sub" aria-haspopup="true" role="menuitem">
          <a href="http://shop.oreilly.com/category/browse-subjects/digital-audio-video.do" class="title">Audio &amp; Video</a>
          <ul class="horizontal" role="menu">
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/digital-audio-video.do" class="category">Audio &amp; Video</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/digital-audio-video/digital-audio.do">Audio</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/digital-audio-video/digital-video.do">Video</a></li>
          </ul>
        </li>
        <li class="sub" aria-haspopup="true" role="menuitem">
          <a href="http://shop.oreilly.com/category/browse-subjects/business.do" class="title">Business</a>
          <ul class="horizontal" role="menu">
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/business.do" class="category">Business</a></a>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/business/accounting-finance.do">Accounting &amp; Finance</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/business/agile.do">Agile &amp; Lean</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/business/business-management.do">Business Management &amp; Leadership</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/business/career-development.do">Career Development</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/business/entrepreneurship.do">Entrepreneurship</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/business/it-leadership.do">IT Leadership</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/business/project-management.do">Project Management</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/business/sales-marketing.do">Sales &amp; Marketing</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/business/society-culture.do">Society &amp; Culture</a></li>
          </ul>
        </li>
        <li class="sub" aria-haspopup="true" role="menuitem">
          <a href="http://shop.oreilly.com/category/browse-subjects/certification-training.do" class="title">Certification</a>
          <ul class="horizontal" role="menu">
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/certification-training.do" class="category">Certification</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/certification-training/cisco-certification.do">Cisco Certification</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/certification-training/linux-certification.do">Linux Certification</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/certification-training/microsoft-certification-training.do">Microsoft Certification &amp; Training</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/certification-training/pmp.do">PMP</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/certification-training/other-certification.do">Other Certification</a></li>
          </ul>
        </li>
        <li class="sub" aria-haspopup="true" role="menuitem">
          <a href="http://shop.oreilly.com/category/browse-subjects/data.do" class="title">Data</a>
          <ul class="horizontal" style="width:370px;" role="menu">
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/data.do" class="category">Data</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/data/data-analysis-visualization.do">Data Analysis &amp; Visualization</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/data/data-topics.do">Data Topics</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/data/non-relational-databases.do">Non-Relational Databases</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/data/sas.do">SAS</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/data/oracle.do">Oracle</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/data/relational-databases.do">Relational Databases</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/data/sql-server.do">SQL Server</a></li>

          </ul>
        </li>
        <li class="sub" aria-haspopup="true" role="menuitem">
          <a href="http://shop.oreilly.com/category/browse-subjects/design.do" class="title">Design</a>
          <ul class="horizontal" role="menu">
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/design.do" class="category">Design</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/design/animation.do">Animation</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/design/design-apps.do">Design Apps</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/design/digital-publishing.do">Digital Publishing</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/design/game-design.do">Game Design &amp; Development</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/design/information-architecture.do">Information Architecture</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/design/mobile-design.do">Mobile Design &amp; Development</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/design/prod-design.do">Product Design</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/design/user-experience.do">User Experience</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/design/web-design.do">Web Design</a></li>
          </ul>
        </li>
        <li class="sub" aria-haspopup="true" role="menuitem">
          <a href="http://shop.oreilly.com/category/browse-subjects/science-math.do" class="title">Engineering, Math, &amp; Science</a>
          <ul class="horizontal" role="menu">
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/science-math.do" class="category">Engineering, Math, &amp; Science</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/science-math/bioinformatics.do">Bioinformatics</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/science-math/electrical-engineering.do">Electrical Engineering</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/science-math/hardware-engineering.do">Hardware Engineering</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/science-math/math.do">Math</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/science-math/science.do">Science</a></li>
          </ul>
        </li>
        <li class="sub" aria-haspopup="true" role="menuitem">
          <a href="http://shop.oreilly.com/category/browse-subjects/health.do" class="title">Health &amp; Wellness</a>
          <ul class="horizontal" role="menu">
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/health.do" class="category">Health &amp; Wellness</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/health/cancer.do">Cancer</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/health/disorders-diseases.do">Disorders &amp; Diseases</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/health/health-it.do">Health IT</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/health/mind-body.do">Mind &amp; Body</a></li>
          </ul>
        </li>
        <li class="sub" aria-haspopup="true" role="menuitem">
          <a href="http://shop.oreilly.com/category/browse-subjects/iot.do" class="title">IoT (Internet of Things)</a>
          <ul class="horizontal" role="menu">
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/iot.do" class="category">IoT (Internet of Things)</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/iot/diy-projects.do">DIY Projects</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/iot/electronics.do">Electronics</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/iot/hardware-hacking.do">Hardware Hacking</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/iot/lego-robotics.do">Lego &amp; Robotics</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/iot/make-craft.do">Make &amp; Craft</a></li>
          </ul>
        </li>

        <li class="sub" aria-haspopup="true" role="menuitem">
          <a href="http://shop.oreilly.com/category/browse-subjects/microsoft.do" class="title">Microsoft</a>
          <ul class="horizontal" role="menu">
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/microsoft.do" class="category">Microsoft</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/microsoft/dotnet.do">.NET &amp; Windows Programming</a></li>
            <li role="menuitem" role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/microsoft/business-solutions.do">Microsoft Business Solutions</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/microsoft/certification-training.do">Microsoft Certification &amp; Training</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/microsoft/servers.do">Microsoft Servers</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/microsoft/software-development.do">Microsoft Software Development</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/microsoft/webdesign.do">Microsoft Web Design &amp; Development</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/microsoft/office-sharepoint.do">Office &amp; Sharepoint</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/microsoft/windows.do">Windows</li></a>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/microsoft/windows-administration.do">Windows Administration</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/microsoft/windows-phone.do">Windows Phone</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/microsoft/windows-phone-programming.do">Windows Phone Programming</a></li>
          </ul>
        </li>
        <li class="sub" aria-haspopup="true" role="menuitem">
          <a href="http://shop.oreilly.com/category/browse-subjects/mobile-devices.do" class="title">Mobile &amp; Ereader Devices</a>
          <ul class="horizontal" role="menu">
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/mobile-devices.do" class="category">Mobile &amp; Ereader Devices</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/mobile-devices/android.do">Android</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/mobile-devices/ipad-iphone-ipod.do">iPad, iPhone, &amp; iPad</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/mobile-devices/kindle.do">Kindle</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/mobile-devices/nook.do">Nook</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/mobile-devices/windows-phone.do">Windows Phone</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/mobile-devices/other-devices.do">Other Devices</a></li>
          </ul>
        </li>
        <li class="sub" aria-haspopup="true" role="menuitem">
          <a href="http://shop.oreilly.com/category/browse-subjects/networking.do" class="title">Networking</a>
          <ul class="horizontal" role="menu">
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/networking.do" class="category">Networking</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/networking/cisco.do">Cisco</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/networking/cloud-network-security.do">Cloud &amp; Network Security</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/networking/home-networking.do">Home Networking</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/networking/network-administration.do">Network Administration</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/networking/networking-topics.do">Networking Topics</a></li>
          </ul>
        </li>
        <li class="sub" aria-haspopup="true" role="menuitem">
          <a href="http://shop.oreilly.com/category/browse-subjects/personal-computing.do" class="title">Personal Computing</a>
          <ul class="horizontal" role="menu">
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/personal-computing.do" class="category">Personal Computing</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/personal-computing/home-networking.do">Home Networking</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/personal-computing/mac.do">Mac</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/personal-computing/pc.do">PC</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/personal-computing/windows.do">Windows</a></li>
          </ul>
        </li>
        <li class="sub" aria-haspopup="true" role="menuitem">
          <a href="http://shop.oreilly.com/category/browse-subjects/personal-growth.do" class="title">Personal Growth</a>
          <ul class="horizontal" role="menu">
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/personal-growth.do" class="category">Personal Growth</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/personal-growth/business-management-leadership.do">Business Management &amp; Leadership</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/personal-growth/career-development.do">Career Development</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/personal-growth/mind-body.do">Mind &amp; Body</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/personal-growth/personal-finance.do">Personal Finance</a></li>
          </ul>
        </li>
        <li class="sub" aria-haspopup="true" role="menuitem">
          <a href="http://shop.oreilly.com/category/browse-subjects/digital-photography.do" class="title">Photography</a>
          <ul class="horizontal" style="width:370px;" role="menu">
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/digital-photography.do" class="category">Photography</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/digital-photography/camera-guides.do">Camera Guides</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/digital-photography/digital-photography.do">Digital Photography</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/digital-photography/photoshop.do">Photoshop &amp; Photo Apps</a></li>


          </ul>
        </li>
        <li class="sub" aria-haspopup="true" role="menuitem">
          <a href="http://shop.oreilly.com/category/browse-subjects/programming.do" class="title">Programming</a>
          <ul class="horizontal" style="width:425px;" role="menu">
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming.do" class="category">Programming</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/dotnet.do">.NET &amp; Windows</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/agile.do">Agile</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/android-programming.do">Android</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/apple-programming.do">Apple</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/c.do">C/C++</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/csharp.do">C#</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/design-patterns.do">Design Patterns</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/game-design.do">Game Design &amp; Development</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/graphics-multimedia-programming.do">Graphics &amp; Multimedia</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/ios-programming.do">iOS</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/java.do">Java</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/javascript.do">JavaScript</a></li>
            <li class="split" style="position:relative; z-index:10;" role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/perl.do">Perl</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/mobile-design.do">Mobile Design &amp; Development</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/php.do">PHP</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/python.do">Python</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/r.do">R</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/ruby.do">Ruby &amp; Rails</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/secure-programming.do">Secure</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/software-engineering.do">Software Engineering</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/testing.do">Testing</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/windows-phone-programming.do">Windows Phone</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/programming/other-programming-languages.do">Other Languages</a></li>

          </ul>
        </li>
        <li class="sub" aria-haspopup="true" role="menuitem">
          <a href="http://shop.oreilly.com/category/browse-subjects/security.do" class="title">Security &amp; Cryptography</a>
          <ul class="horizontal" role="menu">
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/security.do" class="category">Security &amp; Cryptography</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/security/cloud-network-security.do">Cloud &amp; Network Security</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/security/computer-security.do">Computer Security</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/security/cryptography.do">Cryptography</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/security/secure-programming.do">Secure Programming</a></li>
          </ul>
        </li>
        <li class="sub" aria-haspopup="true" role="menuitem">
          <a href="http://shop.oreilly.com/category/browse-subjects/system-administration.do" class="title">System Administration</a>
          <ul class="horizontal" role="menu">
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/system-administration.do" class="category">System Administration</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/system-administration/cloud-administration.do">Cloud Administration</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/system-administration/email-administration.do">Email Administration</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/system-administration/linux-unix.do">Linux &amp; Unix</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/system-administration/microsoft-servers.do">Microsoft Servers</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/system-administration/performance.do">Performance</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/system-administration/system-admin-ops.do">System Admin &amp; Ops</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/system-administration/windows-administration.do">Windows Administration</a></li>
          </ul>
        </li>
        <li class="sub" aria-haspopup="true" role="menuitem">
          <a href="http://shop.oreilly.com/category/browse-subjects/tech-culture.do" class="title">Tech Culture</a>
          <ul class="horizontal" role="menu">
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/tech-culture.do" class="category">Tech Culture</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/tech-culture/game-strategy.do">Game Strategy</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/tech-culture/tech-culture.do">Tech Culture</a></li>
          </ul>
        </li>
        <li class="sub" aria-haspopup="true" role="menuitem">
          <a href="http://shop.oreilly.com/category/browse-subjects/web-development.do" class="title">Web Development</a>
          <ul class="horizontal" role="menu">
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/web-development.do" class="category">Web Development</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/web-development/html-css.do">HTML &amp; CSS</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/web-development/javascript.do">JavaScript</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/web-development/performance.do">Performance</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/web-development/php.do">PHP</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/web-development/ruby-rails.do">Ruby &amp; Rails</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/web-development/sem-seo.do">SEM &amp; SEO</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/web-development/web-content-management.do">Web Content Management</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/web-development/web-design.do">Web Design</a></li>
            <li role="menuitem"><a href="http://shop.oreilly.com/category/browse-subjects/web-development/web-development.do">Web Development</a></li>
          </ul>
        </li>
      </ul>
    </li>
    <li role="menuitem"><a href="http://shop.oreilly.com/category/learning-path.do">Learning Paths</a></li>
    <li role="menuitem"><a href="http://shop.oreilly.com/category/videos.do">Video Training</a></li>
    <li role="menuitem"><a href="http://shop.oreilly.com/category/new.do">New</a></li>
    <li role="menuitem"><a href="http://shop.oreilly.com/category/upcoming.do">Upcoming</a></li>
    <li role="menuitem"><a href="http://shop.oreilly.com/category/early-release.do">Early Release</a></li>
    <li role="menuitem"><a href="http://shop.oreilly.com/category/bestselling.do">Bestselling</a></li>
    <li role="menuitem" class="no-divider"><a href="http://shop.oreilly.com/category/ebooks.do">Ebooks</a></li>

    <li class="contact vcard">
        <span class="tel">1-800-889-8969</span> / <span class="tel">707-827-7019</span> / <a class="email" href="mailto:orders@oreilly.com">orders@oreilly.com</a>
    </li>
  </ul>
  

  

  


  

  


</nav>

<div style="text-align:center" id="global-ad">
<!-- Safari  -->
<a href="https://www.safaribooksonline.com/?utm_medium=web+site=&utm_source=oreilly.com&utm_campaign=olt+launch&utm_content=20161205+olt+orm+shop" onClick="var s=s_gi(s_account); s.products=';orm-store-global-safari'; s.eVar23='orm-store-global-safari'; s.events='event5'; s.linkTrackVars='eVar23,products,events'; s.linkTrackEvents='event5'; s.tl(this,'o','Ad Click');"><img src="//cdn.oreillystatic.com/assets/images/global-safari-lot-20161202.jpg" width="974" height="160" alt="Get real answers from real experts - in real time. Learn more" /></a>
</div>












	</div>






    
  

  
  

  
  
  
  
  


</div>
    </td>
  </tr>

  <tr valign="top">

    

    <td width="8" class="contentbg"><img src="/images/oreilly/en_us/global/globalgraphics/spacer01.gif" width="8" height=1 border=0></td>
    <td width="974" class="contentbg">
      <div>

























  

















			
		

























  











<script src="/includes/kits.js"></script>
<script src="/includes/validateProductSelection.js"></script>
<script type="text/javascript" src="//cdn.oreillystatic.com/assets/js/abridge-description.js"></script>
<script language="javascript">
	var noQtyMsg = "Quantity must be at least 1.";
	var noOptionsMsg = "Select Valid Option(s)";
</script>

	
	
	








<div class"detailFillslot">
	
</div>



<table cellspacing="0" cellpadding="0" border="0">


	<input type="hidden" name="from" value="detail">

	

	<input type="hidden" name="pageCategory" value="">

	

	<tr valign="top">

  		<td style="width:690px;">

				<div id="browse-content" style="float:left;width:190px;">
					

					
					
					
					
						
							
						

























  







  



<div>
	
		<a href="https://library.oreilly.com/book/0636920063698/_/toc" id="search-inside" onclick="var s=s_gi(s_account); s.products=';shop-reader-searchin-0636920063698'; s.eVar23='shop-reader-searchin-0636920063698'; s.events='event5'; s.linkTrackVars='eVar23,products,events'; s.linkTrackEvents='event5'; s.tl(this,'o','Ad Click');">Search Inside and Read</a>
	
</div>


										

					
					
					
						
					

























  







<script src="/includes/optionClasses.js"></script>
<script src="/includes/detailImageSwatches.js"></script>





  









  
  
    
    

    
  










	
		
		
		
			<div class="detailimgcontainer">
				
				 
				 
				 
				 
				 
			<a href="/product/0636920063698.do?sortby=publicationDate" target="_parent" onClick="goSwatches_253789.openViewLarger(500,680,'/product/0636920063698/ViewLarger.do?sortby=publicationDate','ViewLarger');">
			<img id="largeImage" src="http://akamaicovers.oreilly.com/images/0636920063698/rc_cat.gif" border="0" alt="A guide to building deep learning systems"/></a>
				
			</div>
		
	
	<script type="text/javascript">
		var sViewLargerCall = "goSwatches_253789.openViewLarger(500,680,'/product/0636920063698/ViewLarger.do?sortby=publicationDate','ViewLarger', 'NoFocus')"
	</script>

	

	
	
		<div class="viewLarger">
		<a href="#" onClick="goSwatches_253789.openViewLarger(500,680,'/product/0636920063698/ViewLarger.do?sortby=publicationDate','ViewLarger');" >

			Larger Cover

			
		</a>
		</div>
	
 


 






<script type="text/javascript">
  

  
    
    
      
      
    
  

  
  var goSwatches_253789 = new DetailImageSwatches(253789,null,null,null,null);
</script>


					




					
				</div>

			
   			<div class="detailheader">
   				Learning TensorFlow
   			</div>

			
			
				<div class="detailSubHeader">
					A guide to building deep learning systems
				</div>
			

    		

			
			 <div>
				 
					
					
				 

























  





























   <div class="AuthorName">By&nbsp;<a href="#tab_04_2" class="byLineLink" onclick="setActiveTab('tab_04_2', 'About the Author',2)">Tom Hope, Yehezkel S. Resheff, Itay Lieder</a></div>



   <div>Publisher:&nbsp;O'Reilly Media</div>

	
	
      
         
            <div>Final Release Date:&nbsp;January 2017
			
            </div>
         
      
   
   
      <div class="default">Pages:&nbsp;250</div>
   
   




			 </div>


			<div class="SocialIconBox">

							<table cellspacing="0" cellpadding="0" border="0" width="100%">
					<tr>

						
							<td>
								<!--Start:fix for ORLY97  -->
								<div>
									 
										
									 

























  





<link rel="stylesheet" href="/text/pwr/engine/pr_styles_review.css" id="prBaseStylesheet"/>
<link rel="stylesheet" href="/includes/reviews_social.css" type="text/css" id="prMerchantOverrideStylesheet">


	
	
	
    
	
	
	
	
	

	<script type="text/javascript" src="/text/pwr/engine/js/full.js"></script>
	<script type="text/javascript">
		 var pr_locale = 'en_US';
		 var pr_zip_location='/text';
		var pr_style_sheet='/includes/reviews_social.css ';
		var pr_page_id = '0636920063698.IP'; /* SPECIFY THE PRODUCT SEO code here since Product ID not dependable  */
	</script>

	<script type="text/javascript">
	function ReviewAnchor() {
			window.location = String(window.location).replace(/#.*$/, "") + "#PowerReview";
	}
	</script>


		<div id="hasReviews">
			<script type="text/javascript">
				POWERREVIEWS.display.snippet(document, {
				pr_page_id : '0636920063698.IP',
				pr_read_review : 'javascript:ReviewAnchor()',
				pr_write_review : '/product/0636920063698/ReviewSubmit.do?sortby=publicationDate?pageId=0636920063698.IP'
			});
			</script>
		</div>
		<div id="noReviews" style="display:none">
			<script type="text/javascript">document.write('Be the first to <a href="/product/0636920063698/ReviewSubmit.do?sortby=publicationDate?pageId=0636920063698.IP">write a review </a>')</script>
		</div>

<!-- End PowerReviews snippet -->



							 	</div>
								<!--End:fix for ORLY97  -->
								
							</td>
					</tr>
				</table>
			</div>
			
			
						
			<!--Start:SC-2013-04523  -->
			<div id="detail-description-container">
			
			
			<table width="500" cellpadding=0 cellspacing=0><tr><td>
				<div class="detail-description-content">
				
					<div>
                                                <div>
                                                    <p>With Early Release ebooks, you get books in their earliest form—the author's raw and unedited content as he or she writes—so you can take advantage of these technologies long before the official release of these titles. You’ll also receive updates when significant changes are made, new chapters are available, and the final ebook bundle is released.</p>
                                                    <p>TensorFlow is currently the leading open-source software for deep learning, used by a rapidly growing number of practitioners working on computer vision, Natural Language Processing (NLP), speech recognition, and general predictive analytics. This book is an end-to-end guide to TensorFlow designed for data scientists, engineers, students and researchers.</p>
                                                    <p>With this book you will learn how to:</p>
                                                    <ul>
                                                        <li>Get up and running with TensorFlow, rapidly and painlessly</li>
                                                        <li>Build and train popular deep learning models for computer vision and NLP</li>
                                                        <li>Apply your advanced understanding of the TensorFlow framework to build and adapt models for your specific needs</li>
                                                        <li>Train models at scale, and deploy TensorFlow in a production setting</li>
                                                    </ul>
                                                </div>
                                            </div>
				</div></td></tr></table>
				<script type="text/javascript">abridgeDescription();</script>
			</div>
			<!--End-2013-04523  -->
			
				
					
				

























  











  
  
  	
    	
    
  

  
  

  
  
  
  
  




			
				 
					
				 

























  















				
		
			
			
				<div>
				
				</div>
			
		

			
			 <div style="clear: both;"></div>

			
			

			
			
				
				<div class="infoTabs">
					
					
						
						
							
						
					

























  







  









				</div>
				
				
				<div class="infoTabs">
					
					
						
					

























  







  









  
  
  
  

  
  <script src="/includes/InfoTabs.js"></script>

  
  
  
  
  
    <div id="tab_02_2_content" style="display:none;">
      <table width="100%" cellpadding=0 cellspacing=0><tr><td><div id="toc-content">  <ol id="chapters">  <li class="chapter available" title="">      <h3><span class="chapter-label">Preface</span></h3>    </li>    <li class="chapter available" title="1">      <h3><span class="chapter-label">Chapter 1</span>Introduction</h3>    </li>    <li class="chapter available" title="2">      <h3><span class="chapter-label">Chapter 2</span>Go with the Flow: Up and running with TensorFlow</h3>    </li>    <li class="chapter available" title="3">      <h3><span class="chapter-label">Chapter 3</span>Understanding TensorFlow Basics </h3>    </li>    <li class="chapter available" title="4">      <h3><span class="chapter-label">Chapter 4</span>Convolutional Neural Networks</h3>    </li>    <li class="chapter available" title="5">      <h3><span class="chapter-label">Chapter 5</span>Working with Text and Sequences + TensorBoard visualization</h3>    </li>    <li class="chapter available" title="6">      <h3><span class="chapter-label">Chapter 6</span>TF Abstractions and Simplification</h3>    </li>    <li class="chapter unavailable" title="7">      <h3><span class="chapter-label">Chapter 7</span>Queues, Threads, and Reading Data</h3>    </li>    <li class="chapter unavailable" title="8">      <h3><span class="chapter-label">Chapter 8</span>Distributed TensorFlow</h3>    </li>    <li class="chapter unavailable" title="9">      <h3><span class="chapter-label">Chapter 9</span>Serving Models</h3>    </li>    <li class="chapter unavailable" title="10">      <h3><span class="chapter-label">Chapter 10</span>Miscellaneous</h3>    </li>      </ol></div></td></tr></table>
    </div>
	
  
  
    <div id="tab_03_2_content" style="display:none;">
      <table width="100%" cellpadding=0 cellspacing=0><tr><td><dl>                                                <dt>Title:</dt>                                                <dd>                                                    <cite property="dc:title">Learning TensorFlow</cite>                                                </dd>                                                <dt>By:</dt>                                                <dd>                                                    <span rel="dc:creator">                                                        <span>                                                            <a about="urn:x-domain:oreilly.com:agent:pdb:37125" href="http://www.oreilly.com/pub/au/7297" typeof="foaf:Person" rel="foaf:homepage" property="foaf:name" class="authorname">Tom Hope</a>, <a about="urn:x-domain:oreilly.com:agent:pdb:37124" href="http://www.oreilly.com/pub/au/7298" typeof="foaf:Person" rel="foaf:homepage" property="foaf:name" class="authorname">Yehezkel S. Resheff</a>, <a about="urn:x-domain:oreilly.com:agent:pdb:37123" href="http://www.oreilly.com/pub/au/7299" typeof="foaf:Person" rel="foaf:homepage" property="foaf:name" class="authorname">Itay Lieder</a>                                                        </span>                                                    </span>                                                </dd>                                                <dt>Publisher:</dt>                                                <dd>                                                    <span property="dc:publisher">O'Reilly Media</span>                                                </dd>                                                <dt>Formats:</dt>                                                <dd>                                                    <ul rel="frbr:embodiment">                                                        <li about="urn:x-domain:oreilly.com:product:9781491978511.BOOK" typeof="frbr:Manifestation">                                                            <span resource="http://purl.oreilly.com/product-types/BOOK" rel="dc:type">Print</span>                                                        </li>                                                        <li about="urn:x-domain:oreilly.com:product:9781491978504.SAF" typeof="frbr:Manifestation">                                                            <span resource="http://purl.oreilly.com/product-types/SAF" rel="dc:type">Safari Books Online</span>                                                        </li>                                                        <li about="urn:x-domain:oreilly.com:product:9781491978443.EBOOK" class="last" typeof="frbr:Manifestation">                                                            <span resource="http://purl.oreilly.com/product-types/EarlyReleaseEbook" rel="dc:type">Early Release Ebook</span>                                                        </li>                                                    </ul>                                                </dd>                                                <dt>Print:</dt>                                                <dd about="urn:x-domain:oreilly.com:product:9781491978511.BOOK">                                                    <span datatype="xsd:dateTime" content="2017-07-15" property="dc:date" class="date">    July 2017            (est.)    </span>                                                </dd>                                                <dt>Early Release Ebook:</dt>                                                <dd about="urn:x-domain:oreilly.com:product:9781491978443.EBOOK">                                                    <span datatype="xsd:dateTime" content="2017-01-19" property="dc:issued" class="date">    January 2017    </span>                                                </dd>                                                <dt>Pages:</dt>                                                <dd about="urn:x-domain:oreilly.com:product:9781491978511.BOOK" property="dc:extent">                    250                        (est.)                </dd>                                                <dt>Print ISBN:</dt>                                                <dd about="urn:x-domain:oreilly.com:product:9781491978511.BOOK" resource="urn:isbn:9781491978511" class="isbn" rel="dc:identifier">978-1-4919-7851-1</dd>                                                <dt class="isbn-10"> | ISBN 10:</dt>                                                <dd>1-4919-7851-1</dd>                                                <dt>Early Release Ebook ISBN:</dt>                                                <dd about="urn:x-domain:oreilly.com:product:9781491978443.EBOOK" resource="urn:isbn:9781491978443" class="isbn" rel="dc:identifier">978-1-4919-7844-3</dd>                                                <dt class="isbn-10"> | ISBN 10:</dt>                                                <dd>1-4919-7844-9</dd>                                            </dl></td></tr></table>
    </div>
	
  
  
    <div id="tab_04_2_content" style="display:none;">
      <table width="100%" cellpadding=0 cellspacing=0><tr><td><ol>                                                <li class="author-bio">                                                    <h3>Tom Hope</h3>                                                    <div>                                                        <div>                                                            <p>Tom Hope is an applied machine learning researcher and data scientist with extensive background in academia and industry.</p>                                                            <p>He has background as a senior data scientist in large international corporation settings, leading data science and deep learning R&amp;D across multiple domains including web mining, text analytics, computer vision,sales and marketing, IoT, financial forecasting and large-scale manufacturing. Previously he was at a successful e-commerce startup in its early days, leading data science R&amp;D. He has also served as a data science consultant for major international companies and startups. His research in computer science, data mining and statistics revolves around machine learning, deep learning, NLP, weak supervision and time-series.</p>                                                        </div>                                                    </div>                                                    <p>                                                        <a href="http://www.oreilly.com/pub/au/7297">View Tom Hope's full profile page.</a>                                                    </p>                                                </li>                                                <li class="author-bio">                                                    <h3>Yehezkel S. Resheff</h3>                                                    <div>                                                        <p>Hezi Reshef is an applied researcher and PhD student in Machine Learning at the Hebrew University, developing Machine Learning and Deep Learning methods for wearable device data, and working on using wearable devices to monitor patient health. He has worked at Intel Corp., leading Deep Learning R&amp;D for monitoring and predicting patient outcomes using remote sensing and wearables. Prior to Intel, Hezi was at Microsoft, leading Machine Learning R&amp;D for mining telemetry data, predicting software bugs, user segmentation, and other projects.</p>                                                    </div>                                                    <p>                                                        <a href="http://www.oreilly.com/pub/au/7298">View Yehezkel S. Resheff's full profile page.</a>                                                    </p>                                                </li>                                                <li class="author-bio">                                                    <h3>Itay Lieder</h3>                                                    <div>                                                        <p>Itay Lieder is an applied researcher in Machine Learning and Computational Neuroscience and a PhD student at the Hebrew University, in collaboration with the Gatsby Computational Neuroscience Unit at UCL, studying the human perception with massive crowd-sourcing experiments on Amazon Turk. His current work focuses on predicting and understanding the way humans react to sounds (e.g. music), via multiple online interactive experiments. He has worked for large international corporations, leading Deep Learning R&amp;D in text analytics and web mining for sales and marketing.</p>                                                    </div>                                                    <p>                                                        <a href="http://www.oreilly.com/pub/au/7299">View Itay Lieder's full profile page.</a>                                                    </p>                                                </li>                                            </ol></td></tr></table>
    </div>
	
  

  
  

  
  <div style="width:690px;overflow:hidden">

  <table border="0" cellpadding="0" cellspacing="0" class="infoTabs" style="">
    
    <tr>
      <td>

        <table border="0" cellpadding="0" cellspacing="0"  style="border-left: 1px solid #dddddd;">
          <tr>
          
			
			
			
			
			
          
			
			
			
			
			
            
              
              

              
              
                <td id="tab_02_2" class="infoTabOff" onclick="setActiveTab('tab_02_2', 'Table of Contents',2)" valign="top" nowrap>
                  <div>Table of Contents</div>
                </td>
              
            
            
            
		 
          
			
			
			
			
			
            
              
              

              
              
                <td id="tab_03_2" class="infoTabOff" onclick="setActiveTab('tab_03_2', 'Product Details',2)" valign="top" nowrap>
                  <div>Product Details</div>
                </td>
              
            
            
            
		 
          
			
			
			
			
			
            
              
              

              
              
                <td id="tab_04_2" class="infoTabOff" onclick="setActiveTab('tab_04_2', 'About the Author',2)" valign="top" nowrap>
                  <div>About the Author</div>
                </td>
              
            
            
		 
          

          
          
            <td class="infoTabSpacer" style="WIDTH:100%"><img src="/images/oreilly/en_us/global/globalgraphics/spacer01.gif" width="1" height="1" border="0"></td>
          </tr>
        </table>
      </td>
      <td class="infoTabSpacer" style="WIDTH:100%"><img src="/images/oreilly/en_us/global/globalgraphics/spacer01.gif" width="0" height="1" border="0"></td>
    </tr>

    
    <tr>
      
        
        
          <td colspan=2 class="infoTabContent" valign="top">
            <div id="tabContentFixer">
            	<div
            		id="tabContent_2" class="tabContent"
            		style="height:255px;"></div>
            </div>
          </td>
        
        
        
      
    </tr>
  </table>
	</div>
  
  <script>
    // Preloading tab images here.
    

    // Activate the first tab.
    
      
      
        setActiveTab('tab_02_2','',2);
      

      
      
    

  </script>


				</div>
				
				

				<script type="text/javascript">
				<!--

				function setActiveTabB(theTab){

					document.getElementById("tab_01_b").className = "infoTabOff";

					if(document.getElementById("tab_02_b") != null){
						document.getElementById("tab_02_b").className = "infoTabOff";
					}

					if(document.getElementById("tab_03_b") != null){
						document.getElementById("tab_03_b").className = "infoTabOff";
					}


					document.getElementById("tab_01_b_content").style.display = "none";

					if(document.getElementById("tab_02_b") != null){
						document.getElementById("tab_02_b_content").style.display = "none";
					}

					if(document.getElementById("tab_03_b") != null){
						document.getElementById("tab_03_b_content").style.display = "none";
					}


					document.getElementById(theTab).className = "infoTabOn";
					document.getElementById(theTab + "_content").style.display = "block";

				}

				// -->
				</script>
				
			
			
				<div class="relatedContent" style="padding-top: 25px;"><div id="video-preview"/>  <div id="video-preview"/></div>
			
				
				<div class="infoTabs" style="marign-bottom:15px;">

					<table width="100%" cellspacing="0" cellpadding="0" border="0" class="infoTabs">

						<tr>
							<td>

								<table cellspacing="0" cellpadding="0" border="0" style="border-left: 1px solid #dddddd;">
									<tr>

										<td valign="top" onclick="setActiveTabB('tab_01_b')" class="infoTabOn" id="tab_01_b" nowrap="" >
											<div>Recommended for You</div>
										</td>

											

											

										<td style="width: 100%;" class="infoTabSpacer"><img height="1" width="1" border="0" src="/images/oreilly/en_us/global/globalgraphics/spacer01.gif"/></td>
									</tr>
								</table>

							</td>
						</tr>

						<tr>
							<td valign="top" class="infoTabContent" colspan="2">

								<div class="tab_b_content first" id="tab_01_b_content">
									
										
										

										
											
										

























  







<!-- MyBuys Web Recommendation Zone - Place in body element -->


  <div mybuyszone="2"></div>

<!-- End MyBuys Web Recommendation Zone -->
										

























  





<!-- MyBuys Page Parameters Place in body element -->
<script type="text/javascript">
  mybuys.set("productid","0636920063698.IP");
</script>
<!-- End MyBuys Page Parameters -->
										

























  





<!-- MyBuys Page Parameters Place in body element -->


	
		
		
			<script type="text/javascript">
				mybuys.setPageType("PRODUCT_DETAILS");
			</script>
		
	

<!-- End MyBuys Page Parameters -->
								</div>
								

									
								
							</td>
						</tr>
					</table>
				</div>

			
			
				
			
			

			
			 
			 <a name="PowerReview"></a>
			 
				<div><img src="/images/oreilly/en_us/global/globalgraphics/spacer01.gif" width="1" height="25" border=0></div>
				<div class="content-subtitle">Customer Reviews</div>
				<div><img src="/images/oreilly/en_us/global/globalgraphics/spacer01.gif" width="1" height="10" border=0></div>
				
					<script type="text/javascript">
						POWERREVIEWS.display.engine(document, {
							pr_page_id : '0636920063698.IP',
							pr_write_review : '/product/0636920063698/ReviewSubmit.do?sortby=publicationDate?pageId=0636920063698.IP'
						});
					</script>
			
 
		</td>

		<td style="width:10px;">&nbsp;</td>

		<td>
			
			 	
			 

























  







  




	<div>
		
				
				
		

























  













	


	











<script language="javascript">
	function setTarget(ismobile) {
		
		if(ismobile != '' && ismobile=='yes'){
			document.getElementById('mainForm').action="/mobile/addToBasket.do?method=view";
		}else{
			document.getElementById('mainForm').action="/stockAvailability.do?method=view";
		}
		
		 return true;
}

function flyopenLocal(width, height){
    width = (width && !isNaN(width))? width:null;
    height = (height && !isNaN(height))? height:null;
    var winURL = (arguments[2])? arguments[2]:null;
    var winName = (arguments[3])? arguments[3]:"generic";

	//only launch the window if we've got a width, height and url
	if (width && height && winURL){
        var ieIncrement = ((navigator.appName+"").indexOf("Netscape") == -1)? 15:0;
        winName = eval("window.open('"+ winURL +"','"+ winName +"','resizable=yes,scrollbars=yes,width="+ (width + ieIncrement) +",height="+ (height + ieIncrement) +",top=5,left=75')");
		if(winName != null && winName != 'undefined') {
			winName.focus();
		}
	}
}

</script>
<!--Back Order Message if any now using the product in the kit.element ORLY-124-->
<!%--Date now = new Date(); %>

	
			

				
				<div>
						
							
						

























  











<div style="width:272px;height:49px;">
	
	
	
	
		
		
			
				<a href="/category/customer-service/b2g1f.do"><img
					src="/images/oreilly/en_us/local/localgraphics/buytwogetone_off.gif"
					border="0"
					name="buyTwoGetOne"
					alt="Buy 2 Get 1 Free"
					style="float:left"
					onmouseover="this.src='/images/oreilly/en_us/local/localgraphics/buytwogetone_on.gif'"
					onmouseout="this.src='/images/oreilly/en_us/local/localgraphics/buytwogetone_off.gif'"
					/></a>

				<a href="/category/customer-service/free-shipping.do"><img
					src="/images/oreilly/en_us/local/localgraphics/freeshipping_off.gif"
					border="0"
					name="freeShipping"
					alt="Free Shipping"
					style="float:left;margin:0 3px"
					onmouseover="this.src='/images/oreilly/en_us/local/localgraphics/freeshipping_on.gif'"
					onmouseout="this.src='/images/oreilly/en_us/local/localgraphics/freeshipping_off.gif'"
					/></a>

				<a href="/category/customer-service/oreilly-guarantee.do"><img
					src="/images/oreilly/en_us/local/localgraphics/guarantee_off.gif"
					border="0"
					name="guarantee"
					alt="Guarantee"
					style="float:left"
					onmouseover="this.src='/images/oreilly/en_us/local/localgraphics/guarantee_on.gif'"
					onmouseout="this.src='/images/oreilly/en_us/local/localgraphics/guarantee_off.gif'"
					/></a>

		
	
 </div>
				</div>
				
				
			<div id="buyingOptionTable">
				<table cellspacing="0" cellpadding="0" border="0">
				<tr>
					<td style="border-bottom:1px solid #dddddd; ">
						
							<img src="/images/oreilly/en_us/local/headers/main/buyingoptions_mhd.gif" alt="Buying Options" />
							
						
				</td>
				</tr>
				<tr>
				<td>
				
						
		
			
			
			
						
					<div class="goGreen">Immediate Access - Go Digital&nbsp;<a id="goGreen" href="#" onClick="return flyopenLocal(360,600,'http://oreilly.com/store/gogreen.html','goGreen');">what's this?</a></div>
					
					
					
					
						
						
						
								
								
								 
								
									
									
								
								
								
								
								
								<form name="addToBasketForm" method="post" action="/addToBasket.do" onsubmit="document.getElementById('mainForm').pageCategory.value=getVariableValue('eVar4');return validateProductSelection(noQtyMsg, noOptionsMsg, this, 1);" id="mainForm">
										<input type="hidden" name="from" value="detail">
											<div style="position: relative;">
													<input type="hidden" name="pageCategory" value="">
													<table cellspacing="0" cellpadding="0" border="0" id="optionsTable">
													 <tr>
													  <td width="64%" class="optionsTd">
															<input type='hidden' name='productPk' value='253789' />
															
															<input type='hidden' name='optionTypes' value='1' />
															<input type='hidden' name='option' value='100002=100011'/>
															<input type="hidden" name="selectedKitItems" id="selectedKitItems_main_253789" value='130920,254632,256643,1'>
															<div style="float:left;">
																
																	
																	
																
																
																
																	<div float="right" style="font-size: 12px; width: 130px;">
																		
																			
																			
																				
																				
																					
																						
																								
																								<a id="earlyRelease" href="#" onClick="return flyopenLocal(520,240,'/text/oreilly/early-release-popup.html','earlyRelease');">Early Release Ebook</a>
																								
																						
																					
																					
																				
																			
																		  
																		 
																			
																			
																			
																			
																			
																			
																				<span class="price">&nbsp;$42.49</span>
																			
																		
																		</div>
																
																
																
																
																	
																			<span style="font-size:11px;">Formats:&nbsp;</span>
																			<a id="availableFormats" href="#" onClick="javascript:flyopenLocal(480,480,'http://oreilly.com/store/ebooks.html','AvailableFormats');  return false;">
																			ePub, Mobi, PDF </a>
																	
																
																
																
																
																<div class="accQtyBox">
																
																	
																										<div class="tableitem">
																											<input type="hidden" name="qty" id="qty_100011" value="1" size="2" class="quantity"/>
																										</div>
																									
																									
																									
																									
																								
																							</div>
				
																							 <div style="width: 130px;">
																								
				
																								
																							</div>
																							<div>
																							
																						   </div>
																						</td>
																						<td width="36%" class="optionsTd" style="padding-bottom: 0px;">
				
																						<!--ORLY-124-->
																						
																							
																							
																							<!-- ORLY-397 -->
																							
																								
																									
																									
																									
																										
																										
																											
																											
																											<span style="padding-left:8px;"><input type="image" name="addToBasket" alt="Add To Cart"src="/images/oreilly/en_us/local/localbuttons/addtobasket_btn.gif" border="0" /></span><div><img src="/images/oreilly/en_us/global/globalgraphics/spacer01.gif" width="1" height="5" border=0></div>
																											
																												
																												
																												
																											
																																																
																										
																									
																								
																							
																							<!-- ORLY-397 -->
																							
																							
																							
																							
																                          
				
				
																						</td>
																					</tr>
																					</table>
																					
																					</div>
																				</form>
																		
						
						
						
								
								
								 
								
									
									
								
								
								
								
								
								<form name="addToBasketForm" method="post" action="/addToBasket.do" onsubmit="document.getElementById('mainForm').pageCategory.value=getVariableValue('eVar4');return validateProductSelection(noQtyMsg, noOptionsMsg, this, 1);" id="mainForm">
										<input type="hidden" name="from" value="detail">
											<div style="position: relative;">
													<input type="hidden" name="pageCategory" value="">
													<table cellspacing="0" cellpadding="0" border="0" id="optionsTable">
													 <tr>
													  <td width="64%" class="optionsTd">
															<input type='hidden' name='productPk' value='253789' />
															
															<input type='hidden' name='optionTypes' value='1' />
															<input type='hidden' name='option' value='100002=100012'/>
															<input type="hidden" name="selectedKitItems" id="selectedKitItems_main_253789" value='130499,253788,255777,1'>
															<div style="float:left;">
																
																	
																	
																
																
																
																	<div float="right" style="font-size: 12px; width: 130px;">
																		
																			
																			
																				
																							Pre-Order&nbsp;
																				
																				
																					
																					Print:
																				
																			
																		  
																		 
																			
																			
																			
																			
																			
																			
																				<span class="price">&nbsp;$49.99</span>
																			
																		
																		</div>
																
																
																
																
																	
																
																
																
																
																<div class="accQtyBox">
																
																	
																									
																									
																									
																										<div class="tableitem">
																											<input type="text" name="qty" id="qty_100012" value="1" size="2" maxlength="2" class="quantity"/>
																										</div>
																									
																								
																							</div>
				
																							 <div style="width: 130px;">
																								
																									
																										
																											July 2017&nbsp;(est.)
																										
																									
																								
				
																								
																							</div>
																							<div>
																							
																						   </div>
																						</td>
																						<td width="36%" class="optionsTd" style="padding-bottom: 0px;">
				
																						<!--ORLY-124-->
																						
																							
																							
																							<!-- ORLY-397 -->
																							
																								
																									
																									
																									
																										
																										
																											
																											
																											<span style="padding-left:8px;"><input type="image" name="addToBasket" alt="Add To Cart"src="/images/oreilly/en_us/local/localbuttons/addtobasket_btn.gif" border="0" /></span><div><img src="/images/oreilly/en_us/global/globalgraphics/spacer01.gif" width="1" height="5" border=0></div>
																											
																												
																												
																												
																											
																																																
																										
																									
																								
																							
																							<!-- ORLY-397 -->
																							
																							
																                          
				
				
																						</td>
																					</tr>
																					</table>
																					
																					</div>
																				</form>
																		
				
			
			
														
															<tr>
																<td class="links" colspan="2" style="border-bottom: 1px solid #ddd;">
														
														
															
																
																
																	Safari Books Online - <a target="_blank" href="https://www.safaribooksonline.com/library/view/_/9781491978504/?utm_medium=referral&amp;utm_campaign=publisher&amp;utm_source=oreilly&amp;utm_content=book+page">Read now ></a>
																
															
														
														
														
																</td>
															</tr>
														
													
				
				
			
			
	
	</td>
</tr>

</table>
</div>

	</div>
	
	<div>
	
		<div class="relatedLink"><div id="related-links">                                            <div class="box-heading">Essential Links</div>                                            <ul>                                                <li>                                                    <a href="http://oreilly.com/catalog/errata.csp?isbn=0636920063698" class="errata-link" rel="nofollow">View/Submit Errata</a>                                                </li>                                                <li>                                                    <a href="http://getsatisfaction.com/oreilly/">Ask a Question</a>                                                </li>                                                <li>                                                    <a href="http://oreilly.com/corporate/">Bulk Discounts &amp; Licensing</a>                                                </li>                                            </ul>                                        </div></div>
	
	</div>
	
		
	 	
	 

























  







  







<div>
	
</div>
	 
	 
	 	
	 	
	 

























  







  







<div>
	
</div>
	 
	 
	 	
	 	
	 

























  







  







<div>
	
</div>
	


		</td>
</tr>
</table>




<style>
.mbzone2 .mbzonetitle {display: none; !important;}
</style>

	
	
</div>
    </td>
    <td width="8" class="contentbg"><img src="/images/oreilly/en_us/global/globalgraphics/spacer01.gif" width="8" height=1 border=0></td>
  </tr>

	
	<tr>
		<td colspan="3" class="eightPixel">&nbsp;</td>
	</tr>



  <tr valign="bottom">
    <td align="center" colspan="3" class="navfooterbg">

























  











  
  
  	
    	<!--BottomNav Start-->


























  









	<!-- autocomplete scripts --> 
<script type="text/javascript" src="//ajax.googleapis.com/ajax/libs/yui/2.6.0/build/utilities/utilities.js"></script> 
<script type="text/javascript" src="//ajax.googleapis.com/ajax/libs/yui/2.6.0/build/datasource/datasource-min.js"></script> 
<script type="text/javascript" src="//ajax.googleapis.com/ajax/libs/yui/2.6.0/build/autocomplete/autocomplete-min.js"></script> 
<script type="text/javascript" src="//content.atomz.com/sp10049ed9/publish/autocomplete_data.js?sp_js_cache_ver=14"></script>










	

	

	

	






	



	<!-- ncs 3141 071014 --><table border="0" cellspacing="0" cellpadding="0" class="emailSignUpTable">
  <tr>
    <td style="width:516px;">
    
    </td>

    <td>
    
    </td>

    <td style="text-align:right">
      <ul class="utility">
        <li><a class="twitter" href="http://twitter.com/oreillymedia" target="_blank"><span class="hidden">Twitter</span></a></li>
        <li><a class="youtube" href="http://youtube.com/oreillymedia" target="_blank"><span class="hidden">YouTube</span></a></li>
        <li><a class="slideshare" href="http://slideshare.net/oreillymedia" target="_blank"><span class="hidden">Slideshare</span></a></li>
        <li><a class="facebook" href="http://www.facebook.com/OReilly" target="_blank"><span class="hidden">Facebook</span></a></li>
        <li><a class="googleplus" href="https://plus.google.com/108442503368488643007?prsrc=3"><span class="hidden">Google Plus</span></a></li>
        <li><a class="rss" href="http://feeds.feedburner.com/oreilly/all" target="_blank"><span class="hidden">RSS</span></a></li>
        <li><a class="all-rss" href="http://oreilly.com/feeds/">View All RSS Feeds &gt;</a></li>
      </ul>
    </td>
  </tr>
</table>





<div id="multiColumnFooter">

	<div id="footer-branding">
		<p class="copyright">&copy; 2016, O'Reilly Media, Inc.</p>
<p><span class="phone-number">(707) 827-7019</span><span class="phone-number">(800) 889-8969</span></p>
<p class="trademarks">All trademarks and registered trademarks appearing on oreilly.com are the property of their respective owners.</p><!-- 2013 -->

	</div>

	
	<div class="contentSectionBlock">
		
			
				

				<!-- style="width:25%;" -->

				<div class="contentSectionContainer" >
					<span id="footerColumn-1" class="contentSection">
						<h3>About O'Reilly</h3>
						<ul>
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://oreilly.com/academic/">Academic Solutions</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://oreilly.com/jobs/">Jobs</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://oreilly.com/contact.html">Contacts</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://oreilly.com/about/">Corporate Information</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://press.oreilly.com/index.html">Press Room</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://oreilly.com/oreilly/privacy.csp">Privacy Policy</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://oreilly.com/terms/">Terms of Service</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://oreilly.com/oreilly/author/intro.csp">Writing for O'Reilly</a></li>
									
									
								
							
						
						</ul>
					</span>
				</div>
			
		
			
				

				<!-- style="width:25%;" -->

				<div class="contentSectionContainer" >
					<span id="footerColumn-2" class="contentSection">
						<h3>Community</h3>
						<ul>
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://oreilly.com/authors/">Authors</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://oreilly.com/community/">Community & Featured Users</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://forums.oreilly.com/">Forums</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="https://members.oreilly.com/">Membership</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://elists.oreilly.com/">Newsletters</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://answers.oreilly.com/">O'Reilly Answers</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://oreilly.com/feeds/">RSS Feeds</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://ug.oreilly.com/">User Groups</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://chimera.labs.oreilly.com/">O'Reilly Chimera (beta)</a></li>
									
									
								
							
						
						</ul>
					</span>
				</div>
			
		
			
				

				<!-- style="width:25%;" -->

				<div class="contentSectionContainer" >
					<span id="footerColumn-3" class="contentSection">
						<h3>Partner Sites</h3>
						<ul>
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://makezine.com/">makezine.com</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://makerfaire.com/">makerfaire.com</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://craftzine.com/">craftzine.com</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://www.ignitetalks.io/">Ignite Talks</a></li>
									
									
								
							
						
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://blogs.forbes.com/oreillymedia/">O'Reilly Insights on Forbes.com</a></li>
									
									
								
							
						
							
						
							
						
						</ul>
					</span>
				</div>
			
		
			
				

				<!-- style="width:24%;" -->

				<div class="contentSectionContainer" >
					<span id="footerColumn-4" class="contentSection">
						<h3>Shop O'Reilly</h3>
						<ul>
						
							
								
								
								
									
									
									
								<li><a class="footer" href="/category/customer-service.do">Customer Service</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="/category/customer-service.do">Contact Us</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="/category/customer-service/shipping-information.do">Shipping Information</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="/category/customer-service/ordering-payment.do">Ordering & Payment</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="http://oreilly.com/affiliates/">Affiliate Program</a></li>
									
									
								
							
						
							
								
								
								
									
									
									
								<li><a class="footer" href="/category/customer-service/oreilly-guarantee.do">The O'Reilly Guarantee</a></li>
									
									
								
							
						
							
						
							
						
							
						
						</ul>
					</span>
				</div>
			
		
		<div style="clear:both;"></div>
	</div>

	
	

	
	
</div>
<!--BottomNav End-->


    
  

  
  

  
  
  
  
  


</td>
  </tr>
</table>


  

























  










      

























  







<!-- Omniture Reporting Support -->
<!-- SiteCatalyst code version: H.20.3.
Copyright 1997-2009 Omniture, Inc. More info available at
http://www.omniture.com -->

<script language="JavaScript">
function getId() {
  return "ororeilly,orglobal"
}
function getSerializationID() {
  return "1921446"
}
</script>
<script language="JavaScript" type="text/javascript" src="/text/omniture/js/s_code.js"></script>
<script language="JavaScript" type="text/javascript" src="/omniture/parseOmnitureJSON.js"></script>
<script language="JavaScript" type="text/javascript"><!--



    var oOmnitureJSON = {"eVar4":"Product Detail","eVar5":"Product Detail","pageName":"oreilly:store:learning tensorflow","eVar3":"Product Detail","eVar8":"DEAL","prop2":"oreilly:store:product detail","prop1":"oreilly:store","eVar6":"Product Detail","events":{"prodView":null,"event3":null,"event18":null},"prop5":"learning tensorflow","prop6":"0636920063698","prop3":"oreilly:store:product detail:product detail","prop4":"product detail","products":[{"eVars":{},"pricePerUnit":null,"subTotal":null,"events":{},"name":"Learning TensorFlow","quantity":null,"code":"0636920063698.IP"}],"channel":"oreilly"};

    parseOmnitureJSON(oOmnitureJSON);

/************* DO NOT ALTER ANYTHING BELOW THIS LINE ! **************/
var s_code=s.t();if(s_code)document.write(s_code)//--></script>
<script language="JavaScript" type="text/javascript"><!--
if(navigator.appVersion.indexOf('MSIE')>=0)document.write(unescape('%3C')+'\!-'+'-')
//--></script><noscript><a href="http://www.omniture.com" title="Web Analytics"><img
src="http://ororeilly,orglobal.122.2O7.net/b/ss/ororeilly,orglobal/1/H.20.3--NS/0"
height="1" width="1" border="0" alt="" /></a></noscript><!--/DO NOT REMOVE/-->
<!-- End SiteCatalyst code version: H.20.3. -->
<!-- End, Omniture Reporting Support -->




      

























  







<!-- Google Analytics Reporting Support -->
<!-- Google Analytics More info available at http://www.google.com/analytics/index.html -->
<script language="JavaScript" type="text/javascript" src="/googleanalytics/parseGoogleAnalyticsJSON.js"></script>
<script type="text/javascript"> 
var _gaq = _gaq || []; 
_gaq.push(['_setAccount', 'UA-4591498-1']); 
_gaq.push(['_setDomainName', 'oreilly.com']); 
_gaq.push(['_addIgnoredRef', 'oreilly.com']); 
_gaq.push(['_trackPageview']); 

  
    
  
  (function() { 
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true; 
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js'; 
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s); 
  })(); 

</script> 
<!-- End, Google Analytics Reporting Support -->




 <script type="text/javascript">
var _sf_async_config={uid:1632,domain:"shop.oreilly.com"};
(function(){
  function loadChartbeat() {
    window._sf_endpt=(new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src',
       (("https:" == document.location.protocol) ? "https://a248.e.akamai.net/chartbeat.download.akamai.com/102508/" : "http://static.chartbeat.com/") +
       "js/chartbeat.js");
    document.body.appendChild(e);
  }
  var oldonload = window.onload;
  window.onload = (typeof window.onload != 'function') ?
     loadChartbeat : function() { oldonload(); loadChartbeat(); };
})();

</script> 

<!-- crazyegg -->
<script type="text/javascript">
setTimeout(function(){var a=document.createElement("script"); var b=document.getElementsByTagName("script")[0]; a.src=document.location.protocol+"//dnn506yrbagrg.cloudfront.net/pages/scripts/0011/6381.js?"+Math.floor(new Date().getTime()/3600000); a.async=true;a.type="text/javascript";b.parentNode.insertBefore(a,b)}, 1);
</script>








</body>
<script type="text/javascript" src="/includes/footerScripts.js"></script>
<!-- MyBuys Page Initialization Place after </body> tag -->
<script type="text/javascript">
  mybuys.initPage();
</script>
<!-- End MyBuys Page Initialization -->
</html>